]> git.pld-linux.org Git - SPECS.git/blob - jquery-mousewheel.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / jquery-mousewheel.spec
1 # TODO
2 # - paths and deps for demo
3 %define         plugin  mousewheel
4 Summary:        jQuery Mouse Wheel Plugin
5 Name:           jquery-%{plugin}
6 Version:        3.0.6
7 Release:        1
8 License:        MIT
9 Group:          Applications/WWW
10 Source0:        https://github.com/downloads/brandonaaron/jquery-mousewheel/jquery-mousewheel-%{version}.zip
11 # Source0-md5:  3b4c993af810fa82b8e0a1a206ce0952
12 URL:            https://github.com/brandonaaron/jquery-mousewheel
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 BuildRequires:  unzip
15 Requires:       jquery >= 1.2
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _appdir %{_datadir}/jquery/%{plugin}
20
21 %description
22 A jQuery plugin that adds cross-browser mouse wheel support.
23
24 In order to use the plugin, simply bind the "mousewheel" event to an
25 element. It also provides two helper methods called mousewheel and
26 unmousewheel that act just like other event helper methods in jQuery.
27 The event callback receives three extra arguments which are the
28 normalized "deltas" of the mouse wheel.
29
30 %package demo
31 Summary:        Demo for jQuery.%{plugin}
32 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.%{plugin}
33 Group:          Development
34 Requires:       %{name} = %{version}-%{release}
35
36 %description demo
37 Demonstrations and samples for jQuery.%{plugin}.
38
39 %prep
40 %setup -q
41
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_appdir}
46 cp -p jquery.%{plugin}.min.js  $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
47 cp -p jquery.%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
48 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{_appdir}
59
60 %files demo
61 %defattr(644,root,root,755)
62 %{_examplesdir}/%{name}-%{version}
This page took 2.113007 seconds and 3 git commands to generate.