]> git.pld-linux.org Git - SPECS.git/blob - jquery-checkbox.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / jquery-checkbox.spec
1 # TODO
2 # - paths and deps for demo
3 %define         plugin  checkbox
4 Summary:        jQuery custom CSS styled checkboxes (and radio buttons, too)
5 Name:           jquery-%{plugin}
6 Version:        1.3.0
7 Release:        0.beta1.1
8 License:        MIT
9 Group:          Applications/WWW
10 Source0:        https://jquery-checkbox.googlecode.com/files/jquery-checkbox.%{version}b1.zip
11 # Source0-md5:  3b4c993af810fa82b8e0a1a206ce0952
12 URL:            https://code.google.com/p/jquery-checkbox/
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 BuildRequires:  unzip
15 BuildRequires:  yuicompressor
16 Requires:       jquery >= 1.2
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _appdir %{_datadir}/jquery/%{plugin}
21
22 %description
23 A replacement for the standard checkbox that allows you to change the
24 look of checkbox elements in your page.
25
26 Features:
27 - only inline elements used, just like default checkoxes
28 - cross-browser look and feel (tested in IE6, IE7, IE8, Firefox and
29   Chrome engines)
30 - work with radio buttons too
31 - supports inline and jQuery attached click events
32 - supports "label hovering": when you point over parent label element,
33   it will highlight its checkbox (thanks to Eugene for the idea)
34 - dynamic skin changing
35 - adds new checkbox events "check", "uncheck", "disable", "enable",
36   ready to use in jQuery.bind() method
37
38 %package demo
39 Summary:        Demo for jQuery.checkbox
40 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.checkbox
41 Group:          Development
42 URL:            http://widowmaker.kiev.ua/checkbox/
43 Requires:       %{name} = %{version}-%{release}
44
45 %description demo
46 Demonstrations and samples for jQuery.checkbox.
47
48 %prep
49 %setup -qc
50
51 %build
52 install -d build
53
54 # pack .css
55 for css in *.css; do
56         out=build/${css#*/jquery.}
57 %if 0%{!?debug:1}
58         yuicompressor --charset UTF-8 $css -o $out
59 %else
60         cp -p $css $out
61 %endif
62 done
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_appdir}
67 cp -p jquery.%{plugin}.min.js  $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
68 cp -p jquery.%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
69 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
70
71 cp -p build/jquery.%{plugin}.css $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.css
72 cp -p jquery.%{plugin}.css $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.css
73 ln -s %{plugin}-%{version}.min.css $RPM_BUILD_ROOT%{_appdir}/%{plugin}.css
74 cp -p build/jquery.safari-%{plugin}.css $RPM_BUILD_ROOT%{_appdir}/safari-%{plugin}-%{version}.min.css
75 cp -p jquery.safari-%{plugin}.css $RPM_BUILD_ROOT%{_appdir}/safari-%{plugin}-%{version}.css
76 ln -s safari-%{plugin}-%{version}.min.css $RPM_BUILD_ROOT%{_appdir}/safari-%{plugin}.css
77
78 cp -p checkbox.png empty.png safari-checkbox.png $RPM_BUILD_ROOT%{_appdir}
79
80 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81 cp -p index.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82 cp -p screenshot.png $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %{_appdir}
90
91 %files demo
92 %defattr(644,root,root,755)
93 %{_examplesdir}/%{name}-%{version}
This page took 0.361535 seconds and 3 git commands to generate.