]> git.pld-linux.org Git - SPECS.git/blob - jquery-birthdaypicker.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / jquery-birthdaypicker.spec
1 %define         plugin  birthdaypicker
2 Summary:        Attempts to mimic the functionality of the birthday select lists on the Facebook signup page
3 Name:           jquery-%{plugin}
4 Version:        1.4
5 Release:        1
6 License:        MIT/GPL
7 Group:          Applications/WWW
8 Source0:        https://github.com/abecoffman/birthdaypicker/archive/834bca8/%{plugin}-%{version}.tar.gz
9 # Source0-md5:  884c18cac5f36a26be0c7621e92ea071
10 URL:            https://github.com/abecoffman/birthdaypicker
11 Requires:       jquery
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _appdir %{_datadir}/jquery/%{plugin}
16
17 %description
18 The birthday picker seeks to emulate the functionality of the birthday
19 picker on the Facebook signup page. It uses three select boxes to
20 choose a date, and tries to ensure that the date is valid by
21 accounting for leap years, etc...
22
23 It also has a number of options, making it somewhat customizable. The
24 birthday picker generates the following markup:
25
26 %package demo
27 Summary:        Demo for jQuery.%{plugin}
28 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu jQuery.%{plugin}
29 Group:          Development
30 Requires:       %{name} = %{version}-%{release}
31
32 %description demo
33 Demonstrations and samples for jQuery.%{plugin}.
34
35 %prep
36 %setup -qc
37 mv birthdaypicker-*/* .
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
42
43 cp -p bday-picker.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
44 cp -p bday-picker.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
45 ln -s %{plugin}-%{version}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
46 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
47 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.min.js
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README.md
55 %{_appdir}
This page took 0.653423 seconds and 3 git commands to generate.