]> git.pld-linux.org Git - SPECS.git/blob - jquery-agility.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / jquery-agility.spec
1 %define         plugin  agility
2 Summary:        Agility.js JavaScript MVC library
3 Name:           jquery-%{plugin}
4 Version:        0.1.3
5 Release:        1
6 License:        MIT
7 Group:          Applications/WWW
8 Source0:        https://github.com/arturadib/agility/tarball/%{version}/%{plugin}-%{version}.tgz
9 # Source0-md5:  83e400b740f711b4e835d16bab33a024
10 URL:            http://agilityjs.com/
11 Requires:       jquery >= 1.6
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _appdir %{_datadir}/jquery/%{plugin}
16
17 %description
18 Agility.js is an MVC library for JavaScript that lets you write
19 maintainable and reusable browser code without the verbose or
20 infrastructural overhead found in other MVC libraries. The goal is to
21 enable developers to write web apps at least as quickly as with
22 jQuery, while simplifying long-term maintainability through MVC
23 objects.
24
25 %prep
26 %setup -qc
27 mv *-%{plugin}-*/* .
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
32
33 cp -p docs/%{plugin}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
34 cp -p %{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.js
35 ln -s %{plugin}-%{version}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
36 ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc README.md LICENSE ChangeLog
44 %{_appdir}
This page took 0.128848 seconds and 3 git commands to generate.