]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- massive attack: source-md5
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 # _with_mmx     - MMX optimization
4 # Optimization must be chosen at compile time :(
5 # Maybe some patch...? But not yet.
6 #
7 Summary:        Password cracker
8 Summary(pl):    £amacz hase³
9 Name:           john
10 Version:        1.6
11 Release:        6
12 License:        GPL
13 Group:          Applications/System
14 Source0:        http://www.openwall.com/john/%{name}-%{version}.tar.gz
15 # Source0-md5:  aae782f160041b2bdc624b0a84054e32
16 Patch0:         %{name}-%{version}.PLD.diff
17 Patch1:         %{name}-%{version}.ini.diff
18 Patch2:         %{name}-%{version}.makefile.diff
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 John the Ripper is a password cracker, currently available for UNIX,
23 DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
24 passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
25 OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
26 IRIX.
27
28 %description -l pl
29 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
30 DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
31 hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
32 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
33
34 %prep
35 %setup -q
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39
40 %build
41 cd src
42 COPT="%{rpmcflags}"
43
44 # bleh... MMX code must be chosen at compile time :(
45 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
46 # K6 optimization exists only in Makefile
47 %ifarch %{ix86}
48         %if %{?_with_mmx:1}%{!?_with_mmx:0}
49                 TARG=linux-x86-mmx-elf
50         %else
51                 TARG=linux-x86-any-elf
52         %endif
53 %else
54         %ifarch alpha
55                 TARG=linux-alpha
56         %else
57                 %ifarch sparc sparc64
58                         TARG=linux-sparc
59                 %else
60                         TARG=generic
61                 %endif
62         %endif
63 %endif
64
65 %{__make} OPT="$COPT" CC="%{__cc}" $TARG
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
70 install run/{*.chr,john.ini} $RPM_BUILD_ROOT%{_libdir}/john
71 install run/john $RPM_BUILD_ROOT%{_bindir}
72 rm -f doc/INSTALL
73
74 cd $RPM_BUILD_ROOT%{_bindir}
75 ln -sf john unafs
76 ln -sf john unique
77 ln -sf john unshadow
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc doc/* run/mailer
85 %attr(755,root,root) %{_bindir}/*
86 %{_libdir}/john
This page took 0.109455 seconds and 4 git commands to generate.