]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- use tomcat uid/gid
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - repackage .war with system jars?
3 %include        /usr/lib/rpm/macros.java
4 Summary:        Hudson Continuous Build Server
5 Name:           hudson
6 Version:        1.278
7 Release:        0.1
8 License:        MIT License
9 Group:          Development/Languages/Java
10 Source0:        https://hudson.dev.java.net/files/documents/2402/124475/%{name}.war
11 # Source0-md5:  223788eb7fd27ba970daf8e06053f356
12 Source1:        %{name}-web.xml
13 Source2:        %{name}-context.xml
14 URL:            https://hudson.dev.java.net/
15 BuildRequires:  jpackage-utils
16 BuildRequires:  rpm-javaprov
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 Requires:       apache-tomcat
19 Requires:       jpackage-utils
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Hudson monitors executions of repeated jobs, such as building a
25 software project or jobs run by cron.
26
27 Among those things, current Hudson focuses on the following two jobs:
28 - Building/testing software projects continuously, just like
29   CruiseControl or DamageControl. In a nutshell, Hudson provides an
30   easy-to-use so-called continuous integration system, making it easier
31   for developers to integrate changes to the project, and making it
32   easier for users to obtain a fresh build. The automated, continoues
33   build increases the productivity.
34 - Monitoring executions of externally-run jobs, such as cron jobs and
35   procmail jobs, even those that are run on a remote machine. For
36   example, with cron, all you receive is regular e-mails that capture
37   the output, and it is up to you to look at them diligently and notice
38   when it broke. Hudson keeps those outputs and makes it easy for you to
39   notice when something is wrong.
40
41 %prep
42 %setup -qc
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hudson,%{_datadir}/tomcat/webapps/hudson,%{_sharedstatedir}/{hudson,tomcat/conf/Catalina/localhost}}
47 install %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/hudson/web.xml
48 install %SOURCE2 $RPM_BUILD_ROOT%{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
49 cp -a . $RPM_BUILD_ROOT%{_datadir}/tomcat/webapps/hudson
50 ln -sf %{_sysconfdir}/hudson/web.xml $RPM_BUILD_ROOT%{_datadir}/tomcat/webapps/hudson/WEB-INF/web.xml
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %dir %{_sysconfdir}/hudson
58 %config(noreplace) %{_sysconfdir}/hudson/web.xml
59 # do not make this file writeable by tomcat. We do not want to allow user to
60 # undeploy this app via tomcat manager.
61 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
62 %{_datadir}/tomcat/webapps/hudson
63 %attr(755,tomcat,tomcat) %dir %{_sharedstatedir}/hudson
This page took 0.044105 seconds and 4 git commands to generate.