]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- require apache-tomcat version that uses tomcat uid/gid
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - repackage .war with system jars?
3 %include        /usr/lib/rpm/macros.java
4 Summary:        Hudson Continuous Build Server
5 Name:           hudson
6 Version:        1.278
7 Release:        0.1
8 License:        MIT License
9 Group:          Development/Languages/Java
10 Source0:        https://hudson.dev.java.net/files/documents/2402/124475/%{name}.war
11 # Source0-md5:  223788eb7fd27ba970daf8e06053f356
12 Source1:        %{name}-web.xml
13 Source2:        %{name}-context.xml
14 URL:            https://hudson.dev.java.net/
15 BuildRequires:  jpackage-utils
16 BuildRequires:  rpm-javaprov
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 # Require version that uses tomcat uid/gid
19 Requires:       apache-tomcat >= 5.5.27-0.2
20 Requires:       jpackage-utils
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Hudson monitors executions of repeated jobs, such as building a
26 software project or jobs run by cron.
27
28 Among those things, current Hudson focuses on the following two jobs:
29 - Building/testing software projects continuously, just like
30   CruiseControl or DamageControl. In a nutshell, Hudson provides an
31   easy-to-use so-called continuous integration system, making it easier
32   for developers to integrate changes to the project, and making it
33   easier for users to obtain a fresh build. The automated, continoues
34   build increases the productivity.
35 - Monitoring executions of externally-run jobs, such as cron jobs and
36   procmail jobs, even those that are run on a remote machine. For
37   example, with cron, all you receive is regular e-mails that capture
38   the output, and it is up to you to look at them diligently and notice
39   when it broke. Hudson keeps those outputs and makes it easy for you to
40   notice when something is wrong.
41
42 %prep
43 %setup -qc
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hudson,%{_datadir}/tomcat/webapps/hudson,%{_sharedstatedir}/{hudson,tomcat/conf/Catalina/localhost}}
48 install %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/hudson/web.xml
49 install %SOURCE2 $RPM_BUILD_ROOT%{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
50 cp -a . $RPM_BUILD_ROOT%{_datadir}/tomcat/webapps/hudson
51 ln -sf %{_sysconfdir}/hudson/web.xml $RPM_BUILD_ROOT%{_datadir}/tomcat/webapps/hudson/WEB-INF/web.xml
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %dir %{_sysconfdir}/hudson
59 %config(noreplace) %{_sysconfdir}/hudson/web.xml
60 # do not make this file writeable by tomcat. We do not want to allow user to
61 # undeploy this app via tomcat manager.
62 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
63 %{_datadir}/tomcat/webapps/hudson
64 %attr(755,tomcat,tomcat) %dir %{_sharedstatedir}/hudson
This page took 0.037025 seconds and 4 git commands to generate.