]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- oss project renamed to jenkins on January 11, 2011
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - consider renaming to jenkins http://en.wikipedia.org/wiki/Jenkins_(software)
3 # - build it from sources
4 #   https://hudson.dev.java.net/files/documents/2402/125619/hudson-1.280-src.zip
5 # - use system jars
6 %include        /usr/lib/rpm/macros.java
7 Summary:        Hudson Continuous Build Server
8 Name:           hudson
9 Version:        1.384
10 Release:        1
11 License:        MIT License
12 Group:          Networking/Daemons/Java/Servlets
13 # Check for new releases and URLs here: https://hudson.dev.java.net/servlets/ProjectRSS?type=news
14 Source0:        http://hudson-ci.org/download/war/%{version}/%{name}.war#/%{name}-%{version}.war
15 # Source0-md5:  65d1108eac802c284fdf4633bee3ef92
16 Source1:        %{name}-context.xml
17 Patch0:         %{name}-webxml.patch
18 URL:            https://hudson.dev.java.net/
19 BuildRequires:  jpackage-utils
20 BuildRequires:  rpm-javaprov
21 BuildRequires:  rpmbuild(macros) >= 1.546
22 Requires:       jpackage-utils
23 Requires:       jre-X11
24 Requires:       tomcat
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Hudson monitors executions of repeated jobs, such as building a
30 software project or jobs run by cron.
31
32 Among those things, current Hudson focuses on the following two jobs:
33 - Building/testing software projects continuously, just like
34   CruiseControl or DamageControl. In a nutshell, Hudson provides an
35   easy-to-use so-called continuous integration system, making it easier
36   for developers to integrate changes to the project, and making it
37   easier for users to obtain a fresh build. The automated, continoues
38   build increases the productivity.
39 - Monitoring executions of externally-run jobs, such as cron jobs and
40   procmail jobs, even those that are run on a remote machine. For
41   example, with cron, all you receive is regular e-mails that capture
42   the output, and it is up to you to look at them diligently and notice
43   when it broke. Hudson keeps those outputs and makes it easy for you to
44   notice when something is wrong.
45
46 %prep
47 %setup -qc
48 rm *.class
49 rm winstone.jar
50
51 %patch0 -p1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_datadir}/%{name},%{_sharedstatedir}/%{name},%{_tomcatconfdir}}
56 mv WEB-INF/web.xml $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/web.xml
57 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/tomcat-context.xml
58 ln -sf %{_sysconfdir}/%{name}/tomcat-context.xml $RPM_BUILD_ROOT%{_tomcatconfdir}/%{name}.xml
59 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
60 ln -sf %{_sysconfdir}/%{name}/web.xml $RPM_BUILD_ROOT%{_datadir}/%{name}/WEB-INF/web.xml
61
62 %postun
63 %tomcat_clear_cache %{name}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %dir %{_sysconfdir}/%{name}
71 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.xml
72 %{_tomcatconfdir}/%{name}.xml
73 %{_datadir}/%{name}
74 %attr(2775,root,servlet) %dir %{_sharedstatedir}/%{name}
This page took 0.028786 seconds and 4 git commands to generate.