]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- once again md5. Is it correct now?
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - build it from sources
3 #   https://hudson.dev.java.net/files/documents/2402/125619/hudson-1.280-src.zip
4 %include        /usr/lib/rpm/macros.java
5 Summary:        Hudson Continuous Build Server
6 Name:           hudson
7 Version:        1.280
8 Release:        0.1
9 License:        MIT License
10 Group:          Development/Languages/Java
11 Source0:        https://hudson.dev.java.net/files/documents/2402/125618/%{name}.war
12 # Source0-md5:  d06c166cc478104bdf6d8cdf46ca5baa
13 Source1:        %{name}-web.xml
14 Source2:        %{name}-context.xml
15 URL:            https://hudson.dev.java.net/
16 BuildRequires:  jpackage-utils
17 BuildRequires:  rpm-javaprov
18 BuildRequires:  rpmbuild(macros) >= 1.300
19 # Require version that uses tomcat uid/gid
20 Requires:       apache-tomcat >= 5.5.27-0.2
21 Requires:       jpackage-utils
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Hudson monitors executions of repeated jobs, such as building a
27 software project or jobs run by cron.
28
29 Among those things, current Hudson focuses on the following two jobs:
30 - Building/testing software projects continuously, just like
31   CruiseControl or DamageControl. In a nutshell, Hudson provides an
32   easy-to-use so-called continuous integration system, making it easier
33   for developers to integrate changes to the project, and making it
34   easier for users to obtain a fresh build. The automated, continoues
35   build increases the productivity.
36 - Monitoring executions of externally-run jobs, such as cron jobs and
37   procmail jobs, even those that are run on a remote machine. For
38   example, with cron, all you receive is regular e-mails that capture
39   the output, and it is up to you to look at them diligently and notice
40   when it broke. Hudson keeps those outputs and makes it easy for you to
41   notice when something is wrong.
42
43 %prep
44 %setup -qc
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hudson,%{_datadir}/hudson,%{_sharedstatedir}/{hudson,tomcat/conf/Catalina/localhost}}
49 install %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/hudson/web.xml
50 install %SOURCE2 $RPM_BUILD_ROOT%{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
51 cp -a . $RPM_BUILD_ROOT%{_datadir}/hudson
52 ln -sf %{_sysconfdir}/hudson/web.xml $RPM_BUILD_ROOT%{_datadir}/hudson/WEB-INF/web.xml
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %dir %{_sysconfdir}/hudson
60 %config(noreplace) %{_sysconfdir}/hudson/web.xml
61 # do not make this file writeable by tomcat. We do not want to allow user to
62 # undeploy this app via tomcat manager.
63 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
64 %{_datadir}/hudson
65 %attr(755,tomcat,tomcat) %dir %{_sharedstatedir}/hudson
This page took 0.029887 seconds and 4 git commands to generate.