]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- up to 1.337
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - build it from sources
3 #   https://hudson.dev.java.net/files/documents/2402/125619/hudson-1.280-src.zip
4 # - use system jars
5 %include        /usr/lib/rpm/macros.java
6 Summary:        Hudson Continuous Build Server
7 Name:           hudson
8 Version:        1.337
9 Release:        1
10 License:        MIT License
11 Group:          Networking/Daemons/Java/Servlets
12 # Check for new releases and URLs here: https://hudson.dev.java.net/servlets/ProjectRSS?type=news
13 Source0:        http://dlc.sun.com/hudson/downloads/war/%{version}/%{name}.war
14 # Source0-md5:  bb7b858ff39fca66302a3a89f526a266
15 Source1:        %{name}-web.xml
16 Source2:        %{name}-context.xml
17 URL:            https://hudson.dev.java.net/
18 BuildRequires:  jpackage-utils
19 BuildRequires:  rpm-javaprov
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       group(servlet)
22 Requires:       jpackage-utils
23 Requires:       jre-X11
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Hudson monitors executions of repeated jobs, such as building a
29 software project or jobs run by cron.
30
31 Among those things, current Hudson focuses on the following two jobs:
32 - Building/testing software projects continuously, just like
33   CruiseControl or DamageControl. In a nutshell, Hudson provides an
34   easy-to-use so-called continuous integration system, making it easier
35   for developers to integrate changes to the project, and making it
36   easier for users to obtain a fresh build. The automated, continoues
37   build increases the productivity.
38 - Monitoring executions of externally-run jobs, such as cron jobs and
39   procmail jobs, even those that are run on a remote machine. For
40   example, with cron, all you receive is regular e-mails that capture
41   the output, and it is up to you to look at them diligently and notice
42   when it broke. Hudson keeps those outputs and makes it easy for you to
43   notice when something is wrong.
44
45 %prep
46 %setup -qc
47
48 rm *.class
49 rm winstone.jar
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hudson,%{_datadir}/hudson,%{_sharedstatedir}/{hudson,tomcat/conf/Catalina/localhost}}
54 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/hudson/web.xml
55 install %{SOURCE2} $RPM_BUILD_ROOT%{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
56 cp -a . $RPM_BUILD_ROOT%{_datadir}/hudson
57 ln -sf %{_sysconfdir}/hudson/web.xml $RPM_BUILD_ROOT%{_datadir}/hudson/WEB-INF/web.xml
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %dir %{_sysconfdir}/hudson
65 %config(noreplace) %{_sysconfdir}/hudson/web.xml
66 # do not make this file writeable by tomcat. We do not want to allow user to
67 # undeploy this app via tomcat manager.
68 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
69 %{_datadir}/hudson
70 %attr(2775,root,servlet) %dir %{_sharedstatedir}/hudson
This page took 0.033296 seconds and 4 git commands to generate.