]> git.pld-linux.org Git - SPECS.git/blob - java-jts.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / java-jts.spec
1 %define         srcname         jts
2 Summary:        JTS Topology Suite
3 Name:           java-%{srcname}
4 Version:        1.12
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Libraries/Java
8 Source0:        http://downloads.sourceforge.net/jts-topo-suite/jts-%{version}.zip
9 # Source0-md5:  88c9842c28b09ef4d5333a3057f4bb76
10 Source1:        build.xml
11 URL:            http://tsusiatsoftware.net/jts/main.html
12 BuildRequires:  ant
13 BuildRequires:  jpackage-utils
14 BuildRequires:  jre
15 BuildRequires:  rpm-javaprov
16 BuildRequires:  rpmbuild(macros) >= 1.300
17 BuildRequires:  unzip
18 Requires:       java-jdom
19 Requires:       java-xerces
20 Requires:       jpackage-utils
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 JTS is a java library which provides:
26 - an implementation of the spatial data model defined in the OGC
27   Simple Features Specification for SQL (SFS)
28 - a complete, consistent, implementation of fundamental 2D spatial
29   algorithms
30 - an explicit precision model, with algorithms that gracefully handle
31   situations that result in dimensional collapse
32 - robust implementations of key computational geometric operations
33 - I/O in Well-Known Text format
34
35 %prep
36 %setup -qc
37 cp -p %{SOURCE1} .
38
39 %build
40 %ant -Dbasedir=.
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 # jars
46 install -d $RPM_BUILD_ROOT%{_javadir}
47 cp -p target/%{srcname}.jar $RPM_BUILD_ROOT%{_javadir}/%{srcname}-%{version}.jar
48 ln -s %{srcname}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{srcname}.jar
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{_javadir}/%{srcname}-%{version}.jar
56 %{_javadir}/%{srcname}.jar
This page took 1.614959 seconds and 3 git commands to generate.