]> git.pld-linux.org Git - SPECS.git/blob - jamvm.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / jamvm.spec
1 Summary:        A small Java Virtual Machine
2 Summary(pl.UTF-8):      Mała maszyna wirtualna Javy (JVM)
3 Name:           jamvm
4 Version:        1.5.1
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/System
8 Source0:        http://dl.sourceforge.net/jamvm/%{name}-%{version}.tar.gz
9 # Source0-md5:  5a82751b50391eb092c906ce64f3b6bf
10 Patch0:         %{name}-libdir.patch
11 Patch1:         %{name}-i786.patch
12 URL:            http://jamvm.sourceforge.net/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 %ifarch %{x8664} hppa
16 BuildRequires:  libffi-devel
17 %endif
18 BuildRequires:  libtool
19 BuildRequires:  unzip
20 BuildRequires:  zlib-devel
21 Requires:       classpath >= 0.19
22 ExclusiveArch:  %{ix86} %{x8664} arm hppa mipsel ppc
23 ExcludeArch:    i386
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 JamVM is a new Java Virtual Machine which conforms to the JVM
28 specification version 2 (blue book).  In comparison to most other
29 VM's (free and commercial) it is extremely small, with a stripped
30 executable on PowerPC of only ~110K, and Intel 80K.  However, unlike
31 other small VMs (e.g. KVM) it is designed to support the full
32 specification, and includes support for object finalisation, the
33 Java Native Interface (JNI) and the Reflection API.
34
35 %description -l pl.UTF-8
36 JamVM jest nową maszyną wirtualną Javy (JVM) zgodną z 2 wersją
37 specyfikacji JVM (niebieska księga). W porównaniu do większości innych
38 VM (darmowych i komercyjnych) jest ekstremalnie mała, plik wykonywalny
39 zajmuje na PowerPC jedynie ~110 kB, na Intelu 80 kB. Tym niemniej, w
40 odróżnieniu od innych małych VM (np. KVM) jest zaprojektowana, aby
41 obsługiwać pełną specyfikację, włączając w to finalizację obiektów,
42 Java Native Interface i Reflection API.
43
44 %package devel
45 Summary:        JNI development header file
46 Summary(pl.UTF-8):      Plik nagłówkowy dla JNI
47 Group:          Development/Languages/Java
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Java Native Interface development header file.
52
53 %description devel -l pl.UTF-8
54 Plik nagłówkowy dla Java Native Interface.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65
66 %configure \
67         %{?debug:--enable-trace} \
68         --with-classpath_install_dir=%{_prefix}
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -D src/jni.h $RPM_BUILD_ROOT%{_includedir}/jni.h
79
80 # unwanted symlink
81 rm $RPM_BUILD_ROOT%{_libdir}/rt.jar
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc ACKNOWLEDGEMENTS AUTHORS NEWS README
89 %attr(755,root,root) %{_bindir}/jamvm
90 %attr(755,root,root) %{_libdir}/libjvm.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libjvm.so.0
92 %{_datadir}/%{name}
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libjvm.so
97 %{_libdir}/libjvm.la
98 %{_includedir}/jni.h
This page took 0.153881 seconds and 3 git commands to generate.