]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
- updated to 0.12.0 (new soname, API 0.12)
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.12.0
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0Download: https://gitlab.com/ixion/ixion
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
14 # Source0-md5:  427da1c197c6d7eab954f88b5be0a952
15 Patch0:         %{name}-flags.patch
16 URL:            https://gitlab.com/ixion/ixion
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  mdds-devel >= 1.2.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  python3 >= 1:3.4
25 BuildRequires:  python3-devel >= 1:3.4
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # __once_call, __once_callable non-function symbols
31 %define         skip_post_check_so      libixion-0.12.so.*
32
33 %description
34 Ixion aims to provide a library for calculating the results of formula
35 expressions stored in multiple named targets, or "cells". The cells
36 can be referenced from each other, and the library takes care of
37 resolving their dependencies automatically upon calculation. The
38 caller can run the calculation routine either in a single-threaded
39 mode, or a multi-threaded mode. The library also supports
40 re-calculation where the contents of one or more cells have been
41 modified since the last calculation, and a partial calculation of only
42 the affected cells gets performed. It is written entirely in C++, and
43 makes extensive use of the boost library to achieve portability across
44 different platforms.
45
46 %description -l pl.UTF-8
47 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
48 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
49 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
50 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
51 obliczeniach. Procedura obliczająca może być wywołana w trybie
52 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
53 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
54 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
55 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
56 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
57 przenośność na wiele platform.
58
59 %package devel
60 Summary:        Development files for ixion
61 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       boost-devel >= 1.36
65 Requires:       libstdc++-devel
66 Requires:       mdds-devel >= 1.2.0
67
68 %description devel
69 This package contains the header files for developing applications
70 that use ixion.
71
72 %description devel -l pl.UTF-8
73 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
74 ixion.
75
76 %package static
77 Summary:        Static ixion library
78 Summary(pl.UTF-8):      Statyczna biblioteka ixion
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static ixion library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka ixion.
87
88 %package -n python3-ixion
89 Summary:        Python 3 interface to ixion library
90 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki ixion
91 Group:          Libraries/Python
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       python3-libs >= 1:3.4
94 # python 2 is no longer supported
95 Obsoletes:      python-ixion
96
97 %description -n python3-ixion
98 Python 3 interface to ixion library.
99
100 %description -n python3-ixion -l pl.UTF-8
101 Interfejs Pythona 3 do biblioteki ixion.
102
103 %prep
104 %setup -q -n libixion-%{version}
105 %patch0 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         --disable-silent-rules \
114         %{?with_static_libs:--enable-static}
115
116 %{__make}
117
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.la
125 %if %{with static_libs}
126 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.a
127 %endif
128 # obsoleted by pkg-config
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS LICENSE README
140 %attr(755,root,root) %{_bindir}/ixion-parser
141 %attr(755,root,root) %{_bindir}/ixion-sorter
142 %attr(755,root,root) %{_libdir}/libixion-0.12.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libixion-0.12.so.0
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libixion-0.12.so
148 %{_includedir}/libixion-0.12
149 %{_pkgconfigdir}/libixion-0.12.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libixion-0.12.a
155 %endif
156
157 %files -n python3-ixion
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py3_sitedir}/ixion.so
This page took 0.060396 seconds and 4 git commands to generate.