]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
try mdds-1.0 pkg-config
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.9.1
9 Release:        8
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://gitlab.com/ixion/ixion
13 Source0:        http://kohei.us/files/ixion/src/lib%{name}-%{version}.tar.xz
14 # Source0-md5:  d292f6d62847f2305178459390842eac
15 Patch0:         mdds-1.0.patch
16 URL:            https://gitlab.com/ixion/ixion
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  mdds-devel >= 1.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  python >= 1:2.7.0
25 BuildRequires:  python-modules
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Ixion aims to provide a library for calculating the results of formula
32 expressions stored in multiple named targets, or "cells". The cells
33 can be referenced from each other, and the library takes care of
34 resolving their dependencies automatically upon calculation. The
35 caller can run the calculation routine either in a single-threaded
36 mode, or a multi-threaded mode. The library also supports
37 re-calculation where the contents of one or more cells have been
38 modified since the last calculation, and a partial calculation of only
39 the affected cells gets performed. It is written entirely in C++, and
40 makes extensive use of the boost library to achieve portability across
41 different platforms.
42
43 %description -l pl.UTF-8
44 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
45 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
46 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
47 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
48 obliczeniach. Procedura obliczająca może być wywołana w trybie
49 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
50 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
51 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
52 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
53 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
54 przenośność na wiele platform.
55
56 %package devel
57 Summary:        Development files for ixion
58 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       boost-devel >= 1.36
62 Requires:       libstdc++-devel
63 Requires:       mdds-devel >= 0.12.0
64
65 %description devel
66 This package contains the header files for developing applications
67 that use ixion.
68
69 %description devel -l pl.UTF-8
70 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
71 ixion.
72
73 %package static
74 Summary:        Static ixion library
75 Summary(pl.UTF-8):      Statyczna biblioteka ixion
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static ixion library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka ixion.
84
85 %package -n python-ixion
86 Summary:        Python interface to ixion library
87 Summary(pl.UTF-8):      Interfejs Pythona do biblioteki ixion
88 Group:          Libraries/Python
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n python-ixion
92 Python interface to ixion library.
93
94 %description -n python-ixion -l pl.UTF-8
95 Interfejs Pythona do biblioteki ixion.
96
97 %prep
98 %setup -q -n lib%{name}-%{version}
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__automake}
106 %configure \
107         --disable-silent-rules \
108         %{?with_static_libs:--enable-static}
109
110 %{__make}
111
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.la
119 %if %{with static_libs}
120 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.a
121 %endif
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS COPYING README
134 %attr(755,root,root) %{_bindir}/ixion-parser
135 %attr(755,root,root) %{_bindir}/ixion-sorter
136 %attr(755,root,root) %{_libdir}/libixion-0.10.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libixion-0.10.so.0
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libixion-0.10.so
142 %{_includedir}/libixion-0.10
143 %{_pkgconfigdir}/libixion-0.10.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libixion-0.10.a
149 %endif
150
151 %files -n python-ixion
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{py_sitedir}/ixion.so
This page took 0.056684 seconds and 4 git commands to generate.