]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
update BR
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.9.1
9 Release:        7
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://gitlab.com/ixion/ixion
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
14 # Source0-md5:  d292f6d62847f2305178459390842eac
15 URL:            https://gitlab.com/ixion/ixion
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.36
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  mdds-devel >= 0.12.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  python >= 1:2.7.0
24 BuildRequires:  python-modules
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Ixion aims to provide a library for calculating the results of formula
31 expressions stored in multiple named targets, or "cells". The cells
32 can be referenced from each other, and the library takes care of
33 resolving their dependencies automatically upon calculation. The
34 caller can run the calculation routine either in a single-threaded
35 mode, or a multi-threaded mode. The library also supports
36 re-calculation where the contents of one or more cells have been
37 modified since the last calculation, and a partial calculation of only
38 the affected cells gets performed. It is written entirely in C++, and
39 makes extensive use of the boost library to achieve portability across
40 different platforms.
41
42 %description -l pl.UTF-8
43 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
44 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
45 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
46 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
47 obliczeniach. Procedura obliczająca może być wywołana w trybie
48 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
49 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
50 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
51 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
52 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
53 przenośność na wiele platform.
54
55 %package devel
56 Summary:        Development files for ixion
57 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       boost-devel >= 1.36
61 Requires:       libstdc++-devel
62 Requires:       mdds-devel >= 0.12.0
63
64 %description devel
65 This package contains the header files for developing applications
66 that use ixion.
67
68 %description devel -l pl.UTF-8
69 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
70 ixion.
71
72 %package static
73 Summary:        Static ixion library
74 Summary(pl.UTF-8):      Statyczna biblioteka ixion
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static ixion library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka ixion.
83
84 %package -n python-ixion
85 Summary:        Python interface to ixion library
86 Summary(pl.UTF-8):      Interfejs Pythona do biblioteki ixion
87 Group:          Libraries/Python
88 Requires:       %{name} = %{version}-%{release}
89
90 %description -n python-ixion
91 Python interface to ixion library.
92
93 %description -n python-ixion -l pl.UTF-8
94 Interfejs Pythona do biblioteki ixion.
95
96 %prep
97 %setup -q -n libixion-%{version}
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__automake}
104 %configure \
105         --disable-silent-rules \
106         %{?with_static_libs:--enable-static}
107
108 %{__make}
109
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.la
117 %if %{with static_libs}
118 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.a
119 %endif
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS COPYING README
132 %attr(755,root,root) %{_bindir}/ixion-parser
133 %attr(755,root,root) %{_bindir}/ixion-sorter
134 %attr(755,root,root) %{_libdir}/libixion-0.10.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libixion-0.10.so.0
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libixion-0.10.so
140 %{_includedir}/libixion-0.10
141 %{_pkgconfigdir}/libixion-0.10.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libixion-0.10.a
147 %endif
148
149 %files -n python-ixion
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{py_sitedir}/ixion.so
This page took 0.090063 seconds and 4 git commands to generate.