]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
25b0406cc59528a8697d0d806e60c510f5ab1c27
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.2.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.gz
13 # Source0-md5:  0f63ee487fda8f21fafa767b3c447ac9
14 URL:            http://kohei.us/2010/06/21/ixion-threaded-formula-calculation-library/
15 BuildRequires:  boost-devel >= 1.36
16 BuildRequires:  libstdc++-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Ixion aims to provide a library for calculating the results of formula
21 expressions stored in multiple named targets, or "cells". The cells
22 can be referenced from each other, and the library takes care of
23 resolving their dependencies automatically upon calculation. The
24 caller can run the calculation routine either in a single-threaded
25 mode, or a multi-threaded mode. The library also supports
26 re-calculation where the contents of one or more cells have been
27 modified since the last calculation, and a partial calculation of only
28 the affected cells gets performed. It is written entirely in C++, and
29 makes extensive use of the boost library to achieve portability across
30 different platforms.
31
32 %description -l pl.UTF-8
33 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
34 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
35 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
36 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
37 obliczeniach. Procedura obliczająca może być wywołana w trybie
38 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
39 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
40 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
41 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
42 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
43 przenośność na wiele platform.
44
45 %package devel
46 Summary:        Development files for ixion
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       boost-devel >= 1.36
51 Requires:       libstdc++-devel
52
53 %description devel
54 This package contains the header files for developing applications
55 that use ixion.
56
57 %description devel -l pl.UTF-8
58 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
59 ixion.
60
61 %package static
62 Summary:        Static ixion library
63 Summary(pl.UTF-8):      Statyczna biblioteka ixion
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static ixion library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka ixion.
72
73 %prep
74 %setup -q
75
76 %build
77 %configure \
78         %{!?with_static_libs:--disable-static}
79
80 %{__make}
81
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # obsoleted by pkg-config
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS COPYING ChangeLog README
100 %attr(755,root,root) %{_bindir}/ixion-parser
101 %attr(755,root,root) %{_bindir}/ixion-sorter
102 %attr(755,root,root) %{_libdir}/libixion-0.2.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libixion-0.2.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libixion-0.2.so
108 %{_includedir}/libixion-0.2
109 %{_pkgconfigdir}/ixion-0.2.pc
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libixion-0.2.a
115 %endif
This page took 0.060938 seconds and 2 git commands to generate.