]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- new %%doc
[packages/ipython.git] / ipython.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define pname IPython
4
5 Summary:        An enhanced Interactive Python shell
6 Summary(pl):    Interaktywna pow³oka jêzyka Python
7 Name:           ipython
8 Version:        0.2.10
9 Release:        1
10 License:        LGPL
11 Group:          Applications/Shells
12 Source0:        http://www-hep.colorado.edu/~fperez/ipython/dist/%{pname}-%{version}.tar.gz
13 URL:            http://www-hep.colorado.edu/~fperez/ipython/
14 %pyrequires_eq  python
15 Requires:       python-%{name} = %{version}
16 BuildRequires:  rpm-pythonprov >= 4.0.2-50
17 BuildRequires:  python-devel
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 IPython is a free software project which tries to:
23
24 1. Provide an interactive interpreter superior to Python's default.
25 IPython has many features for object introspection, shell access, and
26 its own special command system for adding functionality when working
27 interactively.
28
29 2. Serve as an embeddable, ready to use interpreter for your own
30 programs. IPython can be started with a single call from inside
31 another program, providing access to the current namespace. This can
32 be very useful both for debugging purposes and for situations where a
33 blend of batch-processing and interactive exploration are needed.
34
35 3. Offer a flexible framework which can be used as the base
36 environment for other systems with Python as the underlying language.
37 Specifically scientific environments like Mathematica, IDL and Mathcad
38 inspired its design, but similar ideas can be useful in many fields.
39
40 This package contains IPython shell.
41
42 %description -l pl
43 IPython jest wolnym oprogramowaniem, którego celem jest:
44
45 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
46 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
47 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
48 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
49
50 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
51 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
52 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
53 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
54 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
55 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
56 introspekcj±.
57
58 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
59 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
60 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
61 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
62 w wielu przypadkach.
63
64 Pakiet ten zawiera pow³okê IPython.
65
66 %package -n python-ipython
67 Summary:        An enhanced Interactive Python shell modules
68 Summary(pl):    Modu³y interaktywnej pow³oki jêzyka Python
69 Group:          Libraries/Python
70 %pyrequires_eq  python-modules
71 %pyrequires_eq  python-pydoc
72
73 %description -n python-ipython
74 IPython is a free software project which tries to:
75
76 1. Provide an interactive interpreter superior to Python's default.
77 IPython has many features for object introspection, shell access, and
78 its own special command system for adding functionality when working
79 interactively.
80
81 2. Serve as an embeddable, ready to use interpreter for your own
82 programs. IPython can be started with a single call from inside
83 another program, providing access to the current namespace. This can
84 be very useful both for debugging purposes and for situations where a
85 blend of batch-processing and interactive exploration are needed.
86
87 3. Offer a flexible framework which can be used as the base
88 environment for other systems with Python as the underlying language.
89 Specifically scientific environments like Mathematica, IDL and Mathcad
90 inspired its design, but similar ideas can be useful in many fields.
91
92 This package contains IPython modules.
93
94 %description -n python-ipython -l pl
95 IPython jest wolnym oprogramowaniem, którego celem jest:
96
97 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
98 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
99 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
100 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
101
102 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
103 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
104 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
105 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
106 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
107 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
108 introspekcj±.
109
110 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
111 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
112 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
113 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
114 w wielu przypadkach.
115
116 Pakiet ten zawiera modu³y interaktywnej pow³oki jêzyka Python.
117
118 %prep
119 %setup  -q -n %{pname}-%{version}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
125
126 mv doc/manual/manual.pdf doc/
127 mv doc/manual/ doc/html/
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/*
135
136 %files -n python-ipython
137 %defattr(644,root,root,755)
138 %doc *.txt doc/{*.txt,ChangeLog,ToDo,BUGS} doc/html doc/*.pdf
139 %dir %{py_sitedir}/%{pname}
140 %dir %{py_sitedir}/%{pname}/Extensions
141 %dir %{py_sitedir}/%{pname}/UserConfig
142 %{py_sitedir}/%{pname}/*.py?
143 %{py_sitedir}/%{pname}/Extensions/*.py?
144
145 # leave it as source because files below will be installed in ~/.ipython
146 # when IPython is _imported_ (it is the reason why UserConfig is not in
147 # main package) first time
148 %{py_sitedir}/%{pname}/UserConfig/*.py
This page took 0.157808 seconds and 3 git commands to generate.