]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- patch for Makefile not to use kernel headers (from /usr/src)
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - -devel subpackage
4 #       - Requires and BuildRequires with proper versions
5 #
6 Summary:        IP sets utility
7 Name:           ipset
8 %define version_base 2.2.6
9 %define version_tstamp 20051028
10 Version:        %{version_base}_%{version_tstamp}
11 Release:        0.1
12 License:        GPL
13 Group:          Networking/Admin
14 Source0:        http://ipset.netfilter.org/%{name}-%{version_base}-%{version_tstamp}.tar.bz2
15 # Source0-md5:  f44ed0ddb714060716677838cd19045c
16 Patch0:         %{name}-no_kernel_headers.patch
17 URL:            http://ipset.netfilter.org/
18 BuildRequires:  linux-libc-headers >= 2.6.11.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # not all set types are supported by our kernel and linux-libc-headers
22 %define _settypes ipmap portmap macipmap iphash nethash iptree
23
24 %description
25 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
26 can be administered by the ipset utility. Depending on the type,
27 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
28 IP addresses with MAC addresses in a way, which ensures lightning
29 speed when matching an entry against a set.
30
31 %prep
32 %setup -qn %{name}-%{version_base}
33 %patch0 -p1
34
35 %build
36 %{__make} \
37         PREFIX="%{_prefix}" \
38         LIBDIR="%{_libdir}" \
39         MANDIR="%{_mandir}" \
40         BINDIR="%{_sbindir}" \
41         SETTYPES:="%{_settypes}" \
42         COPT_FLAGS:="%{rpmcflags}"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR="$RPM_BUILD_ROOT" \
49         PREFIX="%{_prefix}" \
50         LIBDIR="%{_libdir}" \
51         MANDIR="%{_mandir}" \
52         BINDIR="%{_sbindir}" \
53         SETTYPES:="%{_settypes}"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog ChangeLog.ippool TODO
61 %attr(755,root,root) %{_sbindir}/*
62 %dir %{_libdir}/ipset
63 %attr(755,root,root) %{_libdir}/ipset/*.so
64 %{_mandir}/man8/*
This page took 0.029081 seconds and 4 git commands to generate.