]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- updated to 2.3.3a
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - Requires and BuildRequires with proper versions
4 #
5 Summary:        IP sets utility
6 Summary(pl.UTF-8):      Narzędzie do zarządzania zbiorami IP
7 Name:           ipset
8 Version:        2.3.3a
9 Release:        1
10 License:        GPL
11 Group:          Networking/Admin
12 Source0:        http://ipset.netfilter.org/%{name}-%{version}.tar.bz2
13 # Source0-md5:  c7d2f165242edaef5581db0f7d5af520
14 Source1:        %{name}.init
15 URL:            http://ipset.netfilter.org/
16 BuildRequires:  linux-libc-headers >= 7:2.6.22.1-2
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
21 can be administered by the ipset utility. Depending on the type,
22 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
23 IP addresses with MAC addresses in a way, which ensures lightning
24 speed when matching an entry against a set.
25
26 %description -l pl.UTF-8
27 Zbiory IP to szkielet w jądrze Linuksa 2.4.x i 2.6.x, którym można
28 administrować przy użyciu narzędzia ipset. W zależności od rodzaju
29 aktualnie zbiór IP może przechowywać adresy IP, numery portów
30 (TCP/UDP) lub adresy IP z adresami MAC - w sposób zapewniający
31 maksymalną szybkość przy dopasowywaniu elementu do zbioru.
32
33 %package devel
34 Summary:        Header files for ipset interface
35 Summary(pl.UTF-8):      Pliki nagłówkowe do interfejsu ipset
36 Group:          Development/Libraries
37
38 %description devel
39 Header files for ipset interface.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe do interfejsu ipset.
43
44 %package init
45 Summary:        Ipset init (RedHat style)
46 Group:          Networking/Admin
47 Requires(post,preun):   /sbin/chkconfig
48 Requires:       %{name}
49 Requires:       rc-scripts
50
51 %description init
52 Ipset initialization script.
53
54 %prep
55 %setup -q
56
57 %build
58 %{__make} binaries \
59         CC="%{__cc}" \
60         PREFIX="%{_prefix}" \
61         LIBDIR="%{_libdir}" \
62         MANDIR="%{_mandir}" \
63         BINDIR="%{_sbindir}" \
64         COPT_FLAGS:="%{rpmcflags}"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_includedir}}
69
70 %{__make} binaries_install \
71         DESTDIR="$RPM_BUILD_ROOT" \
72         PREFIX="%{_prefix}" \
73         LIBDIR="%{_libdir}" \
74         MANDIR="%{_mandir}" \
75         BINDIR="%{_sbindir}"
76
77 install *.h $RPM_BUILD_ROOT%{_includedir}
78
79 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post init
85 /sbin/chkconfig --add %{name}
86
87 %preun init
88 if [ "$1" = "0" ]; then
89         /sbin/chkconfig --del %{name}
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc ChangeLog ChangeLog.ippool TODO
95 %attr(755,root,root) %{_sbindir}/*
96 %dir %{_libdir}/ipset
97 %attr(755,root,root) %{_libdir}/ipset/*.so
98 %{_mandir}/man8/*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_includedir}/*.h
103
104 %files init
105 %defattr(644,root,root,755)
106 %attr(754,root,root) /etc/rc.d/init.d/*
This page took 0.07302 seconds and 4 git commands to generate.