]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- pl
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - -devel subpackage
4 #       - Requires and BuildRequires with proper versions
5 #
6 Summary:        IP sets utility
7 Summary(pl):    Narzêdzie do zarz±dzania zbiorami IP
8 Name:           ipset
9 %define version_base 2.2.6
10 %define version_tstamp 20051028
11 Version:        %{version_base}_%{version_tstamp}
12 Release:        0.1
13 License:        GPL
14 Group:          Networking/Admin
15 Source0:        http://ipset.netfilter.org/%{name}-%{version_base}-%{version_tstamp}.tar.bz2
16 # Source0-md5:  f44ed0ddb714060716677838cd19045c
17 Patch0:         %{name}-no_kernel_headers.patch
18 URL:            http://ipset.netfilter.org/
19 BuildRequires:  linux-libc-headers >= 2.6.11.1
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # not all set types are supported by our kernel and linux-libc-headers
23 %define _settypes ipmap portmap macipmap iphash nethash iptree
24
25 %description
26 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
27 can be administered by the ipset utility. Depending on the type,
28 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
29 IP addresses with MAC addresses in a way, which ensures lightning
30 speed when matching an entry against a set.
31
32 %description -l pl
33 Zbiory IP to szkielet w j±drze Linuksa 2.4.x i 2.6.x, którym mo¿na
34 administrowaæ przy u¿yciu narzêdzia ipset. W zale¿no¶ci od rodzaju
35 aktualnie zbiór IP mo¿e przechowywaæ adresy IP, numery portów
36 (TCP/UDP) lub adresy IP z adresami MAC - w sposób zapewniaj±cy
37 maksymaln± szybko¶æ przy dopasowywaniu elementu do zbioru.
38
39 %prep
40 %setup -qn %{name}-%{version_base}
41 %patch0 -p1
42
43 %build
44 %{__make} \
45         PREFIX="%{_prefix}" \
46         LIBDIR="%{_libdir}" \
47         MANDIR="%{_mandir}" \
48         BINDIR="%{_sbindir}" \
49         SETTYPES:="%{_settypes}" \
50         COPT_FLAGS:="%{rpmcflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR="$RPM_BUILD_ROOT" \
57         PREFIX="%{_prefix}" \
58         LIBDIR="%{_libdir}" \
59         MANDIR="%{_mandir}" \
60         BINDIR="%{_sbindir}" \
61         SETTYPES:="%{_settypes}"
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ChangeLog ChangeLog.ippool TODO
69 %attr(755,root,root) %{_sbindir}/*
70 %dir %{_libdir}/ipset
71 %attr(755,root,root) %{_libdir}/ipset/*.so
72 %{_mandir}/man8/*
This page took 0.04069 seconds and 4 git commands to generate.