]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- up to 2.3.0-20070828
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - Requires and BuildRequires with proper versions
4 #
5 Summary:        IP sets utility
6 Summary(pl.UTF-8):      Narzędzie do zarządzania zbiorami IP
7 Name:           ipset
8 %define         version_base    2.3.0
9 %define         version_tstamp  20070828
10 Version:        %{version_base}_%{version_tstamp}
11 Release:        1
12 License:        GPL
13 Group:          Networking/Admin
14 Source0:        http://ipset.netfilter.org/%{name}-%{version_base}-%{version_tstamp}.tar.bz2
15 # Source0-md5:  9e17798dfd8ed87c63a1f3498f9fe64d
16 Patch0:         %{name}-no_kernel_headers.patch
17 URL:            http://ipset.netfilter.org/
18 BuildRequires:  linux-libc-headers >= 7:2.6.22.1-2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
23 can be administered by the ipset utility. Depending on the type,
24 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
25 IP addresses with MAC addresses in a way, which ensures lightning
26 speed when matching an entry against a set.
27
28 %description -l pl.UTF-8
29 Zbiory IP to szkielet w jądrze Linuksa 2.4.x i 2.6.x, którym można
30 administrować przy użyciu narzędzia ipset. W zależności od rodzaju
31 aktualnie zbiór IP może przechowywać adresy IP, numery portów
32 (TCP/UDP) lub adresy IP z adresami MAC - w sposób zapewniający
33 maksymalną szybkość przy dopasowywaniu elementu do zbioru.
34
35 %package devel
36 Summary:        Header files for ipset interface
37 Summary(pl.UTF-8):      Pliki nagłówkowe do interfejsu ipset
38 Group:          Development/Libraries
39
40 %description devel
41 Header files for ipset interface.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe do interfejsu ipset.
45
46 %prep
47 %setup -qn %{name}-%{version_base}
48 %patch0 -p1
49
50 %build
51 %{__make} \
52         PREFIX="%{_prefix}" \
53         LIBDIR="%{_libdir}" \
54         MANDIR="%{_mandir}" \
55         BINDIR="%{_sbindir}" \
56         COPT_FLAGS:="%{rpmcflags}"
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_includedir}
61
62 %{__make} install \
63         DESTDIR="$RPM_BUILD_ROOT" \
64         PREFIX="%{_prefix}" \
65         LIBDIR="%{_libdir}" \
66         MANDIR="%{_mandir}" \
67         BINDIR="%{_sbindir}"
68
69 install *.h $RPM_BUILD_ROOT%{_includedir}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc ChangeLog ChangeLog.ippool TODO
77 %attr(755,root,root) %{_sbindir}/*
78 %dir %{_libdir}/ipset
79 %attr(755,root,root) %{_libdir}/ipset/*.so
80 %{_mandir}/man8/*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %{_includedir}/*.h
This page took 0.059777 seconds and 4 git commands to generate.