]> git.pld-linux.org Git - SPECS.git/blob - intersync.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / intersync.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without kernel from distribution
4 #
5 Summary:        InterMezzo filesystem synchronization client
6 Summary(pl.UTF-8):      Klient do synchronizacji systemów plików InterMezzo
7 Name:           intersync
8 Version:        0.9.5
9 Release:        1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        ftp://ftp.inter-mezzo.org/pub/intermezzo/%{name}-%{version}.tar.gz
13 # Source0-md5:  63e8c651923a62f92d40df3812cdc03f
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 Patch0:         %{name}-aclnoextattr.patch
17 Patch1:         %{name}-FHS.patch
18 URL:            http://www.inter-mezzo.org/
19 BuildRequires:  curl-devel
20 BuildRequires:  e2fsprogs-devel
21 BuildRequires:  glib2-devel
22 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4}
23 BuildRequires:  libghttp-devel >= 1.0.9-5
24 BuildRequires:  pkgconfig
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.202
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(postun):       /usr/sbin/userdel
30 Requires(pre):  /bin/id
31 Requires(pre):  /usr/bin/getgid
32 Requires(pre):  /usr/sbin/groupadd
33 Requires(pre):  /usr/sbin/useradd
34 Requires:       webserver = apache
35 Provides:       group(intermezzo)
36 Provides:       user(intermezzo)
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 InterSync is a C based InterMezzo client, intended to operate with an
41 HTTP server (e.g. TUX or Apache) as a server.
42
43 %description -l pl.UTF-8
44 InterSync to napisany w C klient InterMezzo, mający współpracować z
45 serwerem HTTP (np. TUX lub Apache) jako serwerem.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51
52 %build
53 %configure
54 %{__make} all
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{/var/log/intermezzo,%{_sysconfdir}/intermezzo} \
59         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install sampleconfigs/intersync.conf $RPM_BUILD_ROOT%{_sysconfdir}/intermezzo
65
66 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/intersync
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/intersync
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %pre
73 %groupadd -g 45 -r -f intermezzo
74 %useradd -g intermezzo -u 45 -d /usr/share/empty -s /bin/false intermezzo
75
76 %post
77 /sbin/chkconfig --add intersync
78
79 %preun
80 if [ "$1" = "0" ]; then
81         /sbin/chkconfig --del intersync
82 fi
83
84 %postun
85 if [ "$1" = "0" ]; then
86         %userremove intermezzo
87         %groupremove intermezzo
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc ChangeLog NEWS
93 %doc doc/*.txt doc/*.html
94 %attr(755,root,root) %{_bindir}/*
95 %attr(755,root,root) %{_libdir}/intermezzo
96 %attr(754,root,root) /etc/rc.d/init.d/intersync
97 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/intersync
98 %dir %{_sysconfdir}/intermezzo
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/intermezzo/intersync.conf
100 %{_mandir}/man[458]/*
101 /var/log/intermezzo
102
103 # devel?
104 #%%{_libdir}/lib*.a
105 #%%{_includedir}/intermezzo
This page took 1.399981 seconds and 3 git commands to generate.