]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/blob - intel-graphics-compiler.spec
actually use a version number for %llvm_version
[packages/intel-graphics-compiler.git] / intel-graphics-compiler.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 7.0.1-3
4
5 %define opencl_clang_version 8.0.1
6
7 Summary:        The Intel Graphics Compiler for OpenCL
8 Name:           intel-graphics-compiler
9 Version:        1.0.8
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
14 # Source0-md5:  9999fd7b6947b2ed0a11f7b07b1e7acc
15 Patch0:         pkgconfig.patch
16 URL:            https://github.com/intel/intel-graphics-compiler/
17 BuildRequires:  llvm-devel >= %{llvm_version}
18 BuildRequires:  opencl-clang-devel >= %{opencl_clang_version}
19 BuildRequires:  cmake >= 3.2.0
20 BuildRequires:  pkgconfig
21 Requires:       %{name}-libs = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Intel Graphics Compiler for OpenCL is an LLVM based compiler for OpenCL
26 targeting Intel Gen graphics hardware architecture.
27
28 %package libs
29 Summary:        The Intel Graphics Compiler for OpenCL libraries
30 Group:          Libraries
31
32 %description libs
33 The Intel Graphics Compiler for OpenCL libraries.
34
35 %package devel
36 Summary:        Header files for %{name} library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
38 Group:          Development/Libraries
39 Requires:       llvm-devel >= %{llvm_version}
40 Requires:       %{name}-libs = %{version}-%{release}
41
42 %description devel
43 Header files for %{name} library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki %{name}.
47
48 %prep
49 %setup -qn %{name}-igc-%{version}
50
51 %patch0 -p1
52
53 %build
54 install -d build
55 cd build
56 %cmake \
57         -DCCLANG_FROM_SYSTEM=ON \
58         ../
59 %{__make}
60
61 cd ..
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.md
75 %attr(755,root,root) %{_bindir}/GenX_IR
76 %ifarch %{x8664}
77 %attr(755,root,root) %{_bindir}/iga64
78 %else
79 %attr(755,root,root) %{_bindir}/iga32
80 %endif
81
82 %files libs
83 %defattr(644,root,root,755)
84 %ifarch %{x8664}
85 %attr(755,root,root) %{_libdir}/libiga64.so.1.*.*
86 %ghost %attr(755,root,root) %{_libdir}/libiga64.so.1
87 %else
88 %attr(755,root,root) %{_libdir}/libiga32.so.1.*.*
89 %ghost %attr(755,root,root) %{_libdir}/libiga32.so.1
90 %endif
91 %attr(755,root,root) %{_libdir}/libigc.so.1.*.*
92 %ghost %attr(755,root,root) %{_libdir}/libigc.so.1
93 %attr(755,root,root) %{_libdir}/libigdfcl.so.1.*.*
94 %ghost %attr(755,root,root) %{_libdir}/libigdfcl.so.1
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_includedir}/igc
99 %ifarch %{x8664}
100 %attr(755,root,root) %{_libdir}/libiga64.so
101 %else
102 %attr(755,root,root) %{_libdir}/libiga32.so
103 %endif
104 %attr(755,root,root) %{_libdir}/libigc.so
105 %attr(755,root,root) %{_libdir}/libigdfcl.so
106 %{_pkgconfigdir}/igc-opencl.pc
This page took 0.04656 seconds and 4 git commands to generate.