]> git.pld-linux.org Git - SPECS.git/blob - imvirt.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / imvirt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Detects several virtualizations
6 Name:           imvirt
7 Version:        0.9.6
8 Release:        1
9 Source0:        http://downloads.sourceforge.net/imvirt/%{name}-%{version}.tar.gz
10 # Source0-md5:  792d986e79d763a44b55c33a17abb62d
11 License:        GPL v2+
12 Group:          Applications/System
13 URL:            http://micky.ibh.net/~liske/imvirt.html
14 BuildRequires:  perl-ExtUtils-MakeMaker
15 Requires:       dmidecode
16 ExclusiveArch:  %{ix86} %{x8664} ia64
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This little Perl script tries to detect if it is called from within a
21 virtualization container. This is detected by looking for well known
22 boot messages, directories and reading DMI (Desktop Management
23 Interface) data.
24
25 The following containers are detected:
26 - Virtual PC/Virtual Server
27 - VirtualBox
28 - VMware
29 - QEMU/KVM (experimental)
30 - Xen (para and non-para virtualized)
31 - OpenVZ/Virtuozzo
32 - UML
33 - any HVM providing CPUID 0x40000000 detection
34 - lguest
35 - ARAnyM
36 - LXC
37
38 %prep
39 %setup -q
40
41 %build
42 %configure
43 %{__make}
44
45 %if %{with tests}
46 %{__make} check
47 %endif
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/ImVirt/.packlist
55 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
56 rm $RPM_BUILD_ROOT%{perl_vendorlib}/ImVirt.pm.in
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS ChangeLog README
64 %attr(755,root,root) %{_sbindir}/imvirt-report
65 %attr(755,root,root) %{_bindir}/imvirt
66 %dir %{_libexecdir}/imvirt
67 %attr(755,root,root) %{_libdir}/%{name}/hvm
68 %attr(755,root,root) %{_libdir}/%{name}/hyperv
69 %attr(755,root,root) %{_libdir}/%{name}/pillbox
70 %attr(755,root,root) %{_libdir}/%{name}/vmware
71 %attr(755,root,root) %{_libdir}/%{name}/xen
72 %{_mandir}/man1/imvirt-report.1*
73 %{_mandir}/man1/imvirt.1*
74
75 # perl-ImVirt
76 %{perl_vendorlib}/ImVirt.pm
77 %{perl_vendorlib}/ImVirt
78 %{_mandir}/man3/ImVirt.3pm*
This page took 0.753596 seconds and 3 git commands to generate.