]> git.pld-linux.org Git - packages/id3lib.git/blob - id3lib.spec
- added using %%{__make} macro.
[packages/id3lib.git] / id3lib.spec
1 # $Id: id3lib.spec,v 1.2 2000-06-09 07:22:59 kloczek Exp $
2
3 Name:           id3lib
4 Version:        3.7.9
5 Release:        1
6 Summary:        A software library for manipulating ID3v1 and ID3v2 tags.
7 Source0:        http://download.sourceforge.net/id3lib/%{name}-%{version}.tar.gz
8 URL:            http://id3lib.sourceforge.net
9 Group:          Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13 License:        LGPL
14 Requires:       zlib
15
16 %description
17 This package provides a software library for manipulating ID3v1 and
18 ID3v2 tags. It provides a convenient interface for software developers
19 to include standards-compliant ID3v1/2 tagging capabilities in their
20 applications. Features include identification of valid tags, automatic
21 size conversions, (re)synchronisation of tag frames, seamless tag
22 (de)compression, and optional padding facilities.
23
24 %package        devel
25 Summary:        Headers for developing programs that will use id3lib
26 Group:          Development/Libraries
27 Group(fr):      Development/Librairies
28 Group(pl):      Programowanie/Biblioteki
29 Requires:       %{name}
30
31 %description    devel
32 This package contains the headers that programmers will need to
33 develop applications which will use id3lib, the software library for
34 ID3v1 and ID3v2 tag manipulation.
35
36 %package        doc
37 Summary:        Documentation for developing programs that will use id3lib
38 Group:          Documentation
39 Group(pl):      Dokumentacja
40
41 %description    doc
42 This package contains the documentation of the id3lib API that
43 programmers will need to develop applications which will use id3lib,
44 the software library for ID3v1 and ID3v2 tag manipulation.
45
46 %package        examples
47 Summary:        Example applications that make use of the id3lib library
48 Group:          Applications/File
49 ######          Unknown group!
50 Requires:       %{name}
51
52 %description    examples
53 This package contains simple example applications that make use of
54 id3lib, a software library for ID3v1 and ID3v2 tag maniuplation.
55
56 %prep
57 %setup -q
58
59 %build
60 %ifarch i386 i486
61 ID3_ARCH=i486
62 %endif 
63
64 %ifarch i586
65 ID3_ARCH=pentium
66 %endif 
67
68 %ifarch i686
69 ID3_ARCH=pentiumpro
70 %endif 
71
72 %ifarch k6
73 ID3_ARCH=k6
74 %endif
75
76 %ifarch i386 i486 i586 i686 k6
77
78 RPM_OPT_FLAGS="-O3 -fomit-frame-pointer -pipe -s -mcpu=$ID3_ARCH -march=$ID3_ARCH -ffast-math -fexpensive-optimizations -malign-loops=2 -malign-jumps=2 -malign-functions=2 -mpreferred-stack-boundary=2"
79
80 %endif
81
82 CXXFLAGS="$RPM_OPT_FLAGS -fexceptions" %configure
83
84 %ifnarch noarch
85
86 uname -a|grep SMP && make -j 2 || make
87
88 %endif
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %ifnarch noarch
94
95 %{__make} DESTDIR=$RPM_BUILD_ROOT install
96
97 %else
98
99 %{__make} docs
100  
101 # strip down the doc and examples directories so we can copy w/impunity
102 for i in doc/ examples/; do \
103   find $i                   \
104   \(  -name 'Makefile*' -or \
105       -name '*.ps.gz'   -or \
106       -name '*.pdf'         \
107   \)  -exec rm {} \; ; done
108
109 %endif
110
111 gzip -9nf AUTHORS ChangeLog HISTORY NEWS README THANKS TODO
112
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post -p /sbin/ldconfig
118
119 %postun -p /sbin/ldconfig
120
121 %ifnarch noarch
122
123 %files
124 %defattr(644,root,root,755)
125 %doc {AUTHORS,ChangeLog,HISTORY,NEWS,README,THANKS,TODO}.gz
126 %{_libdir}/*.so.*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %{_includedir}/id3*.h
131 %{_includedir}/id3
132 %{_libdir}/*.la
133 %{_libdir}/*.a
134 %{_libdir}/*.so
135
136 %files examples
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/id3*
139
140 %else
141
142 %files doc
143 %defattr(644,root,root,755)
144 %doc AUTHORS COPYING ChangeLog HISTORY NEWS README THANKS TODO
145 %doc doc/*.* doc/api examples
146
147 %endif
This page took 0.083004 seconds and 3 git commands to generate.