]> git.pld-linux.org Git - packages/icu.git/blob - icu.spec
- add autoconf 2.64 hack; rel 2
[packages/icu.git] / icu.spec
1 %define         ver     %(echo %{version} | tr . _)
2 Summary:        International Components for Unicode
3 Summary(pl.UTF-8):      Międzynarodowe komponenty dla unikodu
4 Name:           icu
5 Version:        4.2.1
6 Release:        2
7 License:        MIT-like
8 Group:          Libraries
9 Source0:        http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{ver}-src.tgz
10 # Source0-md5:  e3738abd0d3ce1870dc1fd1f22bba5b1
11 Patch0:         pkgconfig.patch
12 Patch1:         ac264-hack.patch
13 Source1:        %{name}-config
14 URL:            http://www.icu-project.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 Requires:       libicu = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 ICU is a set of C and C++ libraries that provides robust and
24 full-featured Unicode and locale support. The library provides
25 calendar support, conversions for many character sets, language
26 sensitive collation, date and time formatting, support for many
27 locales, message catalogs and resources, message formatting,
28 normalization, number and currency formatting, time zones support,
29 transliteration, word, line and sentence breaking, etc.
30
31 This package contains the Unicode character database and derived
32 properties, along with converters and time zones data.
33
34 %description -l pl.UTF-8
35 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
36 obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
37 kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
38 języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
39 katalogów komunikatów i zasobów, formatowanie komunikatów,
40 normalizację, formatowanie liczb i walut, obsługę stref czasowych,
41 transliterację, łamanie słów, linii i zdań itp.
42
43 Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
44 konwerterami i danymi stref czasowych.
45
46 %package -n libicu
47 Summary:        International Components for Unicode (libraries)
48 Summary(pl.UTF-8):      Międzynarodowe Komponenty dla Unikodu (biblioteki)
49 Group:          Development/Libraries
50 Obsoletes:      libicu30
51
52 %description -n libicu
53 ICU is a set of C and C++ libraries that provides robust and
54 full-featured Unicode support. This package contains the runtime
55 libraries for ICU. It does not contain any of the data files needed at
56 runtime and present in the `icu' and `icu-locales` packages.
57
58 %description -n libicu -l pl.UTF-8
59 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
60 obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
61 uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
62 czasie działania i obecnymi w pakietach "icu" i "icu-locales".
63
64 %package -n libicu-devel
65 Summary:        International Components for Unicode (development files)
66 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
67 Group:          Development/Libraries
68 Requires:       libicu = %{version}-%{release}
69
70 %description -n libicu-devel
71 ICU is a set of C and C++ libraries that provides robust and
72 full-featured Unicode support. This package contains the development
73 files for ICU.
74
75 %description -n libicu-devel -l pl.UTF-8
76 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
77 obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
78 programistyczne ICU.
79
80 %prep
81 %setup -q -n %{name}
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 cd source
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %configure \
91         --sbindir=%{_bindir} \
92         --disable-samples
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C source install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-config
103 sed -i 's/\$(THREADSCXXFLAGS)//' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/icu.pc
104 sed -i 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/icu.pc
105
106 # help rpm to generate deps
107 chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
108
109 # rpm is too stupid sometimes and fails on symlinks to symlinked resources
110 # (reporting unresolved dependency at install time)
111 ln -sf %{version}/Makefile.inc $RPM_BUILD_ROOT%{_libdir}/%{name}/Makefile.inc
112
113 rm -f $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/license.html
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -n libicu -p /sbin/ldconfig
119 %postun -n libicu -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc license.html readme.html
124 %attr(755,root,root) %{_bindir}/*
125 %exclude %{_bindir}/icu-config
126 %{_mandir}/man1/*
127 %{_mandir}/man8/*
128 %exclude %{_mandir}/man1/icu-config.1*
129
130 %files -n libicu
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libicu*.so.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libicu*.so.42
134
135 %files -n libicu-devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/icu-config
138 %attr(755,root,root) %{_libdir}/libicu*.so
139 %{_pkgconfigdir}/icu.pc
140 %{_includedir}/unicode
141 %{_includedir}/layout
142 %dir %{_libdir}/%{name}
143 %{_libdir}/%{name}/*.inc
144 %dir %{_libdir}/%{name}/current
145 %dir %{_libdir}/%{name}/%{version}
146 %{_libdir}/%{name}/%{version}/*.inc
147 %dir %{_datadir}/%{name}
148 %dir %{_datadir}/%{name}/%{version}
149 %{_datadir}/%{name}/%{version}/config
150 %attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
151 %attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
152 %{_mandir}/man1/icu-config.1*
This page took 0.060418 seconds and 3 git commands to generate.