]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- updated BRs and License, sync configure options order with xulrunner/firefox
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
8 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
9 %bcond_without  lightning       # disable Sunbird/Lightning calendar
10 %bcond_with     xulrunner       # system xulrunner
11 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
12
13 %if 0%{?_enable_debug_packages} != 1
14 %undefine       crashreporter
15 %endif
16
17 %define         enigmail_ver    1.6
18 %define         nspr_ver        4.10.2
19 %define         nss_ver         3.15.4
20
21 %define         xulrunner_ver   2:24.0
22
23 %if %{without xulrunner}
24 # The actual sqlite version (see RHBZ#480989):
25 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
26 %endif
27
28 Summary:        Icedove - email client
29 Summary(pl.UTF-8):      Icedove - klient poczty
30 Name:           icedove
31 Version:        24.5.0
32 Release:        1
33 License:        MPL v2.0
34 Group:          X11/Applications/Mail
35 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
36 # Source0-md5:  dbe164c48e42c04b4959910eda2e52ca
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  4a2bbcb020bdb282a660fda8c70d5608
39 Source2:        %{name}-branding.tar.bz2
40 # Source2-md5:  d8e6897870bf288fdf264c0e9ef85f7d
41 Source3:        %{name}-rm_nonfree.sh
42 Source4:        %{name}.desktop
43 Source5:        %{name}.sh
44 Patch0:         %{name}-branding.patch
45 Patch1:         %{name}-enigmail-shared.patch
46 Patch2:         %{name}-sh.patch
47 Patch3:         %{name}-fonts.patch
48 Patch6:         %{name}-prefs.patch
49 Patch7:         system-mozldap.patch
50 Patch8:         %{name}-makefile.patch
51 Patch10:        %{name}-extensiondir.patch
52 Patch12:        no-subshell.patch
53 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
54 Patch13:        system-virtualenv.patch
55 Patch14:        gyp-slashism.patch
56 Patch15:        enable-addons.patch
57 URL:            http://www.pld-linux.org/Packages/Icedove
58 BuildRequires:  GConf2-devel >= 1.2.1
59 BuildRequires:  alsa-lib-devel
60 BuildRequires:  automake
61 BuildRequires:  bzip2-devel
62 BuildRequires:  cairo-devel >= 1.10
63 BuildRequires:  dbus-glib-devel >= 0.60
64 BuildRequires:  freetype-devel >= 1:2.1.8
65 BuildRequires:  glib2-devel >= 2.0
66 BuildRequires:  gstreamer0.10-devel
67 BuildRequires:  gstreamer0.10-plugins-base-devel
68 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.14}
69 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 BuildRequires:  libevent-devel
73 BuildRequires:  libiw-devel
74 # requires libjpeg-turbo implementing at least libjpeg 6b API
75 BuildRequires:  libjpeg-devel >= 6b
76 BuildRequires:  libjpeg-turbo-devel
77 BuildRequires:  libpng-devel >= 1.4.1
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  mozldap-devel
80 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
81 BuildRequires:  nss-devel >= 1:%{nss_ver}
82 BuildRequires:  pango-devel >= 1:1.14.0
83 BuildRequires:  perl-base >= 1:5.6
84 BuildRequires:  python-virtualenv
85 BuildRequires:  pkgconfig
86 BuildRequires:  python >= 1:2.5
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.7.17
89 BuildRequires:  startup-notification-devel >= 0.8
90 BuildRequires:  libvpx-devel >= 1.0.0
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 BuildRequires:  yasm
95 BuildRequires:  zip
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
98 %else
99 %{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
100 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Requires:       libjpeg-turbo
111 Obsoletes:      mozilla-thunderbird
112 Obsoletes:      mozilla-thunderbird-dictionary-en-US
113 Conflicts:      icedove-lang-resources < %{version}
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
117
118 # iceweasel/icedove/iceape provide their own versions
119 %define         _noautoprovfiles        %{_libdir}/%{name}/components
120 %if %{without xulrunner}
121 # we don't want these to satisfy packages depending on xulrunner
122 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
123 # and as we don't provide them, don't require either
124 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
125 %endif
126
127 %define         topdir          %{_builddir}/%{name}-%{version}
128 %define         objdir          %{topdir}/obj-%{_target_cpu}
129
130 %description
131 Icedove is an open-source, fast and portable email client.
132
133 %description -l pl.UTF-8
134 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
135 poczty.
136
137 %package addon-lightning
138 Summary:        An integrated calendar for Icedove
139 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
140 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
141 Group:          Applications/Networking
142 Requires:       %{name} = %{version}-%{release}
143
144 %description addon-lightning
145 Lightning is an calendar extension to Icedove email client.
146
147 %description addon-lightning -l pl.UTF-8
148 Lightning to rozszerzenie do klienta poczty Icedove dodające
149 funkcjonalność kalendarza.
150
151 %package addon-enigmail
152 Summary:        Extension for the authentication and encryption features provided by GnuPG
153 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
154 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
155 Group:          Applications/Networking
156 URL:            http://enigmail.mozdev.org/
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       gnupg
159 Obsoletes:      mozilla-thunderbird-addon-enigmail
160
161 %description addon-enigmail
162 Enigmail is an extension to the Icedove mail client which allows users
163 to access the authentication and encryption features provided by
164 GnuPG.
165
166 Main Features:
167 - Encrypt/sign mail when sending, decrypt/authenticate received mail
168 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
169 - Per-Account based encryption and signing defaults
170 - Per-Recipient rules for automated key selection, and
171   enabling/disabling encryption and signing
172 - OpenPGP key management interface
173
174 %description addon-enigmail -l pl.UTF-8
175 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
176 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
177 przez GnuPG.
178
179 Główne możliwości:
180 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
181   odszyfrowywanie/uwierzytelnianie poczty odebranej
182 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
183 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
184 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
185   podpisywania dla każdego adresata
186 - interfejs do zarządzania kluczami OpenPGP
187
188 %prep
189 %setup -qc
190 mv comm-esr24 mozilla
191 %setup -q -T -D -a2
192 cd mozilla
193 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} xf - -C mailnews/extensions}
194 /bin/sh %{SOURCE3}
195 %patch0 -p1
196 %{?with_enigmail:%patch1 -p1}
197 %patch2 -p1
198 %patch3 -p1
199 %patch6 -p1
200 %patch7 -p1
201 %patch8 -p2
202 %patch10 -p2
203 %patch12 -p1
204 %patch13 -p1
205 %patch14 -p1
206 %patch15 -p1
207
208 %build
209 cd mozilla
210 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214 cat << EOF > .mozconfig
215 mk_add_options MOZ_OBJDIR=%{objdir}
216
217 export CFLAGS="%{rpmcflags}"
218 export CXXFLAGS="%{rpmcflags}"
219
220 %if %{with crashreporter}
221 export MOZ_DEBUG_SYMBOLS=1
222 %endif
223
224 # Options for 'configure' (same as command-line options).
225 ac_add_options --prefix=%{_prefix}
226 ac_add_options --exec-prefix=%{_exec_prefix}
227 ac_add_options --bindir=%{_bindir}
228 ac_add_options --sbindir=%{_sbindir}
229 ac_add_options --sysconfdir=%{_sysconfdir}
230 ac_add_options --datadir=%{_datadir}
231 ac_add_options --includedir=%{_includedir}
232 ac_add_options --libdir=%{_libdir}
233 ac_add_options --libexecdir=%{_libexecdir}
234 ac_add_options --localstatedir=%{_localstatedir}
235 ac_add_options --sharedstatedir=%{_sharedstatedir}
236 ac_add_options --mandir=%{_mandir}
237 ac_add_options --infodir=%{_infodir}
238 %if %{?debug:1}0
239 ac_add_options --disable-optimize
240 ac_add_options --enable-debug
241 ac_add_options --enable-debug-modules
242 ac_add_options --enable-debugger-info-modules
243 ac_add_options --enable-crash-on-assert
244 %else
245 ac_add_options --disable-debug
246 ac_add_options --disable-debug-modules
247 ac_add_options --disable-logging
248 ac_add_options --enable-optimize="%{rpmcflags} -Os"
249 %endif
250 ac_add_options --disable-strip
251 ac_add_options --disable-strip-libs
252 %if %{with tests}
253 ac_add_options --enable-tests
254 %else
255 ac_add_options --disable-tests
256 %endif
257 %if %{with lightning}
258 ac_add_options --enable-calendar
259 %else
260 ac_add_options --disable-calendar
261 %endif
262 %if %{with crashreporter}
263 ac_add_options --enable-crashreporter
264 %else
265 ac_add_options --disable-crashreporter
266 %endif
267 ac_add_options --disable-elf-dynstr-gc
268 ac_add_options --disable-gnomeui
269 ac_add_options --disable-gnomevfs
270 ac_add_options --disable-installer
271 ac_add_options --disable-javaxpcom
272 ac_add_options --disable-profilesharing
273 ac_add_options --disable-updater
274 ac_add_options --disable-xterm-updates
275 ac_add_options --enable-application=mail
276 ac_add_options --enable-crypto
277 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
278 ac_add_options --enable-gio
279 %if %{with ldap}
280 ac_add_options --enable-ldap
281 ac_add_options --with-system-ldap
282 %else
283 ac_add_options --disable-ldap
284 %endif
285 ac_add_options --enable-libxul
286 ac_add_options --enable-pango
287 ac_add_options --enable-postscript
288 ac_add_options --enable-shared-js
289 ac_add_options --enable-single-profile
290 ac_add_options --enable-startup-notification
291 ac_add_options --enable-system-cairo
292 ac_add_options --enable-system-hunspell
293 ac_add_options --enable-system-sqlite
294 ac_add_options --with-branding=icedove/branding
295 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
296 ac_add_options --with-distribution-id=org.pld-linux
297 %if %{with xulrunner}
298 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
299 ac_add_options --with-system-libxul
300 %endif
301 ac_add_options --with-pthreads
302 ac_add_options --with-system-bz2
303 ac_add_options --with-system-ffi
304 ac_add_options --with-system-jpeg
305 ac_add_options --with-system-libevent
306 ac_add_options --with-system-libvpx
307 ac_add_options --with-system-nspr
308 ac_add_options --with-system-nss
309 ac_add_options --with-system-png
310 ac_add_options --with-system-zlib
311 EOF
312
313 mkdir -p %{objdir}/config
314 ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
315
316 %{__make} -j1 -f client.mk build \
317         STRIP="/bin/true" \
318         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
319         installdir=%{_libdir}/%{name} \
320         XLIBS="-lX11 -lXt" \
321         CC="%{__cc}" \
322         CXX="%{__cxx}"
323
324 %if %{with crashreporter}
325 # create debuginfo for crash-stats.mozilla.com
326 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
327 %endif
328
329 %if %{with enigmail}
330 cd mailnews/extensions/enigmail
331 ./makemake -r -o %{objdir}
332 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
333         STRIP="/bin/true" \
334         CC="%{__cc}" \
335         CXX="%{__cxx}"
336
337 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
338         STRIP="/bin/true" \
339         CC="%{__cc}" \
340         CXX="%{__cxx}"
341 %endif
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
346
347 cd %{objdir}
348 %{__make} -C mail/installer stage-package \
349         DESTDIR=$RPM_BUILD_ROOT \
350         installdir=%{_libdir}/%{name} \
351         PKG_SKIP_STRIP=1
352
353 %{__make} -C icedove/branding install \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
357  
358 %if %{with xulrunner}
359 # needed to find mozilla runtime
360 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
361 %endif
362  
363 # Enable crash reporter for Thunderbird application
364 %if %{with crashreporter}
365 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
366
367 # Add debuginfo for crash-stats.mozilla.com
368 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
369 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
370 %endif
371
372 # copy manually lightning files, somewhy they are not installed by make
373 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
374         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
375
376 # move arch independant ones to datadir
377 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
378 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
379
380 # dir for arch independant extensions besides arch dependant extensions
381 # see mozilla/xpcom/build/nsXULAppAPI.h
382 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
383 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
384
385 %if %{without xulrunner}
386 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388 %endif
389
390 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
391          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
392         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
393
394 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
395 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
396 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
397
398 # install icons and desktop file
399 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
400 for i in 16 32 48 64 128 256; do
401         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
402         cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
403                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
404 done
405 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
406 cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
407
408 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
409
410 # files created by regxpcom -register in post
411 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
412 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
413 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
414 #!/bin/sh
415 umask 022
416 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
417 # dangerous if you run this with sudo with keep_env += HOME
418 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
419 t=$(mktemp -d)
420 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
421 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
422 rm -rf $t
423 EOF
424 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
425
426 %if %{with enigmail}
427 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
428 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
429 cd mozilla/dist/bin
430 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
431 cp -rfLp components/enig* $ext_dir/components
432 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
433 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
434 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
435 cd -
436 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
437 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
438 %endif
439
440 # mozldap
441 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
442 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %pretrans
448 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
449         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
450 fi
451 for d in chrome defaults icons isp modules res searchplugins; do
452         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
453                 install -d %{_datadir}/%{name}
454                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
455         fi
456 done
457 exit 0
458
459 %post
460 %{_libdir}/%{name}/register || :
461
462 %files
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_bindir}/icedove
465 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
466 %attr(755,root,root) %{_bindir}/thunderbird
467 %dir %{_libdir}/%{name}
468 %{_libdir}/%{name}/application.ini
469 %{_libdir}/%{name}/blocklist.xml
470 %{_libdir}/%{name}/chrome.manifest
471 %dir %{_libdir}/%{name}/components
472 %{_libdir}/%{name}/components/components.manifest
473 %attr(755,root,root) %{_libdir}/%{name}/*.sh
474 %attr(755,root,root) %{_libdir}/%{name}/*-bin
475 %attr(755,root,root) %{_libdir}/%{name}/icedove
476 %attr(755,root,root) %{_libdir}/%{name}/register
477 %{_libdir}/%{name}/omni.ja
478 %if %{without xulrunner}
479 %{_libdir}/%{name}/dependentlibs.list
480 %{_libdir}/%{name}/platform.ini
481 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
482 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
484 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
485 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
487 %endif
488
489 # symlinks
490 %{_libdir}/%{name}/chrome
491 %{_libdir}/%{name}/defaults
492 %{_libdir}/%{name}/isp
493 %{_libdir}/%{name}/searchplugins
494 %if %{with xulrunner}
495 %{_libdir}/%{name}/xulrunner
496 %else
497 %{_libdir}/%{name}/dictionaries
498 %endif
499
500 %{_pixmapsdir}/icedove.png
501 %{_desktopdir}/icedove.desktop
502
503 %dir %{_datadir}/%{name}
504 %{_datadir}/%{name}/extensions
505 %{_datadir}/%{name}/searchplugins
506
507 %if %{with crashreporter}
508 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
509 %{_libdir}/%{name}/crashreporter.ini
510 %{_libdir}/%{name}/Throbber-small.gif
511 %endif
512
513 %dir %{_libdir}/%{name}/extensions
514 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
515
516 # files created by regxpcom -register
517 %ghost %{_libdir}/%{name}/components/compreg.dat
518 %ghost %{_libdir}/%{name}/components/xpti.dat
519
520 %{_iconsdir}/hicolor/*/apps/icedove.*
521
522 %if %{with lightning}
523 %files addon-lightning
524 %defattr(644,root,root,755)
525 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
526 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
531 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
532 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
539 %endif
540
541 %if %{with enigmail}
542 %files addon-enigmail
543 %defattr(644,root,root,755)
544 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
545 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
546 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
549 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
552 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
555 %endif
This page took 0.069931 seconds and 4 git commands to generate.