]> git.pld-linux.org Git - SPECS.git/blob - hyperestraier.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / hyperestraier.spec
1 # TODO: perl binding
2 #
3 # Conditional build:
4 %bcond_without  fcgi            # build estseek.fcgi
5 %bcond_without  java            # Java bindings
6 %bcond_without  ruby            # Ruby bindings
7 %bcond_without  static_libs     # don't build static libraries
8 #
9 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
10 %undefine with_java
11 %endif
12 Summary:        Full-text search system
13 Summary(pl.UTF-8):      Pełnotekstowy system wyszukiwawczy
14 Name:           hyperestraier
15 Version:        1.4.13
16 Release:        12
17 License:        LGPL v2.1+
18 Group:          Applications/Text
19 Source0:        http://downloads.sourceforge.net/hyperestraier/%{name}-%{version}.tar.gz
20 # Source0-md5:  847aefb9e23266545280378d797f3981
21 Source1:        %{name}.sh
22 Patch0:         %{name}-am_ac.patch
23 Patch1:         %{name}-ruby1.9.patch
24 Patch2:         ruby-vendor.patch
25 URL:            http://hyperestraier.sourceforge.net/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %{?with_fcgi:BuildRequires:     fcgi-devel}
29 %{?with_java:BuildRequires:     jdk}
30 %{?with_java:BuildRequires:     jpackage-utils}
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 BuildRequires:  qdbm-devel >= 1.8.75
34 %{?with_java:BuildRequires:     rpmbuild(macros) >= 1.300}
35 %{?with_ruby:BuildRequires:     ruby-devel}
36 BuildRequires:  zlib-devel
37 Requires:       %{name}-libs = %{version}-%{release}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _libexecdir     %{_libdir}/%{name}
41
42 %description
43 Hyper Estraier is a full-text search system. You can search lots of
44 documents for some documents including specified words. If you run a
45 web site, it is useful as your own search engine for pages in your
46 site. Also, it is useful as search utilities of mail boxes and file
47 servers.
48
49 The characteristic of Hyper Estraier is the following:
50  - High performance of search
51  - High scalability of target documents
52  - Perfect recall ratio by N-gram method
53  - High precision by hybrid mechanism of N-gram and morphological
54    analyzer
55  - Phrase search, regular expressions, attribute search, and similarity
56    search
57  - Multilingualism with Unicode
58  - Independent of file format and repository
59  - Simple and powerful API
60  - Supporting P2P architecture
61
62 %description -l pl.UTF-8
63 Hyper Estraier to system wyszukiwania pełnotekstowego. Pozwala
64 przeszukiwać wiele dokumentów, aby odnaleźć dokumenty zawierające
65 podane słowa. W przypadku uruchomienia na stronie WWW, może być
66 przydatny jako własna wyszukiwarka stron we własnym serwisie. Jest
67 przydatny także do przeszukiwania skrzynek pocztowych i serwerów
68 plików.
69
70 Charakterystyka Hyper Estraiera:
71  - duża wydajność przeszukiwania
72  - duża skalowalność dokumentów docelowych
73  - doskonały współczynnik odwołań przy użyciu metody N-gramowej
74  - wysoka precyzja przy użyciu hybrydowego mechanizmu N-gramowego i
75    analizatora morfologicznego
76  - wyszukiwanie fraz, wyrażeń regularnych, atrybutów oraz podobieńst
77  - wielojęzyczność z Unicode
78  - niezależność od formatu plików i repozytorium
79  - proste i potężne API
80  - obsługa architektury P2P
81
82 %package libs
83 Summary:        hyperestraier libraries
84 Summary(pl.UTF-8):      Biblioteki hyperestraiera
85 Group:          Libraries
86
87 %description libs
88 hyperestraier libraries - full-text search system.
89
90 %description libs -l pl.UTF-8
91 Biblioteki hyperestraiera - pełnotekstowego systemu wyszukiwawczego.
92
93 %package devel
94 Summary:        Header files for hyperestraier library
95 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki hyperestraier
96 Group:          Development/Libraries
97 Requires:       %{name}-libs = %{version}-%{release}
98
99 %description devel
100 This is the package containing the header files for hyperestraier
101 library.
102
103 %description devel -l pl.UTF-8
104 Ten pakiet zawiera pliki nagłówkowe biblioteki hyperestraier.
105
106 %package static
107 Summary:        Static hyperestraier library
108 Summary(pl.UTF-8):      Statyczna biblioteka hyperestraier
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 Static hyperestraier library.
114
115 %description static -l pl.UTF-8
116 Statyczna biblioteka hyperestraier.
117
118 %package javanative
119 Summary:        Java native bindings for hyperestraier
120 Summary(pl.UTF-8):      Wiązania natywne Javy do hyperestraiera
121 Group:          Libraries/Java
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description javanative
125 Java native bindings for hyperestraier.
126
127 %description javanative -l pl.UTF-8
128 Wiązania natywne Javy do hyperestraiera.
129
130 %package javapure
131 Summary:        Java pure bindings for hyperestraier
132 Summary(pl.UTF-8):      Wiązania Javy do hyperestraiera w czystej Javie
133 License:        BSD-style
134 Group:          Libraries/Java
135
136 %description javapure
137 Java pure bindings for hyperestraier.
138
139 %description javapure -l pl.UTF-8
140 Wiązania Javy do hyperestraiera w czystej Javie.
141
142 %package rubynative
143 Summary:        Ruby native bindings for hyperestraier
144 Summary(pl.UTF-8):      Wiązania natywne języka Ruby do hyperestraiera
145 Group:          Development/Languages
146 Requires:       %{name}-libs = %{version}-%{release}
147
148 %description rubynative
149 Ruby native bindings for hyperestraier.
150
151 %description rubynative -l pl.UTF-8
152 Wiązania natywne języka Ruby do hyperestraiera.
153
154 %package rubypure
155 Summary:        Ruby pure bindings
156 Summary(pl.UTF-8):      Wiązania języka Ruby do hyperestraiera w czystym Rubym
157 License:        BSD-style
158 Group:          Development/Libraries
159
160 %description rubypure
161 Ruby pure bindings for hyperestraier.
162
163 %description rubypure -l pl.UTF-8
164 Wiązania języka Ruby do hyperestraiera w czystym Rubym.
165
166 %prep
167 %setup -q
168 %patch0 -p1
169 %patch1 -p1
170 %patch2 -p1
171
172 %build
173 %{__libtoolize}
174 %{__aclocal}
175 %{__autoconf}
176 %{__automake}
177 %configure \
178         --enable-fcgi%{!?with_fcgi:=no} \
179         --enable-static%{!?with_static_libs:=no}
180 %{__make}
181
182 %if %{with java}
183 export JAVA_HOME="%{java_home}"
184 cd javanative
185 %{__libtoolize}
186 %{__aclocal}
187 %{__autoconf}
188 %{__automake}
189 %configure \
190         --disable-static
191 %{__make}
192 cd ../javapure
193 %{__aclocal}
194 %{__autoconf}
195 %configure
196 %{__make}
197 cd ..
198 %endif
199
200 %if %{with ruby}
201 cd rubynative
202 %{__aclocal}
203 %{__autoconf}
204 %configure
205 %{__make}
206 cd ../rubypure
207 %{__aclocal}
208 %{__autoconf}
209 %configure
210 %{__make}
211 cd ..
212 %endif
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216
217 %{__make} install \
218         DESTDIR=$RPM_BUILD_ROOT
219
220 %if %{with java}
221 %{__make} -C javanative install \
222         DESTDIR=$RPM_BUILD_ROOT
223 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libjestraier.la
224
225 %{__make} -C javapure install \
226         DESTDIR=$RPM_BUILD_ROOT
227 %endif
228
229 %if %{with ruby}
230 %{__make} -C rubynative install \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 %{__make} -C rubypure install \
234         DESTDIR=$RPM_BUILD_ROOT
235 %endif
236
237 install %{SOURCE1} .
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %post   libs -p /sbin/ldconfig
243 %postun libs -p /sbin/ldconfig
244
245 %post   javanative -p /sbin/ldconfig
246 %postun javanative -p /sbin/ldconfig
247
248 %files
249 %defattr(644,root,root,755)
250 %doc ChangeLog README THANKS hyperestraier.sh
251 %attr(755,root,root) %{_bindir}/estbutler
252 %attr(755,root,root) %{_bindir}/estcall
253 %attr(755,root,root) %{_bindir}/estcmd
254 %attr(755,root,root) %{_bindir}/estload
255 %attr(755,root,root) %{_bindir}/estmaster
256 %attr(755,root,root) %{_bindir}/estmttest
257 %attr(755,root,root) %{_bindir}/estwaver
258 %attr(755,root,root) %{_bindir}/estwolefind
259 # don't move cgi binaries to /usr/lib/cgi-bin - write your own wrapper
260 # (shell script) instead, utilize SCRIPT_NAME env. var. and put into
261 # your cgi-bin directory
262 %dir %{_libexecdir}
263 %attr(755,root,root) %{_libexecdir}/est*.cgi
264 %{?with_fcgi:%attr(755,root,root) %{_libexecdir}/est*.fcgi}
265 %{_mandir}/man1/estcall.1*
266 %{_mandir}/man1/estcmd.1*
267 %{_mandir}/man1/estconfig.1*
268 %{_mandir}/man1/estmaster.1*
269 %{_mandir}/man1/estwaver.1*
270 %dir %{_datadir}/%{name}
271 # config templates - don't add to %%config, don't move it to /etc
272 %{_datadir}/%{name}/estseek.conf
273 %{_datadir}/%{name}/estseek.tmpl
274 %{_datadir}/%{name}/estseek.top
275 %{_datadir}/%{name}/estseek.help
276 %{_datadir}/%{name}/estresult.dtd
277 %{_datadir}/%{name}/estraier.idl
278 %{_datadir}/%{name}/estfraud.conf
279 %{_datadir}/%{name}/estproxy.conf
280 %{_datadir}/%{name}/estscout.conf
281 %{_datadir}/%{name}/estsupt.conf
282 %dir %{_datadir}/%{name}/filter
283 %{_datadir}/%{name}/filter/estfxmantotxt
284 %{_datadir}/%{name}/filter/estfxmsotohtml
285 %{_datadir}/%{name}/filter/estfxasis
286 %{_datadir}/%{name}/filter/estfxpdftohtml
287 %{_datadir}/%{name}/filter/estwnetxpnd
288 %{_datadir}/%{name}/filter/estfxxdwtotxt
289 %dir %{_datadir}/%{name}/increm
290 %{_datadir}/%{name}/increm/estseek-frame.html
291 %{_datadir}/%{name}/increm/estseek-form.html
292 %dir %{_datadir}/%{name}/locale
293 %lang(ja) %dir  %{_datadir}/%{name}/locale/ja
294 %lang(ja) %{_datadir}/%{name}/locale/ja/estseek.conf
295 %lang(ja) %{_datadir}/%{name}/locale/ja/estseek.help
296 %lang(ja) %{_datadir}/%{name}/locale/ja/estseek.tmpl
297 %lang(ja) %{_datadir}/%{name}/locale/ja/estseek.top
298
299 %files libs
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_libdir}/libestraier.so.*.*.*
302 %attr(755,root,root) %ghost %{_libdir}/libestraier.so.8
303
304 %files devel
305 %defattr(644,root,root,755)
306 %doc doc/*
307 %attr(755,root,root) %{_bindir}/estconfig
308 %attr(755,root,root) %{_libdir}/libestraier.so
309 %{_libdir}/libestraier.la
310 %{_includedir}/estmtdb.h
311 %{_includedir}/estnode.h
312 %{_includedir}/estraier.h
313 %{_pkgconfigdir}/hyperestraier.pc
314 %{_mandir}/man3/estnode.3*
315 %{_mandir}/man3/estraier.3*
316
317 %if %{with static_libs}
318 %files static
319 %defattr(644,root,root,755)
320 %{_libdir}/libestraier.a
321 %endif
322
323 %if %{with java}
324 %files javanative
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/libjestraier.so.*.*.*
327 %attr(755,root,root) %ghost %{_libdir}/libjestraier.so.1
328 %attr(755,root,root) %{_libdir}/libjestraier.so
329 %{_libdir}/estraier.jar
330
331 %files javapure
332 %defattr(644,root,root,755)
333 %{_libdir}/estraierpure.jar
334 %endif
335
336 %if %{with ruby}
337 %files rubynative
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/estcmd.rb
340 %attr(755,root,root) %{ruby_vendorarchdir}/estraier.so
341
342 %files rubypure
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_bindir}/estcall.rb
345 %{ruby_vendorlibdir}/estraierpure.rb
346 %endif
This page took 1.459311 seconds and 3 git commands to generate.