]> git.pld-linux.org Git - SPECS.git/blob - howl.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / howl.spec
1 Summary:        Cross platform implementation of Zeroconf
2 Summary(pl.UTF-8):      Międzyplatformowa implementacja Zeroconf
3 Name:           howl
4 Version:        1.0.0
5 Release:        7
6 License:        APSL / Other (see COPYING)
7 Group:          Libraries
8 Source0:        http://www.porchdogsoft.com/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  c389d3ffba0e69a179de2ec650f1fdcc
10 Source1:        mDNSResponder-%{name}.init
11 Source2:        nifd.init
12 Source3:        mDNSResponder.conf
13 Patch0:         %{name}-libdir.patch
14 Patch1:         %{name}-pkgconfig.patch
15 Patch2:         %{name}-am.patch
16 Patch3:         %{name}-alpha.patch
17 Patch4:         %{name}-link.patch
18 URL:            http://www.porchdogsoft.com/products/howl/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       rc-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Howl is a cross-platform implementation of Zeroconf networking.
29 Zeroconf brings a new ease of use to IP networking.
30
31 %description -l pl.UTF-8
32 Howl jest międzyplatformową implementacją Zeroconf. Zeroconf przynosi
33 nową łatwość przy pracy w sieci IP.
34
35 %package libs
36 Summary:        Howl libraries
37 Summary(pl.UTF-8):      Biblioteki howl
38 Group:          Libraries
39 Provides:       mdns-howl-libs
40
41 %description libs
42 Howl libraries.
43
44 %description libs -l pl.UTF-8
45 Biblioteki howl.
46
47 %package devel
48 Summary:        Header files for howl library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki howl
50 Group:          Development/Libraries
51 Requires:       %{name}-libs = %{version}-%{release}
52 Provides:       mdns-howl-devel
53
54 %description devel
55 Header files for howl library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki howl.
59
60 %package static
61 Summary:        Static howl library
62 Summary(pl.UTF-8):      Statyczna biblioteka howl
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65 Provides:       mdns-howl-static
66
67 %description static
68 Static howl library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka howl.
72
73 %prep
74 %setup -q
75 %patch0 -p0
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/etc/rc.d/init.d}
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mDNSResponder
98 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/nifd
99 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/mDNSResponder.conf
100
101 # fix up header file directory naming bug
102 mv $RPM_BUILD_ROOT%{_includedir}/%{name} $RPM_BUILD_ROOT%{_includedir}/%{name}-%{version}
103
104 # remove the samples
105 %{__rm} $RPM_BUILD_ROOT%{_bindir}/mDNSBrowse
106 %{__rm} $RPM_BUILD_ROOT%{_bindir}/mDNSPublish
107 %{__rm} $RPM_BUILD_ROOT%{_bindir}/mDNSQuery
108 %{__rm} $RPM_BUILD_ROOT%{_bindir}/mDNSResolve
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 /sbin/chkconfig --add mDNSResponder
115 %service mDNSResponder restart
116
117 /sbin/chkconfig --add nifd
118 %service nifd restart
119
120 %preun
121 if [ "$1" = "0" ]; then
122         %service mDNSResponder stop
123         /sbin/chkconfig --del mDNSResponder
124
125         %service nifd stop
126         /sbin/chkconfig --del nifd
127 fi
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog COPYING NEWS README TODO
135 %attr(755,root,root) %{_bindir}/autoipd
136 %attr(755,root,root) %{_bindir}/mDNSResponder
137 %attr(755,root,root) %{_bindir}/nifd
138 %attr(754,root,root) /etc/rc.d/init.d/mDNSResponder
139 %attr(754,root,root) /etc/rc.d/init.d/nifd
140 %dir %{_sysconfdir}/%{name}
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/mDNSResponder.conf
142 %{_datadir}/%{name}
143 %{_mandir}/man8/autoipd.8*
144 %{_mandir}/man8/mDNSResponder.8*
145 %{_mandir}/man8/nifd.8*
146
147 %files libs
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
150 %ghost %{_libdir}/libhowl.so.0
151 %attr(755,root,root) %{_libdir}/libmDNSResponder.so.*.*.*
152 %ghost %{_libdir}/libmDNSResponder.so.0
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc docs/*.html
157 %{_libdir}/libhowl.so
158 %{_libdir}/libmDNSResponder.so
159 %{_libdir}/libhowl.la
160 %{_libdir}/libmDNSResponder.la
161 %{_includedir}/%{name}-%{version}
162 %{_pkgconfigdir}/howl.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libhowl.a
167 %{_libdir}/libmDNSResponder.a
This page took 0.686783 seconds and 3 git commands to generate.