]> git.pld-linux.org Git - packages/hostapd.git/blob - hostapd.spec
- init release, based on hostap.spec
[packages/hostapd.git] / hostapd.spec
1 %define rel     0.3
2
3 Summary:        HostAP - acts as an access point
4 Summary(es):    HostAP - actúa como un punto de acceso
5 Summary(pl):    HostAP - praca jako access point
6 Name:           hostapd
7 Version:        0.1.0
8 Release:        %{rel}
9 License:        GPL
10 Group:          Daemons
11 Source0:        http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  6be6bb611ee624c66d94dbca104721e9
13 Source1:        %{name}.init
14 URL:            http://hostap.epitest.fi/
15 BuildRequires:  %{kgcc_package}
16 BuildRequires:  rpmbuild(macros) >= 1.118
17 BuildRequires:  kernel-headers
18 Requires:       kernel-net-hostap
19 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This package contains utilities and userspace daemon for the Linux
23 driver for wireless LAN cards based on Intersil's Prism2/2.5/3
24 chipset. The driver supports a so called Host AP mode, i.e., it takes
25 care of IEEE 802.11 management functions in the host computer and acts
26 as an access point. This does not require any special firmware for the
27 wireless LAN card. In addition to this, it has support for normal
28 station operations in BSS and possible also in IBSS.
29
30 %description -l es
31 Este paquete contiene unas herramientas y un servidor del espacio de
32 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
33 Prism2/2.5/3. El driver soporta el llamado modo Host AP, es decir, se
34 encarga de las funciones administrativas el el host, actuando como
35 "access point". Ello no requiere ningún firmware especial para la
36 tarjeta LAN inalámbrica. Además, también hay soporte para operaciones
37 normales de estación en BSS y posiblemente también en IBSS.
38
39 %description -l pl
40 Ten pakiet zawiera narzêdzia oraz demona dzia³aj±cego w przestrzeni
41 u¿ytkownika dla linuksowego sterownika kart sieci bezprzewodowych
42 opartych na uk³adach Intersil Prism2/2.5/3. Sterownik obs³uguje tak
43 zwany tryb Host AP, czyli dba o funkcje zarz±dzaj±ce IEEE 802.11 na
44 komputerze i dzia³a jako access point. Nie wymaga to ¿adnego
45 specjalnego firmware dla karty sieci bezprzewodowej. Ponadto ma
46 obs³ugê normalnych operacji stacyjnych w BSS, a byæ mo¿e tak¿e IBSS.
47
48 %prep
49 %setup -q
50
51 %build
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia}}
58 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
59
60 #hostapd
61 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
62 install hostapd $RPM_BUILD_ROOT/sbin
63
64 #hostapd configuration
65 install hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
66 install hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
67 install hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
68
69 %post
70 /sbin/chkconfig --add hostapd
71 if [ -r /var/lock/subsys/hostapd ]; then
72         /etc/rc.d/init.d/hostapd restart >&2
73 else
74         echo "Run \"/etc/rc.d/init.d/hostapd start\" to start HostAP daemons."
75 fi
76
77 %preun
78 if [ "$1" = "0" ]; then
79         if [ -r /var/lock/subsys/hostapd ]; then
80                 /etc/rc.d/init.d/hostapd stop >&2
81         fi
82         /sbin/chkconfig --del hostapd
83 fi
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README
91 %dir %{_sysconfdir}/hostap
92 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/hostap/*
93 %attr(755,root,root) /sbin/hostapd
94 %attr(754,root,root) /etc/rc.d/init.d/hostapd
This page took 0.055577 seconds and 4 git commands to generate.