]> git.pld-linux.org Git - packages/hostapd.git/blob - hostapd.spec
- cosmetics
[packages/hostapd.git] / hostapd.spec
1 %define rel     1
2
3 Summary:        HostAP - acts as an access point
4 Summary(es):    HostAP - actúa como un punto de acceso
5 Summary(pl):    HostAP - praca jako access point
6 Name:           hostapd
7 Version:        0.1.0
8 Release:        %{rel}
9 License:        GPL
10 Group:          Daemons
11 Source0:        http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  6be6bb611ee624c66d94dbca104721e9
13 Source1:        %{name}.init
14 Patch0:         %{name}-config.patch
15 URL:            http://hostap.epitest.fi/
16 BuildRequires:  %{kgcc_package}
17 BuildRequires:  rpmbuild(macros) >= 1.118
18 BuildRequires:  kernel-headers
19 Requires:       kernel-net-hostap >= 0.1.2
20 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package contains utilities and userspace daemon for the Linux
24 driver for wireless LAN cards based on Intersil's Prism2/2.5/3
25 chipset. The driver supports a so called Host AP mode, i.e., it takes
26 care of IEEE 802.11 management functions in the host computer and acts
27 as an access point. This does not require any special firmware for the
28 wireless LAN card. In addition to this, it has support for normal
29 station operations in BSS and possible also in IBSS.
30
31 %description -l es
32 Este paquete contiene unas herramientas y un servidor del espacio de
33 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
34 Prism2/2.5/3. El driver soporta el llamado modo Host AP, es decir, se
35 encarga de las funciones administrativas el el host, actuando como
36 "access point". Ello no requiere ningún firmware especial para la
37 tarjeta LAN inalámbrica. Además, también hay soporte para operaciones
38 normales de estación en BSS y posiblemente también en IBSS.
39
40 %description -l pl
41 Ten pakiet zawiera narzêdzia oraz demona dzia³aj±cego w przestrzeni
42 u¿ytkownika dla linuksowego sterownika kart sieci bezprzewodowych
43 opartych na uk³adach Intersil Prism2/2.5/3. Sterownik obs³uguje tak
44 zwany tryb Host AP, czyli dba o funkcje zarz±dzaj±ce IEEE 802.11 na
45 komputerze i dzia³a jako access point. Nie wymaga to ¿adnego
46 specjalnego firmware dla karty sieci bezprzewodowej. Ponadto ma
47 obs³ugê normalnych operacji stacyjnych w BSS, a byæ mo¿e tak¿e IBSS.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52 %build
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia}}
59 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
60
61 #hostapd
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
63 install hostapd $RPM_BUILD_ROOT/sbin
64
65 #hostapd configuration
66 install hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
67 install hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
68 install hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
69
70 %post
71 /sbin/chkconfig --add hostapd
72 if [ -r /var/lock/subsys/hostapd ]; then
73         /etc/rc.d/init.d/hostapd restart >&2
74 else
75         echo "Run \"/etc/rc.d/init.d/hostapd start\" to start HostAP daemons."
76 fi
77
78 %preun
79 if [ "$1" = "0" ]; then
80         if [ -r /var/lock/subsys/hostapd ]; then
81                 /etc/rc.d/init.d/hostapd stop >&2
82         fi
83         /sbin/chkconfig --del hostapd
84 fi
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README
92 %dir %{_sysconfdir}/hostap
93 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/hostap/*
94 %attr(755,root,root) /sbin/hostapd
95 %attr(754,root,root) /etc/rc.d/init.d/hostapd
This page took 0.030488 seconds and 3 git commands to generate.