]> git.pld-linux.org Git - SPECS.git/blob - hlds.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / hlds.spec
1 #
2 # Conditional build:
3 %bcond_without  cstrike         # without Counter-Strike server
4 %bcond_with     dmc             # without Death-Match-Classic server
5 %bcond_with     ricochet        # without Ricochet server
6 %bcond_with     tfc             # without Team-Fortress server
7 #
8 Summary:        Half-Life - Linux Dedicated Server
9 Summary(pl.UTF-8):      Dedykowany serwer gry Half-Life dla Linuksa
10 Name:           hlds
11 Version:        1.1.2.0.STEAM
12 Release:        1
13 License:        custom (EULA), non-distributable
14 Group:          Applications/Games
15 Source0:        %{name}_l_1120_full.tar.bz2
16 # NoSource0-md5:        12ff9d0161575b8b8180b7f0041af036
17 BuildRequires:  rpmbuild(macros) >= 1.202
18 Requires(pre):  /bin/id
19 Requires(pre):  /usr/bin/getgid
20 Requires(pre):  /usr/sbin/groupadd
21 Requires(pre):  /usr/sbin/useradd
22 Requires(postun):       /usr/sbin/groupdel
23 Requires(postun):       /usr/sbin/userdel
24 Provides:       group(hlds)
25 Provides:       user(hlds)
26 ExclusiveArch:  %{ix86}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _chroot_home    /home/hlds
30
31 %description
32 Linux Dedicated Server of Half-Life Game.
33
34 %description -l pl.UTF-8
35 Dedykowany serwer gry Half-Life pod Linuksa.
36
37 %package cstrike
38 Summary:        Counter-Strike - Linux Dedicated Server
39 Summary(pl.UTF-8):      Dedykowany serwer gry Counter-Strike dla Linuksa
40 Group:          Applications/Games
41 Requires:       %{name} = %{version}-%{release}
42
43 %description cstrike
44 Linux Dedicated Server of Counter-Strike Game based on Half-Life
45 server.
46
47 %description cstrike -l pl.UTF-8
48 Dedykowany serwer gry Counter-Strike pod Linuksa oparty o serwer
49 Half-Life.
50
51 %package dmc
52 Summary:        Death-Match-Classic - Linux Dedicated Server
53 Summary(pl.UTF-8):      Dedykowany serwer gry Death-Match-Classic dla Linuksa
54 Group:          Applications/Games
55 Requires:       %{name} = %{version}-%{release}
56
57 %description dmc
58 Linux Dedicated Server of Death-Match-Classic Game based on Half-Life
59 server.
60
61 %description dmc -l pl.UTF-8
62 Dedykowany serwer gry Death-Match-Classic pod Linuksa oparty o serwer
63 Half-Life.
64
65 %package ricochet
66 Summary:        Ricochet - Linux Dedicated Server
67 Summary(pl.UTF-8):      Dedykowany serwer gry Ricochet dla Linuksa
68 Group:          Applications/Games
69 Requires:       %{name} = %{version}-%{release}
70
71 %description ricochet
72 Linux Dedicated Server of Ricochet Game based on Half-Life server.
73
74 %description ricochet -l pl.UTF-8
75 Dedykowany serwer gry Ricochet pod Linuksa oparty o serwer Half-Life.
76
77 %package tfc
78 Summary:        Team-Fortress - Linux Dedicated Server
79 Summary(pl.UTF-8):      Dedykowany serwer gry Team-Fortress dla Linuksa
80 Group:          Applications/Games
81 Requires:       %{name} = %{version}-%{release}
82
83 %description tfc
84 Linux Dedicated Server of Team-Fortress Game based on Half-Life
85 server.
86
87 %description tfc -l pl.UTF-8
88 Dedykowany serwer gry Team-Fortress pod Linuksa oparty o serwer
89 Half-Life.
90
91 %prep
92 %setup -q -n hlds_l
93
94 %build
95 chmod u+w ./hlds_run
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_chroot_home}/{cstrike,dmc,ricochet,tfc,valve}
100 install -d $RPM_BUILD_ROOT%{_libdir}
101
102 install hlds_run hltv hlds_amd hlds_amd64 hlds_i486 hlds_i686 steam $RPM_BUILD_ROOT%{_chroot_home}
103 install core_i386.so proxy_i386.so engine_amd.so engine_amd64.so engine_i486.so engine_i686.so filesystem_stdio_i386.so filesystem_stdio_amd64.so $RPM_BUILD_ROOT%{_chroot_home}
104 install libSteamValidateUserIDTickets_amd64.so libSteamValidateUserIDTickets_i386.so $RPM_BUILD_ROOT%{_libdir}
105
106 # mv is for save space on HDD
107
108 %if %{with cstrike}
109 mv cstrike/* $RPM_BUILD_ROOT%{_chroot_home}/cstrike
110 %endif
111
112 %if %{with dmc}
113 mv dmc/* $RPM_BUILD_ROOT%{_chroot_home}/dmc
114 %endif
115 %if %{with ricochet}
116 mv ricochet/* $RPM_BUILD_ROOT%{_chroot_home}/ricochet
117 %endif
118 %if %{with tfc}
119 mv tfc/* $RPM_BUILD_ROOT%{_chroot_home}/tfc
120 %endif
121
122 mv valve/* $RPM_BUILD_ROOT%{_chroot_home}/valve
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %pre
128 %groupadd -g 36 hlds
129 %useradd -u 23 -d %{_chroot_home} -s /bin/bash -c "Half-Life Dedicated Server" -g hlds hlds
130
131 %postun
132 if [ "$1" = "0" ]; then
133         %userremove hlds
134         %groupremove hlds
135 fi
136
137 %files
138 %defattr(644,hlds,hlds,755)
139 %doc linuxreadme.txt
140 %dir %{_chroot_home}
141 %attr(755,hlds,hlds) %{_chroot_home}/hlds_amd
142 %attr(755,hlds,hlds) %{_chroot_home}/hlds_amd64
143 %attr(755,hlds,hlds) %{_chroot_home}/hlds_i486
144 %attr(755,hlds,hlds) %{_chroot_home}/hlds_i686
145 %attr(755,hlds,hlds) %{_chroot_home}/hlds_run
146 %attr(755,hlds,hlds) %{_chroot_home}/hltv
147 %attr(755,hlds,hlds) %{_chroot_home}/steam
148 %attr(755,hlds,hlds) %{_chroot_home}/*.so
149
150 %dir %{_chroot_home}/valve
151 %{_chroot_home}/valve/*.cfg
152 %{_chroot_home}/valve/*.txt
153 %{_chroot_home}/valve/*.lst
154 %{_chroot_home}/valve/*.wad
155 %{_chroot_home}/valve/game.ico
156 %{_chroot_home}/valve/valve.rc
157 %{_chroot_home}/valve/liblist.gam
158 %{_chroot_home}/valve/server.cfg
159 %{_chroot_home}/valve/steam.inf
160 %dir %{_chroot_home}/valve/cl_dlls
161 %{_chroot_home}/valve/cl_dlls/client.dll
162 %dir %{_chroot_home}/valve/dlls
163 %{_chroot_home}/valve/dlls/hl.dll
164 %{_chroot_home}/valve/dlls/hl_i386.so
165 %{_chroot_home}/valve/dlls/hl_amd64.so
166 %dir %{_chroot_home}/valve/events
167 %{_chroot_home}/valve/events/*.sc
168 %dir %{_chroot_home}/valve/gfx
169 %dir %{_chroot_home}/valve/maps
170 %{_chroot_home}/valve/maps/*.bsp
171 %dir %{_chroot_home}/valve/models
172 %{_chroot_home}/valve/models/*.mdl
173 %dir %{_chroot_home}/valve/models/player
174 %dir %{_chroot_home}/valve/models/player/barney
175 %{_chroot_home}/valve/models/player/barney/barney.mdl
176 %dir %{_chroot_home}/valve/models/player/gina
177 %{_chroot_home}/valve/models/player/gina/Gina.mdl
178 %dir %{_chroot_home}/valve/models/player/gman
179 %{_chroot_home}/valve/models/player/gman/Gman.mdl
180 %dir %{_chroot_home}/valve/models/player/gordon
181 %{_chroot_home}/valve/models/player/gordon/gordon.mdl
182 %dir %{_chroot_home}/valve/models/player/helmet
183 %{_chroot_home}/valve/models/player/helmet/Helmet.mdl
184 %dir %{_chroot_home}/valve/models/player/hgrunt
185 %{_chroot_home}/valve/models/player/hgrunt/Hgrunt.mdl
186 %dir %{_chroot_home}/valve/models/player/recon
187 %{_chroot_home}/valve/models/player/recon/recon.mdl
188 %dir %{_chroot_home}/valve/models/player/robo
189 %{_chroot_home}/valve/models/player/robo/robo.mdl
190 %dir %{_chroot_home}/valve/models/player/scientist
191 %{_chroot_home}/valve/models/player/scientist/Scientist.mdl
192 %dir %{_chroot_home}/valve/models/player/zombie
193 %{_chroot_home}/valve/models/player/zombie/zombie.mdl
194 %dir %{_chroot_home}/valve/scripts
195 %{_chroot_home}/valve/scripts/voicemodel.txt
196 %dir %{_chroot_home}/valve/sound
197 %{_chroot_home}/valve/sound/*.txt
198 %dir %{_chroot_home}/valve/sound/agrunt
199 %{_chroot_home}/valve/sound/agrunt/*.wav
200 %dir %{_chroot_home}/valve/sound/ambience
201 %{_chroot_home}/valve/sound/ambience/*.wav
202 %dir %{_chroot_home}/valve/sound/buttons
203 %{_chroot_home}/valve/sound/buttons/*.wav
204 %dir %{_chroot_home}/valve/sound/fvox
205 %{_chroot_home}/valve/sound/fvox/beep.wav
206 %dir %{_chroot_home}/valve/sound/hornet
207 %{_chroot_home}/valve/sound/hornet/*.wav
208 %dir %{_chroot_home}/valve/sound/plats
209 %{_chroot_home}/valve/sound/plats/*.wav
210 %dir %{_chroot_home}/valve/sound/player
211 %{_chroot_home}/valve/sound/player/*.wav
212 %dir %{_chroot_home}/valve/sound/squeek
213 %{_chroot_home}/valve/sound/squeek/*.wav
214 %dir %{_chroot_home}/valve/sound/turret
215 %{_chroot_home}/valve/sound/turret/*.wav
216 %dir %{_chroot_home}/valve/sound/UI
217 %{_chroot_home}/valve/sound/UI/*.wav
218 %dir %{_chroot_home}/valve/sprites
219 %{_chroot_home}/valve/sprites/*.spr
220 %{_chroot_home}/valve/sprites/*.txt
221
222 %attr(755,root,root) %{_libdir}/*.so
223
224 %if %{with cstrike}
225 %files cstrike
226 %defattr(644,hlds,hlds,755)
227 %dir %{_chroot_home}/cstrike
228 %{_chroot_home}/cstrike/*.wad
229 %{_chroot_home}/cstrike/*.txt
230 %{_chroot_home}/cstrike/GameServerConfig.vdf
231 %{_chroot_home}/cstrike/cs_havana.WAD
232 %{_chroot_home}/cstrike/liblist.gam
233 %{_chroot_home}/cstrike/delta.lst
234 %{_chroot_home}/cstrike/server.cfg
235 %{_chroot_home}/cstrike/steam.inf
236 %dir %{_chroot_home}/cstrike/cl_dlls
237 %{_chroot_home}/cstrike/cl_dlls/client.dll
238 %dir %{_chroot_home}/cstrike/dlls
239 %{_chroot_home}/cstrike/dlls/cs_i386.so
240 %{_chroot_home}/cstrike/dlls/cs_amd64.so
241 %{_chroot_home}/cstrike/dlls/mp.dll
242 %dir %{_chroot_home}/cstrike/events
243 %{_chroot_home}/cstrike/events/*.sc
244 %dir %{_chroot_home}/cstrike/manual
245 %{_chroot_home}/cstrike/manual/manual.htm
246 %dir %{_chroot_home}/cstrike/maps
247 %{_chroot_home}/cstrike/maps/*.bsp
248 %dir %{_chroot_home}/cstrike/models
249 %{_chroot_home}/cstrike/models/*.mdl
250 %{_chroot_home}/cstrike/models/grass_01.spr
251 %dir %{_chroot_home}/cstrike/models/shield
252 %{_chroot_home}/cstrike/models/shield/*.mdl
253 %dir %{_chroot_home}/cstrike/models/player
254 %dir %{_chroot_home}/cstrike/models/player/arctic
255 %{_chroot_home}/cstrike/models/player/arctic/arctic.mdl
256 %dir %{_chroot_home}/cstrike/models/player/gign
257 %{_chroot_home}/cstrike/models/player/gign/gign.mdl
258 %dir %{_chroot_home}/cstrike/models/player/gsg9
259 %{_chroot_home}/cstrike/models/player/gsg9/gsg9.mdl
260 %dir %{_chroot_home}/cstrike/models/player/guerilla
261 %{_chroot_home}/cstrike/models/player/guerilla/guerilla.mdl
262 %dir %{_chroot_home}/cstrike/models/player/leet
263 %{_chroot_home}/cstrike/models/player/leet/leet.mdl
264 %dir %{_chroot_home}/cstrike/models/player/sas
265 %{_chroot_home}/cstrike/models/player/sas/sas.mdl
266 %dir %{_chroot_home}/cstrike/models/player/terror
267 %{_chroot_home}/cstrike/models/player/terror/terror.mdl
268 %dir %{_chroot_home}/cstrike/models/player/urban
269 %{_chroot_home}/cstrike/models/player/urban/urban.mdl
270 %dir %{_chroot_home}/cstrike/models/player/vip
271 %{_chroot_home}/cstrike/models/player/vip/vip.mdl
272 %dir %{_chroot_home}/cstrike/sound
273 %{_chroot_home}/cstrike/sound/*.txt
274 %dir %{_chroot_home}/cstrike/sound/ambience
275 %{_chroot_home}/cstrike/sound/ambience/*.wav
276 %dir %{_chroot_home}/cstrike/sound/de_torn
277 %{_chroot_home}/cstrike/sound/de_torn/*.wav
278 %dir %{_chroot_home}/cstrike/sound/hostage
279 %{_chroot_home}/cstrike/sound/hostage/*.wav
280 %dir %{_chroot_home}/cstrike/sound/items
281 %{_chroot_home}/cstrike/sound/items/*.wav
282 %dir %{_chroot_home}/cstrike/sound/misc
283 %{_chroot_home}/cstrike/sound/misc/*.wav
284 %dir %{_chroot_home}/cstrike/sound/plats
285 %{_chroot_home}/cstrike/sound/plats/*.wav
286 %dir %{_chroot_home}/cstrike/sound/player
287 %{_chroot_home}/cstrike/sound/player/*.wav
288 %dir %{_chroot_home}/cstrike/sound/radio
289 %{_chroot_home}/cstrike/sound/radio/*.wav
290 %dir %{_chroot_home}/cstrike/sound/storm
291 %{_chroot_home}/cstrike/sound/storm/*.wav
292 %dir %{_chroot_home}/cstrike/sound/weapons
293 %{_chroot_home}/cstrike/sound/weapons/*.wav
294 %dir %{_chroot_home}/cstrike/sprites
295 %{_chroot_home}/cstrike/sprites/*.spr
296 %{_chroot_home}/cstrike/sprites/scope_arc.tga
297 %dir %{_chroot_home}/cstrike/sprites/effects
298 %{_chroot_home}/cstrike/sprites/effects/*.spr
299 %endif
300
301 %if %{with dmc}
302 %files dmc
303 %defattr(644,hlds,hlds,755)
304 %dir %{_chroot_home}/dmc
305 %{_chroot_home}/dmc/*.txt
306 %{_chroot_home}/dmc/*.wad
307 %{_chroot_home}/dmc/game.ico
308 %{_chroot_home}/dmc/server.cfg
309 %{_chroot_home}/dmc/steam.inf
310 %{_chroot_home}/dmc/liblist.gam
311 %{_chroot_home}/dmc/delta.lst
312 %dir %{_chroot_home}/dmc/cl_dlls
313 %{_chroot_home}/dmc/cl_dlls/client.dll
314 %dir %{_chroot_home}/dmc/dlls
315 %{_chroot_home}/dmc/dlls/dmc_i386.so
316 %{_chroot_home}/dmc/dlls/dmc.dll
317 %dir %{_chroot_home}/dmc/events
318 %{_chroot_home}/dmc/events/*.sc
319 %dir %{_chroot_home}/dmc/events/door
320 %{_chroot_home}/dmc/events/door/*.sc
321 %dir %{_chroot_home}/dmc/maps
322 %{_chroot_home}/dmc/maps/*.bsp
323 %dir %{_chroot_home}/dmc/models
324 %{_chroot_home}/dmc/models/*.mdl
325 %dir %{_chroot_home}/dmc/sound
326 %dir %{_chroot_home}/dmc/sound/ambience
327 %{_chroot_home}/dmc/sound/ambience/*.wav
328 %dir %{_chroot_home}/dmc/sound/items
329 %{_chroot_home}/dmc/sound/items/*.wav
330 %dir %{_chroot_home}/dmc/sound/misc
331 %{_chroot_home}/dmc/sound/misc/*.wav
332 %dir %{_chroot_home}/dmc/sound/player
333 %{_chroot_home}/dmc/sound/player/*.wav
334 %dir %{_chroot_home}/dmc/sound/weapons
335 %{_chroot_home}/dmc/sound/weapons/*.wav
336 %dir %{_chroot_home}/dmc/resource/
337 %{_chroot_home}/dmc/resource/*.tga
338 %{_chroot_home}/dmc/resource/GameMenu.res
339 %{_chroot_home}/dmc/resource/dmc_english.txt
340 %{_chroot_home}/dmc/resource/game_menu.TGA
341 %dir %{_chroot_home}/dmc/sprites
342 %{_chroot_home}/dmc/sprites/*.spr
343 %{_chroot_home}/dmc/sprites/*.txt
344 %{_chroot_home}/dmc/sprites/logo.qc
345 %{_chroot_home}/dmc/sprites/flash1.tga
346 %endif
347
348 %if %{with ricochet}
349 %files ricochet
350 %defattr(644,hlds,hlds,755)
351 %dir %{_chroot_home}/ricochet
352 %{_chroot_home}/ricochet/*.txt
353 %{_chroot_home}/ricochet/delta.lst
354 %{_chroot_home}/ricochet/game.ico
355 %{_chroot_home}/ricochet/liblist.gam
356 %{_chroot_home}/ricochet/*.wad
357 %{_chroot_home}/ricochet/steam.inf
358 %dir %{_chroot_home}/ricochet/cl_dlls
359 %{_chroot_home}/ricochet/cl_dlls/client.dll
360 %dir %{_chroot_home}/ricochet/dlls
361 %{_chroot_home}/ricochet/dlls/mp.dll
362 %{_chroot_home}/ricochet/dlls/ricochet_i386.so
363 %dir %{_chroot_home}/ricochet/events
364 %{_chroot_home}/ricochet/events/*.sc
365 %dir %{_chroot_home}/ricochet/maps
366 %{_chroot_home}/ricochet/maps/*.bsp
367 %dir %{_chroot_home}/ricochet/models
368 %{_chroot_home}/ricochet/models/*.mdl
369 %dir %{_chroot_home}/ricochet/models/player
370 %dir %{_chroot_home}/ricochet/models/player/female
371 %{_chroot_home}/ricochet/models/player/female/female.mdl
372 %dir %{_chroot_home}/ricochet/models/player/male
373 %{_chroot_home}/ricochet/models/player/male/*.mdl
374 %dir %{_chroot_home}/ricochet/sound
375 %{_chroot_home}/ricochet/sound/*.wav
376 %dir %{_chroot_home}/ricochet/sound/Items
377 %{_chroot_home}/ricochet/sound/Items/gunpickup2.wav
378 %dir %{_chroot_home}/ricochet/sound/Vox
379 %{_chroot_home}/ricochet/sound/Vox/*.wav
380 %{_chroot_home}/ricochet/sound/Vox/*.WAV
381 %dir %{_chroot_home}/ricochet/sound/Weapons
382 %{_chroot_home}/ricochet/sound/Weapons/*.wav
383 %dir %{_chroot_home}/ricochet/sprites
384 %{_chroot_home}/ricochet/sprites/*.spr
385 %{_chroot_home}/ricochet/sprites/*.txt
386 %endif
387
388 %if %{with tfc}
389 %files tfc
390 %defattr(644,hlds,hlds,755)
391 %dir %{_chroot_home}/tfc
392 %{_chroot_home}/tfc/*.txt
393 %{_chroot_home}/tfc/delta.lst
394 %{_chroot_home}/tfc/game.ico
395 %{_chroot_home}/tfc/liblist.gam
396 %{_chroot_home}/tfc/steam.inf
397 %{_chroot_home}/tfc/*.wad
398 %{_chroot_home}/tfc/tfc.WAD
399 %{_chroot_home}/tfc/GameServerConfig.vdf
400 %dir %{_chroot_home}/tfc/cl_dlls
401 %{_chroot_home}/tfc/cl_dlls/client.dll
402 %dir %{_chroot_home}/tfc/dlls
403 %{_chroot_home}/tfc/dlls/tfc_i386.so
404 %{_chroot_home}/tfc/dlls/tfc.dll
405 %dir %{_chroot_home}/tfc/events
406 %dir %{_chroot_home}/tfc/events/door
407 %{_chroot_home}/tfc/events/door/*.sc
408 %dir %{_chroot_home}/tfc/events/explode
409 %{_chroot_home}/tfc/events/explode/*.sc
410 %dir %{_chroot_home}/tfc/events/misc
411 %{_chroot_home}/tfc/events/misc/*.sc
412 %dir %{_chroot_home}/tfc/events/wpn
413 %{_chroot_home}/tfc/events/wpn/*.sc
414 %dir %{_chroot_home}/tfc/manual
415 %{_chroot_home}/tfc/manual/*.gif
416 %{_chroot_home}/tfc/manual/*.htm
417 %{_chroot_home}/tfc/manual/*.jpg
418 %{_chroot_home}/tfc/manual/regexp.html
419 %dir %{_chroot_home}/tfc/maps
420 %{_chroot_home}/tfc/maps/*.bsp
421 %dir %{_chroot_home}/tfc/models
422 %{_chroot_home}/tfc/models/*.mdl
423 %dir %{_chroot_home}/tfc/models/player
424 %dir %{_chroot_home}/tfc/models/player/civilian
425 %{_chroot_home}/tfc/models/player/civilian/civilian.mdl
426 %dir %{_chroot_home}/tfc/models/player/demo
427 %{_chroot_home}/tfc/models/player/demo/*.mdl
428 %dir %{_chroot_home}/tfc/models/player/engineer
429 %{_chroot_home}/tfc/models/player/engineer/*.mdl
430 %dir %{_chroot_home}/tfc/models/player/hvyweapon
431 %{_chroot_home}/tfc/models/player/hvyweapon/*.mdl
432 %dir %{_chroot_home}/tfc/models/player/medic
433 %{_chroot_home}/tfc/models/player/medic/*.mdl
434 %dir %{_chroot_home}/tfc/models/player/pyro
435 %{_chroot_home}/tfc/models/player/pyro/*.mdl
436 %dir %{_chroot_home}/tfc/models/player/scout
437 %{_chroot_home}/tfc/models/player/scout/*.mdl
438 %dir %{_chroot_home}/tfc/models/player/sniper
439 %{_chroot_home}/tfc/models/player/sniper/*.mdl
440 %dir %{_chroot_home}/tfc/models/player/soldier
441 %{_chroot_home}/tfc/models/player/soldier/*.mdl
442 %dir %{_chroot_home}/tfc/models/player/spy
443 %{_chroot_home}/tfc/models/player/spy/*.mdl
444 %dir %{_chroot_home}/tfc/resource
445 %{_chroot_home}/tfc/resource/*.res
446 %{_chroot_home}/tfc/resource/*.tga
447 %{_chroot_home}/tfc/resource/tfc_english.txt
448 %dir %{_chroot_home}/tfc/resource/UI
449 %{_chroot_home}/tfc/resource/UI/*.res
450 %dir %{_chroot_home}/tfc/sound
451 %dir %{_chroot_home}/tfc/sound/ambience
452 %{_chroot_home}/tfc/sound/ambience/*.wav
453 %dir %{_chroot_home}/tfc/sound/items
454 %{_chroot_home}/tfc/sound/items/*.wav
455 %dir %{_chroot_home}/tfc/sound/misc
456 %{_chroot_home}/tfc/sound/misc/*.wav
457 %dir %{_chroot_home}/tfc/sound/player
458 %{_chroot_home}/tfc/sound/player/*.wav
459 %{_chroot_home}/tfc/sound/sentences.txt
460 %dir %{_chroot_home}/tfc/sound/speech
461 %{_chroot_home}/tfc/sound/speech/*.wav
462 %dir %{_chroot_home}/tfc/sound/vox
463 %{_chroot_home}/tfc/sound/vox/*.wav
464 %dir %{_chroot_home}/tfc/sound/weapons
465 %{_chroot_home}/tfc/sound/weapons/*.wav
466 %dir %{_chroot_home}/tfc/sprites
467 %{_chroot_home}/tfc/sprites/*.spr
468 %{_chroot_home}/tfc/sprites/*.txt
469 %{_chroot_home}/tfc/sprites/*.qc
470 %dir %{_chroot_home}/tfc/sprites/bmp
471 %{_chroot_home}/tfc/sprites/bmp/*.bmp
472 %dir %{_chroot_home}/tfc/sprites/hudbmps
473 %{_chroot_home}/tfc/sprites/hudbmps/*.bmp
474 %endif
This page took 2.82546 seconds and 3 git commands to generate.