]> git.pld-linux.org Git - SPECS.git/blob - heroes.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / heroes.spec
1 %bcond_without  ggi     # without ggi support
2 %bcond_without  sdl     # without sdl support
3
4 Summary:        Game like Nibbles
5 Summary(pl.UTF-8):      Gra w stylu Nibbles
6 Name:           heroes
7 Version:        0.21
8 Release:        2
9 License:        GPL
10 Group:          Applications/Games
11 Source0:        http://dl.sourceforge.net/heroes/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gkh.patch
13 # Source0-md5:  ec608676e2e75abdfddf8072bb3b28db
14 URL:            http://heroes.sourceforge.net/
15 %if %{with sdl}
16 BuildRequires:  SDL-devel
17 BuildRequires:  SDL_mixer-devel
18 %endif
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  gettext
22 %if %{with ggi}
23 BuildRequires:  libggi-devel
24 BuildRequires:  libgii-devel
25 BuildRequires:  libmikmod-devel
26 %endif
27 Requires:       %{name}-data
28 Requires:       %{name}-engine
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Heroes is similar to the "Tron" and "Nibbles" games of yore, but
33 includes many graphical improvements and new game features. In it, you
34 must maneuver a small vehicle around a world and collect powerups
35 while avoiding obstacles, your opponents' trails, and even your own
36 trail. Several modes of play are available, including
37 "get-all-the-bonuses", deathmatch, and "squish-the-pedestrians".
38
39 %description -l pl.UTF-8
40 Heroes jest podobny do starych gier "Tron" i "Nibbles", ale zawiera
41 wiele graficznych ulepszeń i nowe własności. W tej grze musisz
42 manewrować małym pojazdem i zbierać dopalacze, unikając przeszkód i
43 śladów przeciwników, a nawet swojego własnego śladu. Są dostępne różne
44 tryby gry, w tym "zbierz-wszystkie-premie", deathmatch oraz
45 "rozjedź-pieszych".
46
47 %package sdl
48 Summary:        Game like Nibbles but different - SDL engine
49 Summary(pl.UTF-8):      Gra w stylu Nibbles, ale inna - wersja SDL
50 Group:          Applications/Games
51 Requires:       %{name} = %{version}-%{release}
52 Provides:       %{name}-engine
53
54 %description sdl
55 Heroes is similar to the "Tron" and "Nibbles" games of yore, but
56 includes many graphical improvements and new game features. In it, you
57 must maneuver a small vehicle around a world and collect powerups
58 while avoiding obstacles, your opponents' trails, and even your own
59 trail. Several modes of play are available, including
60 "get-all-the-bonuses", deathmatch, and "squish-the-pedestrians". This
61 package containts SDL engine.
62
63 %description sdl -l pl.UTF-8
64 Heroes jest podobny do starych gier "Tron" i "Nibbles", ale zawiera
65 wiele graficznych ulepszeń i nowe własności. W tej grze musisz
66 manewrować małym pojazdem i zbierać dopalacze, unikając przeszkód i
67 śladów przeciwników, a nawet swojego własnego śladu. Są dostępne różne
68 tryby gry, w tym "zbierz-wszystkie-premie", deathmatch oraz
69 "rozjedź-pieszych". Pakiet zawiera wersję SDL gry.
70
71 %package ggi
72 Summary:        Game like Nibbles but different - GGI engine
73 Summary(pl.UTF-8):      Gra w stylu Nibbles, ale inna - wersja GGI
74 Group:          Applications/Games
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-engine
77
78 %description ggi
79 Heroes is similar to the "Tron" and "Nibbles" games of yore, but
80 includes many graphical improvements and new game features. In it, you
81 must maneuver a small vehicle around a world and collect powerups
82 while avoiding obstacles, your opponents' trails, and even your own
83 trail. Several modes of play are available, including
84 "get-all-the-bonuses", deathmatch, and "squish-the-pedestrians". This
85 package containts GGI engine.
86
87 %description ggi -l pl.UTF-8
88 Heroes jest podobny do starych gier "Tron" i "Nibbles", ale zawiera
89 wiele graficznych ulepszeń i nowe własności. W tej grze musisz
90 manewrować małym pojazdem i zbierać dopalacze, unikając przeszkód i
91 śladów przeciwników, a nawet swojego własnego śladu. Są dostępne różne
92 tryby gry, w tym "zbierz-wszystkie-premie", deathmatch oraz
93 "rozjedź-pieszych". Pakiet zawiera wersję ggi gry
94
95 %prep
96 %setup -q
97 %patch0
98
99 %build
100 cp -f /usr/share/automake/config.sub tools
101 %if %{with ggi}
102 %configure \
103         --with-ggi \
104         --with-gii \
105         --with-mikmod \
106         --without-sdl \
107         --without-sdl-mixer
108 %{__make}
109 mv src/heroes src/heroes-ggi
110 %endif
111
112 %if %{with sdl}
113 %configure \
114         --without-ggi \
115         --without-gii \
116         --without-mikmod \
117         --with-sdl \
118         --with-sdl-mixer
119 %{__make}
120 %endif
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %if %{with ggi}
129 install src/%{name}-ggi $RPM_BUILD_ROOT%{_bindir}/%{name}-ggi
130 %endif
131
132 %if %{with sdl}
133 mv $RPM_BUILD_ROOT%{_bindir}/%{name}{,-sdl}
134 %endif
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p      /sbin/postshell
142 -/usr/sbin/fix-info-dir -c %{_infodir}
143
144 %postun -p      /sbin/postshell
145 -/usr/sbin/fix-info-dir -c %{_infodir}
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc ChangeLog NEWS README THANKS TODO
150 %attr(755,root,root) %{_bindir}/%{name}lvl
151 %{_mandir}/man?/%{name}*
152 %{_infodir}/%{name}*
153 %{_datadir}/%{name}
154
155 %if %{with sdl}
156 %files sdl
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/%{name}-sdl
159 %endif
160
161 %if %{with ggi}
162 %files ggi
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/%{name}-ggi
165 %endif
This page took 0.648338 seconds and 3 git commands to generate.