]> git.pld-linux.org Git - SPECS.git/blob - hdf5_hl_region.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / hdf5_hl_region.spec
1 #
2 # Conditional build:
3 %bcond_without  fortran         # Fortran API
4 %bcond_without  tests           # perform "make tests"
5 #
6 Summary:        High-Level Library for handling HDF5 object and region references
7 Summary(pl.UTF-8):      Wysokopoziomowa biblioteka do obsługi odniesień do obiektów i regionów HDF5
8 Name:           hdf5_hl_region
9 Version:        1.1.5
10 Release:        1
11 License:        BSD-like, changed sources must be marked
12 Group:          Libraries
13 Source0:        https://gamma.hdfgroup.org/ftp/pub/outgoing/JPSS/HL_JPSS/hdf5_HL_REGION-%{version}.tar
14 # Source0-md5:  0e07c7c76eba6e8180ef8973b245f821
15 Patch0:         %{name}-shared.patch
16 Patch1:         %{name}-destdir.patch
17 Patch2:         %{name}-fortran-check.patch
18 URL:            http://portal.hdfgroup.org/display/support/Joint+Polar+Satellite+System+-+JPSS
19 BuildRequires:  hdf5-devel
20 %{?with_fortran:BuildRequires:  hdf5-fortran-devel}
21 %{?with_tests:BuildRequires:    hdf5-progs}
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This package contains C library to:
27  - Get information and read data pointed to by region references
28  - Create an array of region references using paths to datasets and
29    corner coordinates of hyperslabs
30  - Create a dataset and write data pointed to by region references
31  - Copy data pointed to by region references
32  - Retrieve data packed in an integer (quality flags)
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera bibliotekę C pozwalającą na:
36  - uzyskanie informacji i odczyt danych wskazanych przez regionu
37  - utworzenie tablicy wskazań regionu przy użyciu ścieżek do zbiorów
38    danych i współrzędnych rogów obiektów hyperslab
39  - utworzenie zbioru danych i zapis danych wskazanych przez region
40  - skopiowanie danych wskazanych przez region
41  - odtworzenie danych spakowanych w liczbie całkowitej (flag jakości)
42
43 %package devel
44 Summary:        Header files for HDF5 HL_REGION library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5 HL_REGION
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       hdf5-devel
49
50 %description devel
51 Header files for HDF5 HL_REGION library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki HDF5 HL_REGION.
55
56 %package static
57 Summary:        Static HDF5 HL_REGION library
58 Summary(pl.UTF-8):      Statyczna biblioteka HDF5 HL_REGION
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static HDF5 HL_REGION library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka HDF5 HL_REGION.
67
68 %package fortran
69 Summary:        High-Level Fortran Library for handling HDF5 object and region references
70 Summary(pl.UTF-8):      Wysokopoziomowa biblioteka Fortranu do obsługi odniesień do obiektów i regionów HDF5
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description fortran
75 This package contains Fortran library to:
76  - Get information and read data pointed to by region references
77  - Create an array of region references using paths to datasets and
78    corner coordinates of hyperslabs
79  - Create a dataset and write data pointed to by region references
80  - Copy data pointed to by region references
81  - Retrieve data packed in an integer (quality flags)
82
83 %description fortran -l pl.UTF-8
84 Ten pakiet zawiera bibliotekę języka Fortran pozwalającą na:
85  - uzyskanie informacji i odczyt danych wskazanych przez regionu
86  - utworzenie tablicy wskazań regionu przy użyciu ścieżek do zbiorów
87    danych i współrzędnych rogów obiektów hyperslab
88  - utworzenie zbioru danych i zapis danych wskazanych przez region
89  - skopiowanie danych wskazanych przez region
90  - odtworzenie danych spakowanych w liczbie całkowitej (flag jakości)
91
92 %package fortran-devel
93 Summary:        Header files for HDF5 HL_REGION Fortran library
94 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5 HL_REGION dla Fortranu
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Requires:       %{name}-fortran = %{version}-%{release}
98
99 %description fortran-devel
100 Header files for HDF5 HL_REGION library.
101
102 %description fortran-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki HDF5 HL_REGION dla Foortranu.
104
105 %package fortran-static
106 Summary:        Static HDF5 HL_REGION Fortran library
107 Summary(pl.UTF-8):      Statyczna biblioteka HDF5 HL_REGION dla Fortranu
108 Group:          Development/Libraries
109 Requires:       %{name}-fortran-devel = %{version}-%{release}
110
111 %description fortran-static
112 Static HDF5 HL_REGION Fortran library.
113
114 %description fortran-static -l pl.UTF-8
115 Statyczna biblioteka HDF5 HL_REGION dla Fortranu.
116
117 %prep
118 %setup -q -n hdf5_HL_REGION-%{version}
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122
123 %build
124 %{__make} -j1 \
125         CC="%{__cc}" \
126         FC="%{_target_alias}-gfortran" \
127         CCFLAGS="%{rpmcflags}" \
128         FCFLAGS="%{rpmcflags}" \
129         HDF5_INSTALL_DIR=/usr \
130         HDF5_USE_SHLIB=yes \
131         LIBDIR=%{_libdir} \
132         enable-fortran=yes
133
134 %if %{with tests}
135 %{__make} tests \
136         HDF5_INSTALL_DIR=/usr
137 %endif
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         PREFIX=%{_prefix} \
145         LIBDIR=%{_libdir} \
146         HDF5_INSTALL_DIR=/usr \
147         enable-fortran=yes
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %post   fortran -p /sbin/ldconfig
156 %postun fortran -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc COPYING README.txt doc/RELEASE.txt
161 %attr(755,root,root) %{_libdir}/libhdf5_hl_region.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_region.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libhdf5_hl_region.so
167 %{_libdir}/libhdf5_hl_region.la
168 %{_includedir}/h5hl_api.h
169 %{_includedir}/h5hl_region.h
170 %{_includedir}/hl_region_H5LRpublic.h
171 %{_includedir}/hl_region_H5LTpublic.h
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libhdf5_hl_region.a
176
177 %files fortran
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libhdf5_hl_region_fortran.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_region_fortran.so.0
181
182 %files fortran-devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libhdf5_hl_region_fortran.so
185 %{_libdir}/libhdf5_hl_region_fortran.la
186 %{_includedir}/h5hl_region.mod
187 %{_includedir}/hl_region_h5lr.mod
188 %{_includedir}/hl_region_h5lt.mod
189
190 %files fortran-static
191 %defattr(644,root,root,755)
192 %{_libdir}/libhdf5_hl_region_fortran.a
This page took 1.481579 seconds and 3 git commands to generate.