]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- added sig patch (fixes SIGBUS crash on sparc during alignment detection on build)
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - build with MPICH
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_without  szip    # build without SZIP support
7 #
8 Summary:        Hierarchical Data Format 5 library
9 Summary(pl):    Biblioteka HDF5 (Hierarchical Data Format 5)
10 Name:           hdf5
11 Version:        1.6.4
12 Release:        2
13 Group:          Libraries
14 License:        Nearly BSD, but changed sources must be marked
15 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/%{name}-%{version}/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  837de4bb977623e380d3501ab2791f02
17 Patch0:         %{name}-config.patch
18 Patch1:         %{name}-sig.patch
19 URL:            http://hdf.ncsa.uiuc.edu/HDF5/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libjpeg-devel >= 6b
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  openssl-devel >= 0.9.7d
26 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
27 BuildRequires:  zlib-devel >= 1.1.3
28 Obsoletes:      hdf5_hl
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 HDF5 is a completely new Hierarchical Data Format product consisting
33 of a data format specification and a supporting library
34 implementation. HDF5 is designed to address some of the limitations of
35 the older HDF product and to address current and anticipated
36 requirements of modern systems and applications.
37
38 %description -l pl
39 HDF5 jest ca³kowicie nowym produktem Hierarchiczego Formatu Danych,
40 sk³adaj±cym siê ze specyfikacji formatu danych oraz obs³uguj±cej go
41 biblioteki. HDF5 zosta³ zaprojektowany aby pozbyæ siê ograniczeñ
42 poprzedniego HDF oraz ¿eby zaspokoiæ bie¿±ce i przysz³e potrzeby
43 wspó³czesnych systemów i aplikacji.
44
45 %package devel
46 Summary:        HDF5 library development package
47 Summary(pl):    Pliki nag³ówkowe biblioteki HDF5
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       openssl-devel
51 %{?with_szip:Requires:  szip-devel >= 2.0}
52 Requires:       zlib-devel
53 Obsoletes:      hdf5_hl-devel
54 Obsoletes:      hdf5_hl-tutor
55
56 %description devel
57 Header files for HDF5 library and HDF5 documentation.
58
59 %description devel -l pl
60 Pliki nag³ówkowe biblioteki HDF5 oraz dokumentacja HDF5.
61
62 %package static
63 Summary:        HDF5 static library
64 Summary(pl):    Statyczna biblioteka HDF5
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67 Obsoletes:      hdf5_hl-static
68
69 %description static
70 Static version of HDF5 library.
71
72 %description static -l pl
73 Statyczna wersja biblioteki HDF5.
74
75 %package progs
76 Summary:        HDF5 utilities
77 Summary(pl):    Narzêdzia do plików HDF5
78 Group:          Applications/File
79 Requires:       %{name} = %{version}-%{release}
80
81 %description progs
82 Utilities to convert from/to HDF5 format.
83
84 %description progs -l pl
85 Narzêdzia do konwersji z i to formatu HDF5.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 cd c++
97 %{__aclocal}
98 %{__autoconf}
99 cd ..
100 %configure \
101         --enable-cxx \
102         --enable-linux-lfs \
103         --enable-threadsafe \
104         --enable-production \
105         --with-pthread \
106         --with-ssl \
107         %{?with_szip:--with-szlib}
108
109 #       --enable-fortran  - requires Fortran90 compiler
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_includedir}
116
117 %{__make} install \
118         libdir=$RPM_BUILD_ROOT%{_libdir} \
119         includedir=$RPM_BUILD_ROOT%{_includedir} \
120         bindir=$RPM_BUILD_ROOT%{_bindir} \
121         docdir=$RPM_BUILD_ROOT%{_docdir}
122
123 find doc -name Dependencies -o -name Makefile\* | xargs rm -f
124
125 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
126 mv -f $RPM_BUILD_ROOT%{_docdir}/hdf5/examples/{c,c++} \
127         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc COPYING README.txt release_docs/{HISTORY.txt,RELEASE.txt}
138 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
139 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
140 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
141 # used to show configuration at runtime
142 %{_libdir}/libhdf5.settings
143 %{_libdir}/libhdf5_cpp.settings
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc doc/html
148 %attr(755,root,root) %{_libdir}/libhdf5.so
149 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
150 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
151 %{_libdir}/libhdf5.la
152 %{_libdir}/libhdf5_cpp.la
153 %{_libdir}/libhdf5_hl.la
154 %{_includedir}/*.h
155 %{_examplesdir}/%{name}-%{version}
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libhdf5.a
160 %{_libdir}/libhdf5_cpp.a
161 %{_libdir}/libhdf5_hl.a
162
163 %files progs
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/*
This page took 0.069235 seconds and 4 git commands to generate.