]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- updated to 1.8.3
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - build with MPICH
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_without  szip    # build without SZIP support
7 #
8 Summary:        Hierarchical Data Format 5 library
9 Summary(pl.UTF-8):      Biblioteka HDF5 (Hierarchical Data Format 5)
10 Name:           hdf5
11 Version:        1.8.3
12 Release:        1
13 Group:          Libraries
14 License:        Nearly BSD, but changed sources must be marked
15 Source0:        ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  5ce228d860bf9e797ca40ab1a823c380
17 Patch0:         %{name}-config.patch
18 Patch1:         %{name}-sig.patch
19 Patch2:         %{name}-link.patch
20 URL:            http://hdf.ncsa.uiuc.edu/HDF5/
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake
23 BuildRequires:  libjpeg-devel >= 6b
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.5
26 BuildRequires:  openssl-devel >= 0.9.7d
27 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
28 BuildRequires:  zlib-devel >= 1.1.3
29 Obsoletes:      hdf5_hl
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 HDF5 is a completely new Hierarchical Data Format product consisting
34 of a data format specification and a supporting library
35 implementation. HDF5 is designed to address some of the limitations of
36 the older HDF product and to address current and anticipated
37 requirements of modern systems and applications.
38
39 %description -l pl.UTF-8
40 HDF5 jest całkowicie nowym produktem Hierarchiczego Formatu Danych,
41 składającym się ze specyfikacji formatu danych oraz obsługującej go
42 biblioteki. HDF5 został zaprojektowany aby pozbyć się ograniczeń
43 poprzedniego HDF oraz żeby zaspokoić bieżące i przyszłe potrzeby
44 współczesnych systemów i aplikacji.
45
46 %package devel
47 Summary:        HDF5 library development package
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       openssl-devel
52 %{?with_szip:Requires:  szip-devel >= 2.0}
53 Requires:       zlib-devel
54 Obsoletes:      hdf5_hl-devel
55 Obsoletes:      hdf5_hl-tutor
56
57 %description devel
58 Header files for HDF5 library and HDF5 documentation.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki HDF5 oraz dokumentacja HDF5.
62
63 %package static
64 Summary:        HDF5 static library
65 Summary(pl.UTF-8):      Statyczna biblioteka HDF5
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68 Obsoletes:      hdf5_hl-static
69
70 %description static
71 Static version of HDF5 library.
72
73 %description static -l pl.UTF-8
74 Statyczna wersja biblioteki HDF5.
75
76 %package progs
77 Summary:        HDF5 utilities
78 Summary(pl.UTF-8):      Narzędzia do plików HDF5
79 Group:          Applications/File
80 Requires:       %{name} = %{version}-%{release}
81
82 %description progs
83 Utilities to convert from/to HDF5 format.
84
85 %description progs -l pl.UTF-8
86 Narzędzia do konwersji z i to formatu HDF5.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --docdir=%{_docdir} \
102         --enable-cxx \
103         --enable-linux-lfs \
104         --enable-production \
105         --with-pthread \
106         --with-ssl \
107         %{?with_szip:--with-szlib}
108
109 #       --enable-threadsafe is incompatible with cxx/fortran
110 #       --enable-fortran  - requires Fortran90 compiler
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_includedir}
117
118 %{__make} install \
119         libdir=$RPM_BUILD_ROOT%{_libdir} \
120         includedir=$RPM_BUILD_ROOT%{_includedir} \
121         bindir=$RPM_BUILD_ROOT%{_bindir} \
122         docdir=$RPM_BUILD_ROOT%{_docdir}
123
124 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
125 %{__make} -C examples install-examples \
126         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c
127 %{__make} -C c++/examples install-examples \
128         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c++
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc COPYING README.txt release_docs/{HISTORY*.txt,RELEASE.txt}
139 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libhdf5.so.6
141 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libhdf5_cpp.so.6
143 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl.so.6
145 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_cpp.so.6
147 # used to show configuration at runtime
148 %{_libdir}/libhdf5.settings
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libhdf5.so
153 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
154 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
155 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so
156 %{_libdir}/libhdf5.la
157 %{_libdir}/libhdf5_cpp.la
158 %{_libdir}/libhdf5_hl.la
159 %{_libdir}/libhdf5_hl_cpp.la
160 %{_includedir}/H5*.h
161 %{_includedir}/hdf5.h
162 %{_includedir}/hdf5_hl.h
163 %{_examplesdir}/%{name}-%{version}
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libhdf5.a
168 %{_libdir}/libhdf5_cpp.a
169 %{_libdir}/libhdf5_hl.a
170 %{_libdir}/libhdf5_hl_cpp.a
171
172 %files progs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/*
This page took 0.063869 seconds and 4 git commands to generate.