]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- BR: jdk for java
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - finish (optional) MPI support (1.8.14: fails on mpi_file_open check)
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_with     hdfs            # HDFS driver (requires libhdfs, hdfs.h)
7 %bcond_without  java            # Java wrappers
8 %bcond_without  s3              # R/O S3 driver
9 %bcond_without  szip            # SZIP compression support
10 %bcond_with     mpi             # parallel version of library using MPI
11 #
12 Summary:        Hierarchical Data Format 5 library
13 Summary(pl.UTF-8):      Biblioteka HDF5 (Hierarchical Data Format 5)
14 Name:           hdf5
15 Version:        1.10.7
16 Release:        1
17 License:        Nearly BSD, but changed sources must be marked
18 Group:          Libraries
19 Source0:        https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/hdf5-%{version}/src/%{name}-%{version}.tar.bz2
20 # Source0-md5:  dff8a882b61d0b59296dccc3ad13dc29
21 Patch0:         %{name}-sig.patch
22 Patch1:         %{name}-cmake.patch
23 Patch2:         %{name}-sh.patch
24 URL:            https://support.hdfgroup.org/HDF5/
25 BuildRequires:  autoconf >= 2.69
26 BuildRequires:  automake >= 1:1.11
27 %{?with_s3:BuildRequires:       curl-devel}
28 BuildRequires:  gcc-fortran >= 6:4.2
29 %{?with_java:BuildRequires:     jdk}
30 BuildRequires:  libjpeg-devel >= 6b
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:2.2
33 %{?with_mpi:BuildRequires:      mpi-devel}
34 %{?with_s3:BuildRequires:       openssl-devel}
35 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
36 BuildRequires:  zlib-devel >= 1.1.3
37 Obsoletes:      hdf5_hl
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 HDF5 is a completely new Hierarchical Data Format product consisting
42 of a data format specification and a supporting library
43 implementation. HDF5 is designed to address some of the limitations of
44 the older HDF product and to address current and anticipated
45 requirements of modern systems and applications.
46
47 %description -l pl.UTF-8
48 HDF5 jest całkowicie nowym produktem Hierarchiczego Formatu Danych,
49 składającym się ze specyfikacji formatu danych oraz obsługującej go
50 biblioteki. HDF5 został zaprojektowany aby pozbyć się ograniczeń
51 poprzedniego HDF oraz żeby zaspokoić bieżące i przyszłe potrzeby
52 współczesnych systemów i aplikacji.
53
54 %package devel
55 Summary:        HDF5 library development package
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 %{?with_s3:Requires:    curl-devel}
60 %{?with_s3:Requires:    openssl-devel}
61 %{?with_szip:Requires:  szip-devel >= 2.0}
62 Requires:       zlib-devel
63 Obsoletes:      hdf5_hl-devel
64 Obsoletes:      hdf5_hl-tutor
65
66 %description devel
67 Header files for HDF5 library and HDF5 documentation.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki HDF5 oraz dokumentacja HDF5.
71
72 %package static
73 Summary:        HDF5 static library
74 Summary(pl.UTF-8):      Statyczna biblioteka HDF5
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Obsoletes:      hdf5_hl-static
78
79 %description static
80 Static version of HDF5 library.
81
82 %description static -l pl.UTF-8
83 Statyczna wersja biblioteki HDF5.
84
85 %package c++
86 Summary:        C++ APIs for HDF5
87 Summary(pl.UTF-8):      API C++ bibliotek HDF5
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description c++
92 C++ APIs for HDF5 (both base hdf5 and hdf5_hl).
93
94 %description c++ -l pl.UTF-8
95 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl).
96
97 %package c++-devel
98 Summary:        Header files for HDF5 C++ APIs
99 Summary(pl.UTF-8):      Pliki nagłówkowe API C++ bibliotek HDF5
100 Group:          Development/Libraries
101 Requires:       %{name}-c++ = %{version}-%{release}
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description c++-devel
106 Header files for HDF5 C++ APIs (both base hdf5 and hdf5_hl).
107
108 %description c++-devel -l pl.UTF-8
109 Pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej hdf5, jak
110 i hdf5_hl).
111
112 %package c++-static
113 Summary:        C++ APIs for HDF5 - static libraries
114 Summary(pl.UTF-8):      API C++ bibliotek HDF5 - biblioteki statyczne
115 Group:          Development/Libraries
116 Requires:       %{name}-c++-devel = %{version}-%{release}
117
118 %description c++-static
119 C++ APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
120
121 %description c++-static -l pl.UTF-8
122 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl) -
123 biblioteki statyczne.
124
125 %package fortran
126 Summary:        Fortran APIs for HDF5
127 Summary(pl.UTF-8):      API Fortran bibliotek HDF5
128 Group:          Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description fortran
132 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl).
133
134 %description fortran -l pl.UTF-8
135 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
136 hdf5_hl).
137
138 %package fortran-devel
139 Summary:        Header files for HDF5 Fortran APIs
140 Summary(pl.UTF-8):      Pliki nagłówkowe API Fortran bibliotek HDF5
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143 Requires:       %{name}-fortran = %{version}-%{release}
144 Requires:       gcc-fortran >= 6:4.2
145
146 %description fortran-devel
147 Module and header files for HDF5 Fortran APIs (both base hdf5 and
148 hdf5_hl).
149
150 %description fortran-devel -l pl.UTF-8
151 Moduły i pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej
152 hdf5, jak i hdf5_hl).
153
154 %package fortran-static
155 Summary:        Fortran APIs for HDF5 - static libraries
156 Summary(pl.UTF-8):      API Fortran bibliotek HDF5 - biblioteki statyczne
157 Group:          Development/Libraries
158 Requires:       %{name}-fortran-devel = %{version}-%{release}
159
160 %description fortran-static
161 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
162
163 %description fortran-static -l pl.UTF-8
164 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
165 hdf5_hl) - biblioteki statyczne.
166
167 %package progs
168 Summary:        HDF5 utilities
169 Summary(pl.UTF-8):      Narzędzia do plików HDF5
170 Group:          Applications/File
171 Requires:       %{name} = %{version}-%{release}
172
173 %description progs
174 Utilities to convert from/to HDF5 format.
175
176 %description progs -l pl.UTF-8
177 Narzędzia do konwersji z i to formatu HDF5.
178
179 %package -n java-hdf5
180 Summary:        Java HDF5 Interface (JHI5)
181 Summary(pl.UTF-8):      Interfejs HDF5 do Javy (JHI5)
182 # to replace java-hdf5 [0:]2.11/3.3.1 from hdf-java.spec
183 Epoch:          1
184 Group:          Libraries/Java
185 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
186 Requires:       java-slf4j >= 1.7.25
187
188 %description -n java-hdf5
189 The Java Native Interface to the standard HDF5 library.
190
191 %description -n java-hdf5 -l pl.UTF-8
192 Natywny interfejs Javy (JNI) do biblioteki standardowej HDF5.
193
194 %package -n java-hdf5-javadoc
195 Summary:        Javadoc documentation for Java HDF5 Interface (JHI5)
196 Summary(pl.UTF-8):      Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5)
197 Epoch:          1
198 Group:          Documentation
199 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
200
201 %description -n java-hdf5-javadoc
202 Javadoc documentation for Java HDF5 Interface (JHI5).
203
204 %description -n java-hdf5-javadoc -l pl.UTF-8
205 Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5).
206
207 %prep
208 %setup -q
209 %patch0 -p1
210 %patch1 -p1
211 %patch2 -p1
212
213 %build
214 %{__libtoolize}
215 %{__aclocal}
216 %{__autoconf}
217 %{__autoheader}
218 %{__automake}
219 %configure \
220         --docdir=%{_docdir} \
221         --disable-silent-rules \
222         --enable-cxx \
223         --enable-direct-vfd \
224         --enable-fortran \
225         %{?with_java:--enable-java} \
226         %{?with_mpi:--enable-parallel --enable-unsupported} \
227         %{?with_s3:--enable-ros3-vfd} \
228         --enable-shared \
229         %{?with_hdfs:--with-libhdfs=%{_includedir},%{_libdir}} \
230         --with-pthread \
231         %{?with_szip:--with-szlib}
232
233 #       --enable-threadsafe is unspported with cxx/fortran/java/hl
234
235 %{__make}
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239 install -d $RPM_BUILD_ROOT%{_includedir}
240
241 %{__make} install-recursive \
242         DESTDIR=$RPM_BUILD_ROOT \
243         hdf5_javadir=%{_javadir}
244
245 %if %{with java}
246 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhdf5_java.la
247 ln -sf jarhdf5-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/jarhdf5.jar
248 install -d $RPM_BUILD_ROOT%{_javadocdir}
249 cp -pr java/src/javadoc $RPM_BUILD_ROOT%{_javadocdir}/hdf5lib
250 %endif
251
252 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
253 %{__make} -C examples install-examples \
254         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
255         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
256 %{__make} -C c++/examples install-examples \
257         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c++
258 %{__make} -C hl/examples install-examples \
259         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c \
260         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
261 %{__make} -C hl/c++/examples install-examples \
262         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c++
263
264 install -d $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5
265 vmajor=$(sed -ne 's/^#define H5_VERS_MAJOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
266 vminor=$(sed -ne 's/^#define H5_VERS_MINOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
267 vrel=$(sed -ne 's/^#define H5_VERS_RELEASE\s*\([0-9]\+\).*/\1/p' src/H5public.h)
268 vsubr=$(sed -ne 's/^#define H5_VERS_SUBRELEASE\s*"\?\([^" \t]\+\)"\?.*/\1/p' src/H5public.h)
269 for f in hdf5-config-version.cmake hdf5-config.cmake hdf5-targets.cmake hdf5-targets-noconfig.cmake ; do
270         sed -e 's,@HDF5_PACKAGE@,hdf5,g' \
271             -e 's,@HDF_PACKAGE_EXT@,,' \
272             -e "s,@HDF5_VERSION_STRING@,%{version}," \
273             -e "s,@HDF5_VERSION_MAJOR@,1.8," \
274             -e "s,@HDF5_VERSION_MINOR@,$vrel," \
275             -e "s,@H5_VERS_MAJOR@,$vmajor," \
276             -e "s,@H5_VERS_MINOR@,$vminor," \
277             -e "s,@H5_VERS_RELEASE@,$vrel," \
278             -e "s,@H5_VERS_SUBRELEASE@,$vsubr," \
279             -e 's,@HDF5_ENABLE_PARALLEL@,OFF,' \
280             -e 's,@HDF5_BUILD_FORTRAN@,ON,' \
281             -e 's,@HDF5_BUILD_CPP_LIB@,ON,' \
282             -e 's,@HDF5_BUILD_TOOLS@,ON,' \
283             -e 's,@HDF5_BUILD_HL_LIB@,ON,' \
284             -e 's,@HDF5_ENABLE_Z_LIB_SUPPORT@,ON,' \
285             -e 's,@HDF5_ENABLE_SZIP_SUPPORT@,%{?with_szip:ON}%{!?with_szip:OFF},' \
286             -e 's,@HDF5_ENABLE_SZIP_ENCODING@,%{?with_szip:ON}%{!?with_szip:OFF},' \
287 %ifarch %{ix86} x32
288             -e 's,@CMAKE_SIZEOF_VOID_P@,4,' \
289 %else
290 %ifarch %{x8664}
291             -e 's,@CMAKE_SIZEOF_VOID_P@,8,' \
292 %endif
293 %endif
294             -e 's,@BUILD_SHARED_LIBS@,ON,' \
295             -e 's,@HDF5_PACKAGE_EXTLIBS@,OFF,' \
296             -e 's,@ZLIB_PACKAGE_NAME@,zlib,' \
297             -e 's,@SZIP_PACKAGE_NAME@,szip,' \
298             -e 's,@HDF5_LIBRARIES_TO_EXPORT@,hdf5,' \
299             -e 's,@CMAKE_GENERATOR_TOOLSET@,,' \
300             -e 's,@lib@,%{_lib},' \
301             %{?with_mpi:-e 's,@MPI_C_INCLUDE_PATH@,%{_includedir},'} \
302             %{?with_mpi:-e 's,@MPI_C_LIBRARIES@,%{_libdir},'} \
303             -e 's,@PACKAGE_INCLUDE_INSTALL_DIR@,%{_includedir},' \
304             -e 's,@PACKAGE_SHARE_INSTALL_DIR@,%{_libdir}/cmake,' \
305             -e 's,@PACKAGE_CURRENT_BUILD_DIR@,%{_prefix},' \
306                 config/cmake/${f}.in > $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5/$f
307 done
308
309 %clean
310 rm -rf $RPM_BUILD_ROOT
311
312 %post   -p /sbin/ldconfig
313 %postun -p /sbin/ldconfig
314
315 %post   c++ -p /sbin/ldconfig
316 %postun c++ -p /sbin/ldconfig
317
318 %post   fortran -p /sbin/ldconfig
319 %postun fortran -p /sbin/ldconfig
320
321 %files
322 %defattr(644,root,root,755)
323 %doc COPYING README.txt release_docs/{HISTORY*.txt,RELEASE.txt}
324 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
325 %attr(755,root,root) %ghost %{_libdir}/libhdf5.so.103
326 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
327 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl.so.100
328 # used to show configuration at runtime
329 %{_libdir}/libhdf5.settings
330
331 %files devel
332 %defattr(644,root,root,755)
333 %attr(755,root,root) %{_bindir}/h5cc
334 %attr(755,root,root) %{_libdir}/libhdf5.so
335 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
336 %{_libdir}/libhdf5.la
337 %{_libdir}/libhdf5_hl.la
338 %{_includedir}/H5ACpublic.h
339 %{_includedir}/H5Apublic.h
340 %{_includedir}/H5Cpublic.h
341 %{_includedir}/H5DOpublic.h
342 %{_includedir}/H5DSpublic.h
343 %{_includedir}/H5Dpublic.h
344 %{_includedir}/H5Epubgen.h
345 %{_includedir}/H5Epublic.h
346 %{_includedir}/H5FDcore.h
347 %{_includedir}/H5FDdirect.h
348 %{_includedir}/H5FDfamily.h
349 %{_includedir}/H5FDhdfs.h
350 %{_includedir}/H5FDlog.h
351 %{_includedir}/H5FDmirror.h
352 %{_includedir}/H5FDmpi.h
353 %{_includedir}/H5FDmpio.h
354 %{_includedir}/H5FDmulti.h
355 %{_includedir}/H5FDpublic.h
356 %{_includedir}/H5FDros3.h
357 %{_includedir}/H5FDsec2.h
358 %{_includedir}/H5FDsplitter.h
359 %{_includedir}/H5FDstdio.h
360 %{_includedir}/H5FDwindows.h
361 %{_includedir}/H5Fpublic.h
362 %{_includedir}/H5Gpublic.h
363 %{_includedir}/H5IMpublic.h
364 %{_includedir}/H5Include.h
365 %{_includedir}/H5Ipublic.h
366 %{_includedir}/H5LDpublic.h
367 %{_includedir}/H5LTpublic.h
368 %{_includedir}/H5Lpublic.h
369 %{_includedir}/H5MMpublic.h
370 %{_includedir}/H5Opublic.h
371 %{_includedir}/H5PTpublic.h
372 %{_includedir}/H5Ppublic.h
373 %{_includedir}/H5PLextern.h
374 %{_includedir}/H5PLpublic.h
375 %{_includedir}/H5Rpublic.h
376 %{_includedir}/H5Spublic.h
377 %{_includedir}/H5TBpublic.h
378 %{_includedir}/H5Tpublic.h
379 %{_includedir}/H5Zpublic.h
380 %{_includedir}/H5api_adpt.h
381 %{_includedir}/H5overflow.h
382 %{_includedir}/H5pubconf.h
383 %{_includedir}/H5public.h
384 %{_includedir}/H5version.h
385 %{_includedir}/hdf5.h
386 %{_includedir}/hdf5_hl.h
387
388 %{_libdir}/cmake/hdf5
389 %dir %{_examplesdir}/%{name}-%{version}
390 %{_examplesdir}/%{name}-%{version}/README
391 %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
392 %{_examplesdir}/%{name}-%{version}/c
393 %dir %{_examplesdir}/%{name}-%{version}/hl
394 %{_examplesdir}/%{name}-%{version}/hl/run-hl-ex.sh
395 %{_examplesdir}/%{name}-%{version}/hl/c
396
397 %files static
398 %defattr(644,root,root,755)
399 %{_libdir}/libhdf5.a
400 %{_libdir}/libhdf5_hl.a
401
402 %files c++
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
405 %attr(755,root,root) %ghost %{_libdir}/libhdf5_cpp.so.103
406 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so.*.*.*
407 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_cpp.so.100
408
409 %files c++-devel
410 %defattr(644,root,root,755)
411 %attr(755,root,root) %{_bindir}/h5c++
412 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
413 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so
414 %{_libdir}/libhdf5_cpp.la
415 %{_libdir}/libhdf5_hl_cpp.la
416 %{_includedir}/H5AbstractDs.h
417 %{_includedir}/H5ArrayType.h
418 %{_includedir}/H5AtomType.h
419 %{_includedir}/H5Attribute.h
420 %{_includedir}/H5Classes.h
421 %{_includedir}/H5CommonFG.h
422 %{_includedir}/H5CompType.h
423 %{_includedir}/H5Cpp.h
424 %{_includedir}/H5CppDoc.h
425 %{_includedir}/H5DaccProp.h
426 %{_includedir}/H5DataSet.h
427 %{_includedir}/H5DataSpace.h
428 %{_includedir}/H5DataType.h
429 %{_includedir}/H5DcreatProp.h
430 %{_includedir}/H5DxferProp.h
431 %{_includedir}/H5EnumType.h
432 %{_includedir}/H5Exception.h
433 %{_includedir}/H5FaccProp.h
434 %{_includedir}/H5FcreatProp.h
435 %{_includedir}/H5File.h
436 %{_includedir}/H5FloatType.h
437 %{_includedir}/H5Group.h
438 %{_includedir}/H5IdComponent.h
439 %{_includedir}/H5IntType.h
440 %{_includedir}/H5LaccProp.h
441 %{_includedir}/H5LcreatProp.h
442 %{_includedir}/H5Library.h
443 %{_includedir}/H5Location.h
444 %{_includedir}/H5Object.h
445 %{_includedir}/H5OcreatProp.h
446 %{_includedir}/H5PacketTable.h
447 %{_includedir}/H5PredType.h
448 %{_includedir}/H5PropList.h
449 %{_includedir}/H5StrType.h
450 %{_includedir}/H5VarLenType.h
451 %{_examplesdir}/%{name}-%{version}/c++
452 %{_examplesdir}/%{name}-%{version}/hl/c++
453
454 %files c++-static
455 %defattr(644,root,root,755)
456 %{_libdir}/libhdf5_cpp.a
457 %{_libdir}/libhdf5_hl_cpp.a
458
459 %files fortran
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libhdf5_fortran.so.102
463 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libhdf5hl_fortran.so.100
465
466 %files fortran-devel
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_bindir}/h5fc
469 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so
470 %attr(755,root,root) %{_libdir}/libhdf5_hl_fortran.so
471 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so
472 %{_libdir}/libhdf5_fortran.la
473 %{_libdir}/libhdf5hl_fortran.la
474 %{_includedir}/H5f90i.h
475 %{_includedir}/H5f90i_gen.h
476 %{_includedir}/h5_gen.mod
477 %{_includedir}/h5a.mod
478 %{_includedir}/h5d.mod
479 %{_includedir}/h5ds.mod
480 %{_includedir}/h5e.mod
481 %{_includedir}/h5f.mod
482 %{_includedir}/h5fortkit.mod
483 %{_includedir}/h5fortran_types.mod
484 %{_includedir}/h5g.mod
485 %{_includedir}/h5global.mod
486 %{_includedir}/h5i.mod
487 %{_includedir}/h5im.mod
488 %{_includedir}/h5l.mod
489 %{_includedir}/h5lib.mod
490 %{_includedir}/h5lt.mod
491 %{_includedir}/h5lt_const.mod
492 %{_includedir}/h5o.mod
493 %{_includedir}/h5p.mod
494 %{_includedir}/h5r.mod
495 %{_includedir}/h5s.mod
496 %{_includedir}/h5t.mod
497 %{_includedir}/h5tb.mod
498 %{_includedir}/h5tb_const.mod
499 %{_includedir}/h5z.mod
500 %{_includedir}/hdf5.mod
501
502 %files fortran-static
503 %defattr(644,root,root,755)
504 %{_libdir}/libhdf5_fortran.a
505 %{_libdir}/libhdf5_hl_fortran.a
506 %{_libdir}/libhdf5hl_fortran.a
507
508 %files progs
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_bindir}/gif2h5
511 %attr(755,root,root) %{_bindir}/h52gif
512 %attr(755,root,root) %{_bindir}/h5clear
513 %attr(755,root,root) %{_bindir}/h5copy
514 %attr(755,root,root) %{_bindir}/h5debug
515 %attr(755,root,root) %{_bindir}/h5diff
516 %attr(755,root,root) %{_bindir}/h5dump
517 %attr(755,root,root) %{_bindir}/h5format_convert
518 %attr(755,root,root) %{_bindir}/h5import
519 %attr(755,root,root) %{_bindir}/h5jam
520 %attr(755,root,root) %{_bindir}/h5ls
521 %attr(755,root,root) %{_bindir}/h5mkgrp
522 %attr(755,root,root) %{_bindir}/h5perf_serial
523 %attr(755,root,root) %{_bindir}/h5redeploy
524 %attr(755,root,root) %{_bindir}/h5repack
525 %attr(755,root,root) %{_bindir}/h5repart
526 %attr(755,root,root) %{_bindir}/h5stat
527 %attr(755,root,root) %{_bindir}/h5unjam
528 %attr(755,root,root) %{_bindir}/h5watch
529 %attr(755,root,root) %{_bindir}/mirror_server
530 %attr(755,root,root) %{_bindir}/mirror_server_stop
531
532 %if %{with java}
533 %files -n java-hdf5
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libhdf5_java.so
536 %{_javadir}/jarhdf5-%{version}.jar
537 %{_javadir}/jarhdf5.jar
538
539 %files -n java-hdf5-javadoc
540 %defattr(644,root,root,755)
541 %{_javadocdir}/hdf5lib
542 %endif
This page took 0.111043 seconds and 4 git commands to generate.