]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- updated to 1.6.4 (hdf5_hl included now), updated config patch
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - build with MPICH
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_without  szip    # build without SZIP support
7 #
8 Summary:        Hierarchical Data Format 5 library
9 Summary(pl):    Biblioteka HDF5 (Hierarchical Data Format 5)
10 Name:           hdf5
11 Version:        1.6.4
12 Release:        1
13 Group:          Libraries
14 License:        Nearly BSD, but changed sources must be marked
15 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/%{name}-%{version}/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  837de4bb977623e380d3501ab2791f02
17 Patch0:         %{name}-config.patch
18 URL:            http://hdf.ncsa.uiuc.edu/HDF5/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libjpeg-devel >= 6b
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  openssl-devel >= 0.9.7d
25 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
26 BuildRequires:  zlib-devel >= 1.1.3
27 Obsoletes:      hdf5_hl
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 HDF5 is a completely new Hierarchical Data Format product consisting
32 of a data format specification and a supporting library
33 implementation. HDF5 is designed to address some of the limitations of
34 the older HDF product and to address current and anticipated
35 requirements of modern systems and applications.
36
37 %description -l pl
38 HDF5 jest ca³kowicie nowym produktem Hierarchiczego Formatu Danych,
39 sk³adaj±cym siê ze specyfikacji formatu danych oraz obs³uguj±cej go
40 biblioteki. HDF5 zosta³ zaprojektowany aby pozbyæ siê ograniczeñ
41 poprzedniego HDF oraz ¿eby zaspokoiæ bie¿±ce i przysz³e potrzeby
42 wspó³czesnych systemów i aplikacji.
43
44 %package devel
45 Summary:        HDF5 library development package
46 Summary(pl):    Pliki nag³ówkowe biblioteki HDF5
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       openssl-devel
50 %{?with_szip:Requires:  szip-devel >= 2.0}
51 Requires:       zlib-devel
52 Obsoletes:      hdf5_hl-devel
53 Obsoletes:      hdf5_hl-tutor
54
55 %description devel
56 Header files for HDF5 library and HDF5 documentation.
57
58 %description devel -l pl
59 Pliki nag³ówkowe biblioteki HDF5 oraz dokumentacja HDF5.
60
61 %package static
62 Summary:        HDF5 static library
63 Summary(pl):    Statyczna biblioteka HDF5
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Obsoletes:      hdf5_hl-static
67
68 %description static
69 Static version of HDF5 library.
70
71 %description static -l pl
72 Statyczna wersja biblioteki HDF5.
73
74 %package progs
75 Summary:        HDF5 utilities
76 Summary(pl):    Narzêdzia do plików HDF5
77 Group:          Applications/File
78 Requires:       %{name} = %{version}-%{release}
79
80 %description progs
81 Utilities to convert from/to HDF5 format.
82
83 %description progs -l pl
84 Narzêdzia do konwersji z i to formatu HDF5.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 cd c++
95 %{__aclocal}
96 %{__autoconf}
97 cd ..
98 %configure \
99         --enable-cxx \
100         --enable-linux-lfs \
101         --enable-threadsafe \
102         --enable-production \
103         --with-pthread \
104         --with-ssl \
105         %{?with_szip:--with-szlib}
106
107 #       --enable-fortran  - requires Fortran90 compiler
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_includedir}
114
115 %{__make} install \
116         libdir=$RPM_BUILD_ROOT%{_libdir} \
117         includedir=$RPM_BUILD_ROOT%{_includedir} \
118         bindir=$RPM_BUILD_ROOT%{_bindir} \
119         docdir=$RPM_BUILD_ROOT%{_docdir}
120
121 find doc -name Dependencies -o -name Makefile\* | xargs rm -f
122
123 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
124 mv -f $RPM_BUILD_ROOT%{_docdir}/hdf5/examples/{c,c++} \
125         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc COPYING README.txt release_docs/{HISTORY.txt,RELEASE.txt}
136 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
137 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
138 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
139 # used to show configuration at runtime
140 %{_libdir}/libhdf5.settings
141 %{_libdir}/libhdf5_cpp.settings
142
143 %files devel
144 %defattr(644,root,root,755)
145 %doc doc/html
146 %attr(755,root,root) %{_libdir}/libhdf5.so
147 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
148 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
149 %{_libdir}/libhdf5.la
150 %{_libdir}/libhdf5_cpp.la
151 %{_libdir}/libhdf5_hl.la
152 %{_includedir}/*.h
153 %{_examplesdir}/%{name}-%{version}
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libhdf5.a
158 %{_libdir}/libhdf5_cpp.a
159 %{_libdir}/libhdf5_hl.a
160
161 %files progs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/*
This page took 0.102368 seconds and 4 git commands to generate.