]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- updated am/lt BRs
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - build with MPICH
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_without  szip    # build without SZIP support
7 #
8 Summary:        Hierarchical Data Format 5 library
9 Summary(pl.UTF-8):      Biblioteka HDF5 (Hierarchical Data Format 5)
10 Name:           hdf5
11 Version:        1.8.7
12 Release:        1
13 License:        Nearly BSD, but changed sources must be marked
14 Group:          Libraries
15 Source0:        ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  37711d4bcb72997e93d495f97c76c33a
17 Patch0:         %{name}-config.patch
18 Patch1:         %{name}-sig.patch
19 Patch2:         %{name}-link.patch
20 URL:            http://www.hdfgroup.org/HDF5/
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  libjpeg-devel >= 6b
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:2.2
26 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
27 BuildRequires:  zlib-devel >= 1.1.3
28 Obsoletes:      hdf5_hl
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 HDF5 is a completely new Hierarchical Data Format product consisting
33 of a data format specification and a supporting library
34 implementation. HDF5 is designed to address some of the limitations of
35 the older HDF product and to address current and anticipated
36 requirements of modern systems and applications.
37
38 %description -l pl.UTF-8
39 HDF5 jest całkowicie nowym produktem Hierarchiczego Formatu Danych,
40 składającym się ze specyfikacji formatu danych oraz obsługującej go
41 biblioteki. HDF5 został zaprojektowany aby pozbyć się ograniczeń
42 poprzedniego HDF oraz żeby zaspokoić bieżące i przyszłe potrzeby
43 współczesnych systemów i aplikacji.
44
45 %package devel
46 Summary:        HDF5 library development package
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %{?with_szip:Requires:  szip-devel >= 2.0}
51 Requires:       zlib-devel
52 Obsoletes:      hdf5_hl-devel
53 Obsoletes:      hdf5_hl-tutor
54
55 %description devel
56 Header files for HDF5 library and HDF5 documentation.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki HDF5 oraz dokumentacja HDF5.
60
61 %package static
62 Summary:        HDF5 static library
63 Summary(pl.UTF-8):      Statyczna biblioteka HDF5
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Obsoletes:      hdf5_hl-static
67
68 %description static
69 Static version of HDF5 library.
70
71 %description static -l pl.UTF-8
72 Statyczna wersja biblioteki HDF5.
73
74 %package c++
75 Summary:        C++ APIs for HDF5
76 Summary(pl.UTF-8):      API C++ bibliotek HDF5
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description c++
81 C++ APIs for HDF5 (both base hdf5 and hdf5_hl).
82
83 %description c++ -l pl.UTF-8
84 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl).
85
86 %package c++-devel
87 Summary:        Header files for HDF5 C++ APIs
88 Summary(pl.UTF-8):      Pliki nagłówkowe API C++ bibliotek HDF5
89 Group:          Development/Libraries
90 Requires:       %{name}-c++ = %{version}-%{release}
91 Requires:       %{name}-devel = %{version}-%{release}
92 Requires:       libstdc++-devel
93
94 %description c++-devel
95 Header files for HDF5 C++ APIs (both base hdf5 and hdf5_hl).
96
97 %description c++-devel -l pl.UTF-8
98 Pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej hdf5, jak
99 i hdf5_hl).
100
101 %package c++-static
102 Summary:        C++ APIs for HDF5 - static libraries
103 Summary(pl.UTF-8):      API C++ bibliotek HDF5 - biblioteki statyczne
104 Group:          Development/Libraries
105 Requires:       %{name}-c++-devel = %{version}-%{release}
106
107 %description c++-static
108 C++ APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
109
110 %description c++-static -l pl.UTF-8
111 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl) -
112 biblioteki statyczne.
113
114 %package progs
115 Summary:        HDF5 utilities
116 Summary(pl.UTF-8):      Narzędzia do plików HDF5
117 Group:          Applications/File
118 Requires:       %{name} = %{version}-%{release}
119
120 %description progs
121 Utilities to convert from/to HDF5 format.
122
123 %description progs -l pl.UTF-8
124 Narzędzia do konwersji z i to formatu HDF5.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131
132 %build
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --docdir=%{_docdir} \
140         --disable-silent-rules \
141         --enable-cxx \
142         --enable-linux-lfs \
143         --enable-production \
144         --with-pthread \
145         %{?with_szip:--with-szlib}
146
147 #       --enable-threadsafe is incompatible with cxx/fortran
148 #       --enable-fortran  - requires Fortran90 compiler
149
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT%{_includedir}
155
156 %{__make} install-recursive \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
160 %{__make} -C examples install-examples \
161         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
162         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
163 %{__make} -C c++/examples install-examples \
164         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c++
165 %{__make} -C hl/examples install-examples \
166         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c \
167         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
168 %{__make} -C hl/c++/examples install-examples \
169         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c++
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %post   c++ -p /sbin/ldconfig
178 %postun c++ -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc COPYING README.txt release_docs/{HISTORY*.txt,RELEASE.txt}
183 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libhdf5.so.7
185 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl.so.7
187 # used to show configuration at runtime
188 %{_libdir}/libhdf5.settings
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/h5cc
193 %attr(755,root,root) %{_libdir}/libhdf5.so
194 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
195 %{_libdir}/libhdf5.la
196 %{_libdir}/libhdf5_hl.la
197 %{_includedir}/H5ACpublic.h
198 %{_includedir}/H5Apublic.h
199 %{_includedir}/H5Cpublic.h
200 %{_includedir}/H5DSpublic.h
201 %{_includedir}/H5Dpublic.h
202 %{_includedir}/H5Epubgen.h
203 %{_includedir}/H5Epublic.h
204 %{_includedir}/H5FDcore.h
205 %{_includedir}/H5FDdirect.h
206 %{_includedir}/H5FDfamily.h
207 %{_includedir}/H5FDlog.h
208 %{_includedir}/H5FDmpi.h
209 %{_includedir}/H5FDmpio.h
210 %{_includedir}/H5FDmpiposix.h
211 %{_includedir}/H5FDmulti.h
212 %{_includedir}/H5FDpublic.h
213 %{_includedir}/H5FDsec2.h
214 %{_includedir}/H5FDstdio.h
215 %{_includedir}/H5Fpublic.h
216 %{_includedir}/H5Gpublic.h
217 %{_includedir}/H5IMpublic.h
218 %{_includedir}/H5Include.h
219 %{_includedir}/H5Ipublic.h
220 %{_includedir}/H5LTpublic.h
221 %{_includedir}/H5Lpublic.h
222 %{_includedir}/H5MMpublic.h
223 %{_includedir}/H5Opublic.h
224 %{_includedir}/H5PTpublic.h
225 %{_includedir}/H5Ppublic.h
226 %{_includedir}/H5Rpublic.h
227 %{_includedir}/H5Spublic.h
228 %{_includedir}/H5TBpublic.h
229 %{_includedir}/H5Tpublic.h
230 %{_includedir}/H5Zpublic.h
231 %{_includedir}/H5api_adpt.h
232 %{_includedir}/H5overflow.h
233 %{_includedir}/H5pubconf.h
234 %{_includedir}/H5public.h
235 %{_includedir}/H5version.h
236 %{_includedir}/hdf5.h
237 %{_includedir}/hdf5_hl.h
238 %dir %{_examplesdir}/%{name}-%{version}
239 %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
240 %{_examplesdir}/%{name}-%{version}/c
241 %dir %{_examplesdir}/%{name}-%{version}/hl
242 %{_examplesdir}/%{name}-%{version}/hl/run-hl-ex.sh
243 %{_examplesdir}/%{name}-%{version}/hl/c
244
245 %files static
246 %defattr(644,root,root,755)
247 %{_libdir}/libhdf5.a
248 %{_libdir}/libhdf5_cpp.a
249 %{_libdir}/libhdf5_hl.a
250 %{_libdir}/libhdf5_hl_cpp.a
251
252 %files c++
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
255 %attr(755,root,root) %ghost %{_libdir}/libhdf5_cpp.so.7
256 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so.*.*.*
257 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_cpp.so.7
258
259 %files c++-devel
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_bindir}/h5c++
262 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
263 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so
264 %{_libdir}/libhdf5_cpp.la
265 %{_libdir}/libhdf5_hl_cpp.la
266 %{_includedir}/H5AbstractDs.h
267 %{_includedir}/H5ArrayType.h
268 %{_includedir}/H5AtomType.h
269 %{_includedir}/H5Attribute.h
270 %{_includedir}/H5Classes.h
271 %{_includedir}/H5CommonFG.h
272 %{_includedir}/H5CompType.h
273 %{_includedir}/H5Cpp.h
274 %{_includedir}/H5CppDoc.h
275 %{_includedir}/H5DataSet.h
276 %{_includedir}/H5DataSpace.h
277 %{_includedir}/H5DataType.h
278 %{_includedir}/H5DcreatProp.h
279 %{_includedir}/H5DxferProp.h
280 %{_includedir}/H5EnumType.h
281 %{_includedir}/H5Exception.h
282 %{_includedir}/H5FaccProp.h
283 %{_includedir}/H5FcreatProp.h
284 %{_includedir}/H5File.h
285 %{_includedir}/H5FloatType.h
286 %{_includedir}/H5Group.h
287 %{_includedir}/H5IdComponent.h
288 %{_includedir}/H5IntType.h
289 %{_includedir}/H5Library.h
290 %{_includedir}/H5Object.h
291 %{_includedir}/H5PacketTable.h
292 %{_includedir}/H5PredType.h
293 %{_includedir}/H5PropList.h
294 %{_includedir}/H5StrType.h
295 %{_includedir}/H5VarLenType.h
296 %{_examplesdir}/%{name}-%{version}/c++
297 %{_examplesdir}/%{name}-%{version}/hl/c++
298
299 %files progs
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_bindir}/gif2h5
302 %attr(755,root,root) %{_bindir}/h52gif
303 %attr(755,root,root) %{_bindir}/h5copy
304 %attr(755,root,root) %{_bindir}/h5debug
305 %attr(755,root,root) %{_bindir}/h5diff
306 %attr(755,root,root) %{_bindir}/h5dump
307 %attr(755,root,root) %{_bindir}/h5import
308 %attr(755,root,root) %{_bindir}/h5jam
309 %attr(755,root,root) %{_bindir}/h5ls
310 %attr(755,root,root) %{_bindir}/h5mkgrp
311 %attr(755,root,root) %{_bindir}/h5perf_serial
312 %attr(755,root,root) %{_bindir}/h5redeploy
313 %attr(755,root,root) %{_bindir}/h5repack
314 %attr(755,root,root) %{_bindir}/h5repart
315 %attr(755,root,root) %{_bindir}/h5stat
316 %attr(755,root,root) %{_bindir}/h5unjam
This page took 0.11664 seconds and 3 git commands to generate.