]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- perl -pi -e "s/^libtoolize --copy --force/\%\{__libtoolize\}/"
[packages/hdf5.git] / hdf5.spec
1 Summary:        Hierarchical Data Format 5 library
2 Summary(pl):    Biblioteka HDF5 (Hierarchical Data Format 5)
3 Name:           hdf5
4 %define _ver    1.4.2
5 %define _patch  patch1
6 Version:        %{_ver}%{_patch}
7 Release:        2
8 Group:          Libraries
9 License:        Nearly BSD, but changed sources must be marked
10 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/%{name}-%{_ver}-%{_patch}/src/%{name}-%{_ver}-%{_patch}.tar.gz
11 Patch0:         %{name}-config.patch
12 Patch1:         %{name}-hdf4link.patch
13 Patch2:         %{name}-acfix.patch
14 URL:            http://hdf.ncsa.uiuc.edu/
15 BuildRequires:  zlib-devel >= 1.1.3
16 BuildRequires:  openssl-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libjpeg-devel >= 6b
19 BuildRequires:  hdf-devel >= 4.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 HDF5 is a completely new Hierarchical Data Format product consisting
27 of a data format specification and a supporting library
28 implementation. HDF5 is designed to address some of the limitations of
29 the older HDF product and to address current and anticipated
30 requirements of modern systems and applications.
31
32 %description -l pl
33 HDF5 jest ca³kowicie nowym produktem Hierarchiczego Formatu Danych,
34 sk³adaj±cym siê ze specyfikacji formatu danych oraz obs³uguj±cej go
35 biblioteki. HDF5 zosta³ zaprojektowany aby pozbyæ siê ograniczeñ
36 poprzedniego HDF oraz ¿eby zaspokoiæ bie¿±ce i przysz³e potrzeby
37 wspó³czesnych systemów i aplikacji.
38
39 %package devel
40 Summary:        HDF5 library development package
41 Summary(pl):    Pliki nag³ówkowe biblioteki HDF5
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}
44
45 %description devel
46 Header files for HDF5 library and HDF5 documentation.
47
48 %description devel -l pl
49 Pliki nag³ówkowe biblioteki HDF5 oraz dokumentacja HDF5.
50
51 %package static
52 Summary:        HDF5 static library
53 Summary(pl):    Statyczna biblioteka HDF5
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}
56
57 %description static
58 Static version of HDF5 library.
59
60 %description static -l pl
61 Statyczna wersja biblioteki HDF5.
62
63 %package progs
64 Summary:        HDF5 utilities
65 Summary(pl):    Narzêdzia do plików HDF5
66 Group:          Applications/File
67 Requires:       %{name} = %{version}
68
69 %description progs
70 Utilities to convert from/to HDF5 format.
71
72 %description progs -l pl
73 Narzêdzia do konwersji z i to formatu HDF5.
74
75 %package hdf4
76 Summary:        HDF 4.x to/from HDF5 conversion tools
77 Summary(pl):    Narzêdzia do konwersji pomiêdzy HDF 4.x i HDF5
78 Group:          Applications/File
79 Requires:       %{name} = %{version}
80
81 %description hdf4
82 Utilities to convert files from HDF 4.x to HDF5 or from HDF5 to HDF
83 4.x format.
84
85 %description hdf4 -l pl
86 Narzêdzia do konwersji plików z formatu HDF 4.x do HDF5 oraz z HDF5 do
87 HDF 4.x.
88
89 %prep
90 %setup -q -n %{name}-%{_ver}-%{_patch}
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %build
96 %{__libtoolize}
97 aclocal
98 %{__autoconf}
99 (cd c++ ; aclocal ; autoconf)
100 %configure \
101         --enable-cxx \
102         --with-hdf4=/usr/include/hdf
103
104 #       --enable-fortran  - requires Fortran90 compiler
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_includedir}
111
112 %{__make} install \
113         libdir=$RPM_BUILD_ROOT%{_libdir} \
114         includedir=$RPM_BUILD_ROOT%{_includedir} \
115         bindir=$RPM_BUILD_ROOT%{_bindir}
116
117 find doc -name Dependencies -o -name Makefile\* | xargs rm -f
118
119 gzip -9nf COPYING README.txt release_docs/{HISTORY.txt,RELEASE.txt}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc *.gz release_docs/*.gz
130 %attr(755,root,root) %{_libdir}/lib*.so.*.*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc doc/html
135 %attr(755,root,root) %{_libdir}/lib*.so
136 %attr(755,root,root) %{_libdir}/lib*.la
137 %{_includedir}/*
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
142
143 %files progs
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/gif2h5
146 %attr(755,root,root) %{_bindir}/h52gif
147 %attr(755,root,root) %{_bindir}/h5debug
148 %attr(755,root,root) %{_bindir}/h5dump
149 %attr(755,root,root) %{_bindir}/h5import
150 %attr(755,root,root) %{_bindir}/h5ls
151 %attr(755,root,root) %{_bindir}/h5repart
152
153 %files hdf4
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/h4toh5
156 %attr(755,root,root) %{_bindir}/h5toh4
This page took 0.052976 seconds and 3 git commands to generate.