]> git.pld-linux.org Git - SPECS.git/blob - hdf-eos5.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / hdf-eos5.spec
1 #
2 # Conditional build:
3 %bcond_without  szip            # SZIP support (must match hdf build bcond)
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        HDF-EOS 5 library
7 Summary(pl.UTF-8):      Biblioteka HDF-EOS 5
8 Name:           hdf-eos5
9 Version:        5.1.16
10 Release:        1
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        https://observer.gsfc.nasa.gov/ftp/edhs/hdfeos5/latest_release/HDF-EOS%{version}.tar.Z
14 # Source0-md5:  c4a3286f38a2faafc840017af4bd39d6
15 # needed for auto* rebuild
16 Source1:        https://observer.gsfc.nasa.gov/ftp/edhs/hdfeos5/latest_release/HDF-EOS%{version}_TESTDRIVERS.tar.Z
17 # Source1-md5:  498ca8c6634c391d38e126450d8d218d
18 Patch0:         %{name}-cc.patch
19 Patch1:         %{name}-link.patch
20 Patch2:         %{name}-tests.patch
21 Patch3:         %{name}-types.patch
22 Patch4:         %{name}-bufsize.patch
23 URL:            http://hdfeos.org/software/library.php#HDF-EOS5
24 BuildRequires:  autoconf >= 2.59
25 BuildRequires:  automake
26 BuildRequires:  hdf5-devel >= 1.8.19
27 BuildRequires:  libtool
28 %{?with_szip:BuildRequires:     szip-devel >= 2.1.1}
29 BuildRequires:  zlib-devel
30 Requires:       hdf5 >= 1.8.19
31 %{?with_szip:Requires:  szip >= 2.1.1}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 HDF-EOS is a software library designed to support EOS-specific data
36 structures, namely Grid, Point, and Swath. The new data structures are
37 constructed from standard HDF data objects, using EOS conventions,
38 through the use of a software library. A key feature of HDF-EOS files
39 is that instrument-independent services, such as subsetting by
40 geolocation, can be applied to the files across a wide variety of data
41 products. The library is extensible and new data structures can be
42 added.
43
44 %description -l pl.UTF-8
45 HDF-EOS to biblioteka programowa zaprojektowana w celu obsługi
46 struktur danych związanych z EOS, takich jak Grid, Point i Swath. Nowe
47 struktury danych są tworzone z obiektów danych HDF, przy użyciu
48 konwencji EOS, poprzez bibliotekę programową. Kluczową cechą plików
49 HDF-EOS jest to, że usługi niezależne od przyrządu, takie jak na
50 przykład podział według geolokalizacji, można wykonywać na plikach
51 zawierających różnorodne zbiory danych. Biblioteka jest rozszerzalna i
52 pozwala na dodawanie nowych struktur danych.
53
54 %package devel
55 Summary:        Header files for HDF-EOS 5 library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF-EOS 5
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       hdf5-devel >= 1.8.19
60 %{?with_szip:Requires:  szip-devel >= 2.1.1}
61 Requires:       zlib-devel
62
63 %description devel
64 Header files for HDF-EOS 5 library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki HDF-EOS 5.
68
69 %package static
70 Summary:        Static HDF-EOS 5 library
71 Summary(pl.UTF-8):      Statyczna biblioteka HDF-EOS 5
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static HDF-EOS 5 library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka HDF-EOS 5.
80
81 %prep
82 %setup -q -n hdfeos5 -b1
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p1
87 %patch4 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 CPPFLAGS="%{rpmcppflags} -DH5_USE_16_API"
96 # hdf5 installs in plain /usr/include, but we want to isolate headers
97 # from system include dir (hdf-eos2 uses the same filenames)
98 %configure \
99         --includedir=%{_includedir}/he5 \
100         --enable-install-include \
101         --enable-shared \
102         %{?with_szip:--with-szlib}
103
104 %{__make}
105
106 # note: random failures occur when tests are executed in parallel, so use -j1
107 %{?with_tests:%{__make} -j1 check}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc doc/{HDFEOS-DEFINITION.TXT,README}
124 %attr(755,root,root) %{_libdir}/libhe5_Gctp.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libhe5_Gctp.so.0
126 %attr(755,root,root) %{_libdir}/libhe5_hdfeos.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libhe5_hdfeos.so.0
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libhe5_Gctp.so
132 %attr(755,root,root) %{_libdir}/libhe5_hdfeos.so
133 %{_libdir}/libhe5_Gctp.la
134 %{_libdir}/libhe5_hdfeos.la
135 %dir %{_includedir}/he5
136 %{_includedir}/he5/HE5_GctpFunc.h
137 %{_includedir}/he5/HE5_HdfEosDef.h
138 %{_includedir}/he5/HE5_config.h
139 %{_includedir}/he5/bcea.h
140 %{_includedir}/he5/cfortHdf.h
141 %{_includedir}/he5/cproj.h
142 %{_includedir}/he5/cproj_prototypes.h
143 %{_includedir}/he5/ease.h
144 %{_includedir}/he5/gctp_prototypes.h
145 %{_includedir}/he5/isin.h
146 %{_includedir}/he5/proj.h
147 %{_includedir}/he5/tutils.h
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libhe5_Gctp.a
152 %{_libdir}/libhe5_hdfeos.a
This page took 0.265627 seconds and 3 git commands to generate.