]> git.pld-linux.org Git - SPECS.git/blob - hdf-eos.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / hdf-eos.spec
1 #
2 # Conditional build:
3 %bcond_without  szip            # SZIP support (must match hdf build bcond)
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        HDF-EOS 2 library
7 Summary(pl.UTF-8):      Biblioteka HDF-EOS 2
8 Name:           hdf-eos
9 Version:        2.20.1.00
10 Release:        1
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        https://observer.gsfc.nasa.gov/ftp/edhs/hdfeos/latest_release/HDF-EOS2.20v1.00.tar.Z
14 # Source0-md5:  4697174a9296aa3d921915b75b3362d1
15 # needed for auto* rebuild
16 Source1:        https://observer.gsfc.nasa.gov/ftp/edhs/hdfeos/latest_release/HDF-EOS2.20v1.00_TestDriver.tar.Z
17 # Source1-md5:  c15028e666f0f7c794edba529af8e158
18 Patch0:         %{name}-cc.patch
19 Patch1:         %{name}-link.patch
20 Patch2:         stack-overuse.patch
21 URL:            http://hdfeos.org/software/library.php#HDF-EOS2
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake
24 BuildRequires:  hdf-devel >= 4.2.13
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libtool
27 %{?with_szip:BuildRequires:     szip-devel}
28 BuildRequires:  zlib-devel >= 1.2.11
29 Requires:       hdf >= 4.2.13
30 Requires:       zlib >= 1.2.11
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 HDF-EOS is a software library designed to support EOS-specific data
35 structures, namely Grid, Point, and Swath. The new data structures are
36 constructed from standard HDF data objects, using EOS conventions,
37 through the use of a software library. A key feature of HDF-EOS files
38 is that instrument-independent services, such as subsetting by
39 geolocation, can be applied to the files across a wide variety of data
40 products. The library is extensible and new data structures can be
41 added.
42
43 %description -l pl.UTF-8
44 HDF-EOS to biblioteka programowa zaprojektowana w celu obsługi
45 struktur danych związanych z EOS, takich jak Grid, Point i Swath. Nowe
46 struktury danych są tworzone z obiektów danych HDF, przy użyciu
47 konwencji EOS, poprzez bibliotekę programową. Kluczową cechą plików
48 HDF-EOS jest to, że usługi niezależne od przyrządu, takie jak na
49 przykład podział według geolokalizacji, można wykonywać na plikach
50 zawierających różnorodne zbiory danych. Biblioteka jest rozszerzalna i
51 pozwala na dodawanie nowych struktur danych.
52
53 %package devel
54 Summary:        Header files for HDF-EOS 2 library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF-EOS 2
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       hdf-devel >= 4.2.13
59 Requires:       libjpeg-devel
60 %{?with_szip:Requires:  szip-devel}
61 Requires:       zlib-devel >= 1.2.11
62
63 %description devel
64 Header files for HDF-EOS 2 library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki HDF-EOS 2.
68
69 %package static
70 Summary:        Static HDF-EOS 2 library
71 Summary(pl.UTF-8):      Statyczna biblioteka HDF-EOS 2
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static HDF-EOS 2 library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka HDF-EOS 2.
80
81 %prep
82 %setup -q -n hdfeos -b1
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 # as hdf 4 extension, use the same include dir as hdf 4
94 %configure \
95         --includedir=%{_includedir}/hdf \
96         --enable-install-include \
97         --enable-shared \
98         --with-hdf4=%{_includedir}/hdf, \
99         %{?with_szip:--with-szlib}
100
101 %{__make}
102
103 %{?with_tests:%{__make} check}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc doc/{HDFEOS-DEFINITION.TXT,README}
120 %attr(755,root,root) %{_libdir}/libGctp.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libGctp.so.0
122 %attr(755,root,root) %{_libdir}/libhdfeos.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libhdfeos.so.0
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libGctp.so
128 %attr(755,root,root) %{_libdir}/libhdfeos.so
129 %{_libdir}/libGctp.la
130 %{_libdir}/libhdfeos.la
131 %{_includedir}/hdf/HDFEOSVersion.h
132 %{_includedir}/hdf/HE2_config.h
133 %{_includedir}/hdf/HdfEosDef.h
134 %{_includedir}/hdf/bcea.h
135 %{_includedir}/hdf/cfortHdf.h
136 %{_includedir}/hdf/cproj.h
137 %{_includedir}/hdf/cproj_prototypes.h
138 %{_includedir}/hdf/ease.h
139 %{_includedir}/hdf/gctp_prototypes.h
140 %{_includedir}/hdf/isin.h
141 %{_includedir}/hdf/proj.h
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libGctp.a
146 %{_libdir}/libhdfeos.a
This page took 0.888105 seconds and 3 git commands to generate.