]> git.pld-linux.org Git - SPECS.git/blob - happydoc.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / happydoc.spec
1
2 %define         pname HappyDoc
3 %define         ver 2_1
4
5 Summary:        Tool for extracting documentation from Python source code
6 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji ze źródeł programów napisanych w języku Python
7 Name:           happydoc
8 Version:        %(echo %ver | sed 's/_/./g')
9 Release:        3
10 License:        BSD-like
11 Group:          Development/Tools
12 Source0:        http://dl.sourceforge.net/happydoc/%{pname}_r%{ver}.tar.gz
13 # Source0-md5:  7791988bb7498d4281636ab5f5852e67
14 URL:            http://happydoc.sourceforge.net/
15 %pyrequires_eq  python-modules
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 HappyDoc is a tool for extracting documentation from Python source
21 code. It differs from other such applications by the fact that it uses
22 the parse tree for a module to derive the information used in its
23 output, rather that importing the module directly. This allows the
24 user to generate documentation for modules which need special context
25 to be imported.
26
27 %description -l pl.UTF-8
28 HappyDoc jest narzędziem do generowania dokumentacji ze źródeł
29 programów napisanych w języku Python. Program ten, w przeciwności do
30 innych aplikacji tego typu, które muszą uruchomić moduł, analizuje
31 strukturę danego modułu i na jej podstawie tworzy dokumentację.
32 Pozwala to na generowanie dokumentacji dla tych modułów/programów,
33 które muszą być uruchamiane w odpowiednim środowisku.
34
35 %prep
36 %setup  -q -n %{pname}-r%{ver}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir}
42 export PYTHONPATH
43 python ./setup.py install \
44         --optimize=2 \
45         --root=$RPM_BUILD_ROOT
46
47 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py | xargs rm -f
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc *.txt srcdocs/*
55 %attr(755,root,root) %{_bindir}/*
56 %{py_sitescriptdir}/happydoclib
This page took 0.097093 seconds and 3 git commands to generate.