]> git.pld-linux.org Git - packages/happy.git/blob - happy.spec
- copy config.sub to allow build on amd64
[packages/happy.git] / happy.spec
1 Summary:        Yacc-like LALR(1) Parser Generator for Haskell
2 Summary(pl):    Generator parserów LALR(1) w stylu yacc-a dla Haskella
3 Name:           happy
4 Version:        1.14
5 Release:        1
6 License:        BSD w/o adv. clause
7 Group:          Development/Languages
8 URL:            http://haskell.org/happy/
9 Source0:        http://haskell.org/happy/dist/%{version}/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  501b5b63533b2e2838de18085e8c4492
11 Patch0:         %{name}-DESTDIR.patch
12 Patch1:         %{name}-arch.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  ghc
16 BuildRequires:  gmp-devel
17 BuildRequires:  jadetex
18 BuildRequires:  elfutils-libelf
19 BuildRequires:  ncurses-devel
20 BuildRequires:  openjade
21 BuildRequires:  readline-devel
22 BuildRequires:  sgml-common
23 BuildRequires:  tetex-dvips
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Happy is a LALR(1) parser generator for Haskell - similar to yacc for
28 C. It generates a Haskell parser from an annotated BNF specification
29 of a grammar. Happy allows to have several Happy generated parsers in
30 one program.
31
32 %description -l pl
33 Happy jest generatorem parserów LALR(1) dla Haskella - podobnym do
34 yacc-a dla C. Generuje parser w Haskellu ze specyfikacji gramatyki 
35 w notacji BNF. Happy pozwala mieæ wiele wygenerowanych parserów 
36 w jednym programie.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 cp -f /usr/share/automake/config.sub .
45 %{__autoconf}
46 %configure \
47         --with-gcc=%{__cc}
48
49 %{__make} -C glafp-utils sgmlverb mkdirhier all
50 %{__make} -C happy/src depend
51 %{__make} -C happy all
52 %{__make} -C happy/doc html ps
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/happy}
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 cp -a happy/examples/* $RPM_BUILD_ROOT%{_examplesdir}/happy/
62
63 sed -e 's,@LIBDIR@,%{_libdir}/%{name}-%{version},g' \
64         -e 's,@DOCDIR@,%{_docdir}/%{name}-%{version},g' \
65         -e 's,@VERSION@,%{version},g' \
66         happy/doc/happy.1.in > $RPM_BUILD_ROOT%{_mandir}/man1/happy.1
67 ln -sf happy-%{version} $RPM_BUILD_ROOT%{_bindir}/happy
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc happy/README happy/doc/happy.ps happy/doc/happy/*
75 %attr(755,root,root) %{_bindir}/*
76 %dir %{_libdir}/%{name}-%{version}
77 %attr(755,root,root) %{_libdir}/%{name}-%{version}/happy.bin
78 %{_libdir}/%{name}-%{version}/Happy*
79 %{_mandir}/man1/*
This page took 0.087795 seconds and 4 git commands to generate.