]> git.pld-linux.org Git - packages/happy.git/blob - happy.spec
- BR: automake; new %%doc
[packages/happy.git] / happy.spec
1 Summary:        Yacc-like LALR(1) Parser Generator for Haskell
2 Summary(pl):    Generator parserów LALR(1) w stylu yacc-a dla Haskella
3 Name:           happy
4 Version:        1.11
5 Release:        1
6 License:        BSD w/o adv. clause
7 Group:          Development/Languages
8 URL:            http://haskell.org/happy/
9 Source0:        http://haskell.org/happy/dist/%{version}/%{name}-%{version}-src.tar.gz
10 Patch0:         %{name}-sgml-CATALOG.patch
11 Patch1:         %{name}-DESTDIR.patch
12 Patch2:         %{name}-ac.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  ghc
16 BuildRequires:  gmp-devel
17 BuildRequires:  jadetex
18 BuildRequires:  libelf
19 BuildRequires:  ncurses-devel
20 BuildRequires:  openjade
21 BuildRequires:  readline-devel
22 BuildRequires:  sgml-common
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Happy is a LALR(1) parser generator for Haskell - similar to yacc for
27 C. It generates a Haskell parser from an annotated BNF specification
28 of a grammar. Happy allows to have several Happy generated parsers in
29 one program.
30
31 %description -l pl
32 Happy jest generatorem parserów LALR(1) dla Haskella - podobnym do
33 yacc-a dla C. Generuja parser w Haskellu ze specyfikacji gramatyki w
34 notacji BNF. Happy pozwala mieæ wiele wygenerowanych parserów w jednym
35 programie.
36
37 %prep
38 %setup -q
39 #%patch0 -p1
40 %patch1 -p1
41 #%patch2 -p1
42
43 %build
44 chmod u+w configure
45 %{__aclocal}
46 %{__autoconf}
47 chmod u+w configure
48 %configure \
49         --with-gcc=%{__cc}
50
51 %{__make} -C glafp-utils sgmlverb mkdirhier all
52 %{__make} -C happy all
53 %{__make} -C happy/doc html ps
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/happy}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install happy/examples/* $RPM_BUILD_ROOT%{_examplesdir}/happy/
63
64 sed -e 's,@LIBDIR@,%{_libdir}/%{name}-%{version},g' \
65         -e 's,@DOCDIR@,%{_docdir}/%{name}-%{version},g' \
66         -e 's,@VERSION@,%{version},g' \
67         happy/doc/happy.1.in > $RPM_BUILD_ROOT%{_mandir}/man1/happy.1
68 ln -sf happy-%{version} $RPM_BUILD_ROOT%{_bindir}/happy
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc happy/README happy/doc/happy.ps happy/doc/happy/*
76 %attr(755,root,root) %{_bindir}/*
77 %dir %{_libdir}/%{name}-%{version}
78 %dir %{_libdir}/%{name}-%{version}/happy
79 %attr(755,root,root) %{_libdir}/%{name}-%{version}/happy.bin
80 %{_libdir}/%{name}-%{version}/happy/*
81 %{_mandir}/man1/*
This page took 0.286159 seconds and 4 git commands to generate.