]> git.pld-linux.org Git - packages/happy.git/blob - happy.spec
- pl translations, BuildRequires: autoconf
[packages/happy.git] / happy.spec
1 Summary:        Yacc-like LALR(1) Parser Generator for Haskell
2 Summary(pl):    Generator parserów LALR(1) w stylu yacc-a dla Haskella
3 Name:           happy
4 Version:        1.10
5 Release:        2
6 License:        BSD w/o adv. clause
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 URL:            http://haskell.org/happy/
11 Source0:        http://haskell.org/happy/dist/%{version}/%{name}-%{version}-src.tar.gz
12 Patch0:         %{name}-sgml-CATALOG.patch
13 Patch1:         %{name}-DESTDIR.patch
14 Patch2:         %{name}-ac.patch
15 BuildRequires:  autoconf
16 BuildRequires:  ncurses-devel
17 BuildRequires:  readline-devel
18 BuildRequires:  libelf
19 BuildRequires:  gmp-devel
20 BuildRequires:  sgml-common
21 BuildRequires:  openjade
22 BuildRequires:  jadetex
23 BuildRequires:  ghc
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Happy is a LALR(1) parser generator for Haskell - similar to yacc for
28 C. It generates a Haskell parser from an annotated BNF specification
29 of a grammar. Happy allows to have several Happy generated parsers in
30 one program.
31
32 %description -l pl
33 Happy jest generatorem parserów LALR(1) dla Haskella - podobnym do
34 yacc-a dla C. Generuja parser w Haskellu ze specyfikacji gramatyki w
35 notacji BNF. Happy pozwala mieæ wiele wygenerowanych parserów w jednym
36 programie.
37
38 %prep
39 %setup -q
40 #%patch0 -p1
41 %patch1 -p1
42 %patch2 -p1
43
44 %build
45 chmod u+w configure
46 autoconf
47 chmod u+w configure
48 %configure \
49         --libdir=%{_libdir}/happy-%{version}
50
51 %{__make} -C glafp-utils sgmlverb mkdirhier all
52 %{__make} -C happy all
53 %{__make} -C happy/doc html ps
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/happy}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install happy/examples/* $RPM_BUILD_ROOT%{_examplesdir}/happy/
63
64 sed -e 's,@LIBDIR@,%{_libdir}/%{name}-%{version},g' \
65         -e 's,@DOCDIR@,%{_docdir}/%{name}-%{version},g' \
66         -e 's,@VERSION@,%{version},g' \
67         happy/doc/happy.1.in > $RPM_BUILD_ROOT%{_mandir}/man1/happy.1
68 ln -sf happy-1.10 $RPM_BUILD_ROOT%{_bindir}/happy
69
70 gzip -9nf happy/README happy/doc/happy.ps
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc happy/README.gz happy/doc/happy.ps.gz happy/doc/happy/*
78 %attr(755,root,root) %{_bindir}/*
79 %dir %{_libdir}/%{name}-%{version}
80 %dir %{_libdir}/%{name}-%{version}/happy
81 %attr(755,root,root) %{_libdir}/%{name}-%{version}/happy.bin
82 %{_libdir}/%{name}-%{version}/happy/*
83 %{_mandir}/man1/*
This page took 0.101013 seconds and 4 git commands to generate.