]> git.pld-linux.org Git - packages/happy.git/blob - happy.spec
- md5
[packages/happy.git] / happy.spec
1 Summary:        Yacc-like LALR(1) Parser Generator for Haskell
2 Summary(pl):    Generator parserów LALR(1) w stylu yacc-a dla Haskella
3 Name:           happy
4 Version:        1.14
5 Release:        1
6 License:        BSD w/o adv. clause
7 Group:          Development/Languages
8 URL:            http://haskell.org/happy/
9 Source0:        http://haskell.org/happy/dist/%{version}/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  501b5b63533b2e2838de18085e8c4492
11 Patch0:         %{name}-DESTDIR.patch
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  ghc
15 BuildRequires:  gmp-devel
16 BuildRequires:  jadetex
17 BuildRequires:  elfutils-libelf
18 BuildRequires:  ncurses-devel
19 BuildRequires:  openjade
20 BuildRequires:  readline-devel
21 BuildRequires:  sgml-common
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Happy is a LALR(1) parser generator for Haskell - similar to yacc for
26 C. It generates a Haskell parser from an annotated BNF specification
27 of a grammar. Happy allows to have several Happy generated parsers in
28 one program.
29
30 %description -l pl
31 Happy jest generatorem parserów LALR(1) dla Haskella - podobnym do
32 yacc-a dla C. Generuja parser w Haskellu ze specyfikacji gramatyki w
33 notacji BNF. Happy pozwala mieæ wiele wygenerowanych parserów w jednym
34 programie.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 %configure \
42         --with-gcc=%{__cc}
43
44 %{__make} -C glafp-utils sgmlverb mkdirhier all
45 %{__make} -C happy/src depend
46 %{__make} -C happy all
47 %{__make} -C happy/doc html ps
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/happy}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 cp -a happy/examples/* $RPM_BUILD_ROOT%{_examplesdir}/happy/
57
58 sed -e 's,@LIBDIR@,%{_libdir}/%{name}-%{version},g' \
59         -e 's,@DOCDIR@,%{_docdir}/%{name}-%{version},g' \
60         -e 's,@VERSION@,%{version},g' \
61         happy/doc/happy.1.in > $RPM_BUILD_ROOT%{_mandir}/man1/happy.1
62 ln -sf happy-%{version} $RPM_BUILD_ROOT%{_bindir}/happy
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc happy/README happy/doc/happy.ps happy/doc/happy/*
70 %attr(755,root,root) %{_bindir}/*
71 %dir %{_libdir}/%{name}-%{version}
72 %attr(755,root,root) %{_libdir}/%{name}-%{version}/happy.bin
73 %{_libdir}/%{name}-%{version}/Happy*
74 %{_mandir}/man1/*
This page took 0.046271 seconds and 4 git commands to generate.