]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
Update to 0.12.0 (note: new soname)
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.12.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.12/%{name}-%{version}.tar.xz
14 # Source0-md5:  203922473ca4c37dc7fef54b32764b91
15 Patch0:         %{name}-missing.patch
16 Patch1:         %{name}-normalize.patch
17 URL:            https://github.com/GNOME/gxml
18 BuildRequires:  autoconf >= 2.65
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  gettext-tools >= 0.18.1
21 BuildRequires:  glib2-devel >= 1:2.32.0
22 BuildRequires:  gobject-introspection-devel >= 1.32.0
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libgee-devel >= 0.10.5
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libxml2-devel >= 1:2.7
27 BuildRequires:  pkgconfig >= 1:0.21
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  vala >= 2:0.26
31 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
32 BuildRequires:  xz
33 BuildRequires:  yelp-tools
34 Requires:       glib2 >= 1:2.32.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 GXml is a GObject API that wraps around libxml2.
39
40 %description -l pl.UTF-8
41 GXml to API GObject obudowujące libxml2.
42
43 %package devel
44 Summary:        Header files for GXml library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.32.0
49 Requires:       libgee-devel >= 0.10.5
50 Requires:       libxml2-devel >= 1:2.7
51
52 %description devel
53 Header files for GXml library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki GXml.
57
58 %package static
59 Summary:        Static GXml library
60 Summary(pl.UTF-8):      Statyczna biblioteka GXml
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GXml library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka GXml.
69
70 %package -n vala-gxml
71 Summary:        Vala API for GXml library
72 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75 Requires:       vala >= 2:0.26
76 Requires:       vala-libgee >= 0.10.5
77 %if "%{_rpmversion}" >= "5"
78 BuildArch:      noarch
79 %endif
80
81 %description -n vala-gxml
82 Vala API for GXml library.
83
84 %description -n vala-gxml -l pl.UTF-8
85 API języka Vala dla biblioteki GXml.
86
87 %package apidocs
88 Summary:        API documentation for GXml library
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki GXml
90 Group:          Documentation
91
92 %description apidocs
93 API documentation for GXml library.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki GXml.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102
103 %build
104 %{__intltoolize}
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules \
112         %{?with_static_libs:--enable-static} \
113         %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
114 # --enable-devhelp-docs is almost the same as gtk-docs html, but built with valadoc(?) and installed to devhelp dirs
115 # --enable-gir-docs ???
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         gxmlgtkdocdir=%{_gtkdocdir}/gxml
124
125 # obsoleted by pkg-config
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.12.la
127 # packaged as %doc
128 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
129
130 # what a mess... gtk-doc XML intermediate files are installed to html dir...
131 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
132 cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
133
134 # "GXml" gettext domain, "gxml" gnome help
135 %find_lang GXml --with-gnome --all-name
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f GXml.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README
146 %attr(755,root,root) %{_libdir}/libgxml-0.12.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.12.so.12
148 %{_libdir}/girepository-1.0/GXml-0.12.typelib
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libgxml-0.12.so
153 %{_includedir}/gxml-0.12
154 %{_datadir}/gir-1.0/GXml-0.12.gir
155 %{_pkgconfigdir}/gxml-0.12.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libgxml-0.12.a
161 %endif
162
163 %files -n vala-gxml
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/gxml-0.12.deps
166 %{_datadir}/vala/vapi/gxml-0.12.vapi
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/gxml
172 %endif
This page took 0.105936 seconds and 4 git commands to generate.