]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
- updated to 0.20.0 (new API/ABI, switched to meson)
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.20.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  6ee8f2e8f555a76de87cc293dee2106a
15 URL:            https://wiki.gnome.org/GXml
16 BuildRequires:  gettext-tools >= 0.18.1
17 BuildRequires:  glib2-devel >= 1:2.32.0
18 BuildRequires:  gobject-introspection-devel >= 1.32.0
19 BuildRequires:  libgee-devel >= 0.18.0
20 BuildRequires:  libxml2-devel >= 1:2.7
21 BuildRequires:  meson
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig >= 1:0.21
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  vala >= 2:0.34.7
27 %{?with_apidocs:BuildRequires:  valadoc >= 0.30}
28 BuildRequires:  xz
29 BuildRequires:  yelp-tools
30 Requires:       glib2 >= 1:2.32.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 GXml is a GObject API that wraps around libxml2.
35
36 %description -l pl.UTF-8
37 GXml to API GObject obudowujące libxml2.
38
39 %package devel
40 Summary:        Header files for GXml library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       glib2-devel >= 1:2.32.0
45 Requires:       libgee-devel >= 0.18.0
46 Requires:       libxml2-devel >= 1:2.7
47
48 %description devel
49 Header files for GXml library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki GXml.
53
54 %package static
55 Summary:        Static GXml library
56 Summary(pl.UTF-8):      Statyczna biblioteka GXml
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static GXml library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka GXml.
65
66 %package -n vala-gxml
67 Summary:        Vala API for GXml library
68 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71 Requires:       vala >= 2:0.34.7
72 Requires:       vala-libgee >= 0.18.0
73 %if "%{_rpmversion}" >= "4.6"
74 BuildArch:      noarch
75 %endif
76
77 %description -n vala-gxml
78 Vala API for GXml library.
79
80 %description -n vala-gxml -l pl.UTF-8
81 API języka Vala dla biblioteki GXml.
82
83 %package apidocs
84 Summary:        API documentation for GXml library
85 Summary(pl.UTF-8):      Dokumentacja API biblioteki GXml
86 Group:          Documentation
87
88 %description apidocs
89 API documentation for GXml library.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki GXml.
93
94 %prep
95 %setup -q
96
97 %build
98 %if %{with static_libs}
99 %meson build-static \
100         --default-library=static \
101         -Ddocs=false
102
103 %ninja_build -C build-static
104 %endif
105
106 %meson build \
107         --default-library=shared \
108         %{!?with_apidocs:-Ddocs=false}
109
110 %ninja_build -C build
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %if %{with static_libs}
116 %ninja_install -C build-static
117 %endif
118
119 %ninja_install -C build
120
121 %find_lang GXml-0.20
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f GXml-0.20.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS MAINTAINERS NEWS README
132 %attr(755,root,root) %{_libdir}/libgxml-0.20.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.20.so.2
134 %{_libdir}/girepository-1.0/GXml-0.20.typelib
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libgxml-0.20.so
139 %{_includedir}/gxml-0.20
140 %{_datadir}/gir-1.0/GXml-0.20.gir
141 %{_pkgconfigdir}/gxml-0.20.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgxml-0.20.a
147 %endif
148
149 %files -n vala-gxml
150 %defattr(644,root,root,755)
151 %{_datadir}/vala/vapi/gxml-0.20.deps
152 %{_datadir}/vala/vapi/gxml-0.20.vapi
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_datadir}/devhelp/books/GXml-0.20
158 %endif
This page took 0.107312 seconds and 3 git commands to generate.