]> git.pld-linux.org Git - packages/gxine.git/blob - gxine.spec
- release 2 (by relup.sh)
[packages/gxine.git] / gxine.spec
1 #
2 # Conditional build:
3 %bcond_without  lirc    # without LIRC support
4 #
5 Summary:        GTK+ based GUI for xine-libraries
6 Summary(de.UTF-8):      GTK+ basierende grafische Oberfläche für die xine-Bibliotheken
7 Summary(pl.UTF-8):      Oparty na GTK+ graficzny interfejs do bibliotek XINE
8 Name:           gxine
9 Version:        0.5.908
10 Release:        2
11 License:        GPL v2+
12 Group:          X11/Applications/Multimedia
13 Source0:        http://downloads.sourceforge.net/xine/%{name}-%{version}.tar.xz
14 # Source0-md5:  a49618d8d1fdad9e7d15aee4cc5fd15f
15 Patch0:         %{name}-desktop.patch
16 Patch1:         %{name}-plugindir.patch
17 Patch2:         %{name}-link.patch
18 URL:            http://www.xine-project.org/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  dbus-glib-devel >= 0.35
22 BuildRequires:  glib2-devel >= 1:2.10.0
23 BuildRequires:  gtk+2-devel >= 2:2.8.0
24 BuildRequires:  js187-devel
25 BuildRequires:  libtool
26 BuildRequires:  libxcb-devel >= 1.0
27 %{?with_lirc:BuildRequires:     lirc-devel}
28 BuildRequires:  nspr-devel
29 BuildRequires:  pango-devel >= 1:1.12.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.357
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  udev-glib-devel
34 BuildRequires:  xine-lib-devel >= 2:1.1.8
35 BuildRequires:  xorg-lib-libXaw-devel
36 BuildRequires:  xorg-lib-libXext-devel
37 BuildRequires:  xorg-lib-libXinerama-devel
38 BuildRequires:  xorg-lib-libXrandr-devel
39 BuildRequires:  xorg-lib-libXtst-devel
40 BuildRequires:  xz
41 Requires:       glib2 >= 1:2.10.0
42 Requires:       gtk+2 >= 2:2.8.0
43 Requires:       pango >= 1:1.12.0
44 Requires:       xine-lib >= 2:1.1.8
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 xine is a fully-featured free audio/video player for unix-like systems
49 which uses libxine for audio/video decoding and playback. For more
50 informations on what formats are supported, please refer to the
51 libxine documentation. gxine is a GTK+ based GUI for this
52 xine-libraries alternat to xine-ui.
53
54 %description -l de.UTF-8
55 xine ist ein freies Audio- und Video-Abspielprogramm für unixartige
56 Systeme mit umfassenden Funktionen. Zur Audio- und Videodekodierung
57 und Wiedergabe werden die xine-Bibliotheken aus libxine verwendet.
58 Weitere Informationen über die unterstützten Formate entnehmen Sie in
59 der Dokumentation zu libxine. gxine ist eine GTK+ basierende grafische
60 Oberfläche für diese xine-Bibliotheken, alternativ zur xine-ui
61
62 %description -l pl.UTF-8
63 xine to w pełni funkcjonalny wolnodostępny odtwarzacz filmów dla
64 systemów uniksowych, korzystający z libxine do dekodowania i
65 odtwarzania dźwięku i obrazu. Więcej informacji o obsługiwanych
66 formatach można znaleźć w dokumentacji libxine. gxine to graficzny
67 interfejs użytkownika do tych bibliotek, oparty na GTK+, alternatywny
68 dla xine-ui.
69
70 %package -n browser-plugin-gxine
71 Summary:        gxine as browser plugin
72 Summary(pl.UTF-8):      gxine jako wtyczka przeglądarki
73 Group:          X11/Applications/Multimedia
74 Requires(post,postun):  browser-plugins >= 2.0
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       browser-plugins(%{_target_base_arch})
77 Obsoletes:      mozilla-plugin-gxine
78
79 %description -n browser-plugin-gxine
80 gxine as browser plugin.
81
82 %description -n browser-plugin-gxine -l pl.UTF-8
83 gxine jako wtyczka przeglądarki.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 %build
92 %{__gettextize}
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         GSSCMD=/usr/bin/gnome-screensaver-command \
100         XSSCMD=/usr/bin/xscreensaver \
101         %{!?with_lirc:--disable-lirc} \
102         --with-gudev \
103         --without-hal \
104         --with-plugindir=%{_browserpluginsdir} \
105         --with-spidermonkey=/usr/include/js
106
107 # need to use V= because of misc/Makefile.quiet
108 %{__make} \
109         V=1
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         MKDIR_P="mkdir -p" \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
119
120 %find_lang %{name} --all-name
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post -n browser-plugin-gxine
126 %update_browser_plugins
127
128 %postun -n browser-plugin-gxine
129 if [ "$1" = "0" ]; then
130         %update_browser_plugins
131 fi
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS BUGS ChangeLog README TODO
136 %lang(cs) %doc README.cs
137 %lang(de) %doc README.de
138 %attr(755,root,root) %{_bindir}/gxine
139 %attr(755,root,root) %{_bindir}/gxine_client
140 %{_datadir}/gxine
141 %dir %{_sysconfdir}/gxine
142 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gxine/gtkrc
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gxine/startup
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gxine/*.xml
145 %{_desktopdir}/gxine.desktop
146 %{_iconsdir}/hicolor/*/apps/gxine.png
147 %{_pixmapsdir}/gxine.png
148 %{_mandir}/man1/gxine.1*
149 %{_mandir}/man1/gxine_client.1*
150 %lang(de) %{_mandir}/de/man1/gxine.1*
151 %lang(de) %{_mandir}/de/man1/gxine_client.1*
152 %lang(es) %{_mandir}/es/man1/gxine.1*
153 %lang(es) %{_mandir}/es/man1/gxine_client.1*
154
155 %files -n browser-plugin-gxine
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_browserpluginsdir}/gxineplugin.so
This page took 0.069232 seconds and 3 git commands to generate.